Porting Ubuntu Touch (@UBPorts) to tenshi (BQ Aquaris U Plus)



  • Hi Speedy. Maybe you forgotten the reboot to bootloader after flashing recovery an halium-image ? This is the first thing to try. Also maybe was the wrong way to unlock the bootloader. In the last years, i flashed some Uplus to LineAge. Normal unlock via fastboot makes to much problems. Flash was perfect, but the OS shows 180 degrees twisted, like in a mirror. Better way to unlock is the official way via the BQ-Service-Page. You can make a appointment there. BQ will call you back. You need the Model-Number (from the backside of your phone). Say, you need the json-file for your Aquaris Uplus. They will send it via E-Mail. Download the BQ-Flashtool from the same page for Uplus. Install and start it, go to unlock device. In the next step the flashtool aks for the json-file. Add it and go. After unlock disconnect the phone from pc and reboot it while pressing the power long time. Then you can try to install UT again with install recovery. If this way not helpful, take a look to UBports-DEUTSCH group in telegram. There you find me.



  • @malditobastardo @Nandel (sorry for delay in answering) at the moment audio and video playback were fixed. still strugglimg with installing roots in systempart, to comply with UBports-installer and OTA. tenshi works fine and is ready to be a community device



  • @Guf Wow ! Sounds very good. Im surprised. Becaus i didnt belive the Uplus will included to the installer. Uplus is my phone for the future. Thank you so much for your work !!!



  • @Guf Hi Guf... Here is a problem with camera. After start the app, i can change to rear and front camera or video. But if i want to make a photo, the blue circle running in the left upside corner until closing the app. Its not possible to save any photos in to the phone or memory card. Maybe it is a permission error. How can i change the permission via terminal ? Because in system setup i cant give permissions for camera, microphone and location. They are listet, but without function. Please help. Without camera i cant use the phone as daily device. The workaround of @peat_psuwit brings a test view like a television test view in the camera display. This test view can save as a photo, but nothing more.



  • @Nandel Unfortunately this was caused by changes from main developer, @peat_psuwit (not to blame him at all, rather to /praise him for great work), to gs-droid and other packages from rootfs.img. I could not retrieve previous configuration and package version, since they are update continuously in rootfs images.
    I will try to find a work-around or test for new solution soon.
    Sorry, no clue at the moment



  • Quick couple of questions
    Has anyone tried this yet with the installer and whats it like as a dd compared to say the OP3. Thanks



  • @Lakotaubp it's a long time i have struggled to turn it OTA ready (as to get it booting from systempart). I got it once, but in a couple of hours it crashed and i was not able to repeate it anymore.
    I tried to dd rootfs (with system.img inside) as well to cp it to /dev/mmcblk0p24, but somehow it fails to boot from this partition



  • @Guf Thanks for the reply. I am getting one for next to nothing 🙂 So what is the best way to install UT? Do the instructions above still apply or have things altered.



  • @Lakotaubp by using halium-install to install it on datapart (data partition), it works really fine as I have used and tested it myself, as daily driver, for some months.
    I am sharing important stuff with you:
    rootfs
    system.img
    and halium-boot without OTA-compatibility (at the moment)
    To install these three, you need to exec:

    adb push name_of_rootfs.img /data/rootfs.img && adb push name_of_system.img /data/system.img
    

    once you are in TWRP (and previously unlocked the bootloader).
    Then, you reboot to bootloader and execute:

    sudo fastboot flash boot name_of_halium-boot.img && sudo fastboot reboot
    

    Wait for some seconds and you should get UT spinner running.
    I give you the rootfs.img because with this img also camera works, and recently hands-free speakers too.



  • @Guf Thanks should have it by the weekend, then just need to find the time. Will download the bits and get ready. Thanks again.



  • @Guf said in Porting Ubuntu Touch (@UBPorts) to tenshi (BQ Aquaris U Plus):

    To install these three, you need to exec:

    Is there a need to clear and format partitions as on OP3. First attempt reboots to powered by android screen and stops there.



  • @Guf All sorted I have UBports up and running just need to add accounts and take it for a run. Thanks again. This is a nice size phone.

    Edit: During setup I was not asked to set a password, so how do I get past the lock screen without going through it all again phablet does not work.
    Edit 2: Double checked and reinstalled and no request for password setup. Language setup, wifi, device name and location and then into OS. So without password can't change setting or use UTTweakTool.



  • @Lakotaubp password is 1234



  • @Guf 🙄doh. How to feel very silly. Must have tried every combination of everything but 1234. Still plenty of time to get it set up now. Thanks.



  • @Guf Thanks again for this and yes I did miss the code right at the top of this thread as well 😞 Still have most things set and and working during the weekend, so going to use it all day today. Still need to get camera going but that will be down to me again prob rushing. Battery life seems to be very good compared to OPO and OP3. Couple of quick thing if I may first, MTP. Uplus shows up as a wired connection Network on laptop but that's all except when in TWRP recovery when adb works. Is that correct, and the current status of the finger print sensor. How is that going.
    Again thanks for all the work on this. It's a nice size of phone for me and it's really quick on UT again compared to OP3. This is my first halium ported device (that keeps TWRP) so all new to me.



  • Couple more things just to check. Latest version of uNav not picking up GPS or asking for permission to do so, anyone else with this. Also installed indicator weather and on reboot lomiri (unity8) reported a missing file. So reinstalled everything and now time and date is not setting other than to Madrid. Did this last time then suddenly worked so going to keep trying as seen this elsewhere.
    Still can't sort camera, just blank screen but overly bothered by that yet.



  • @Lakotaubp

    sudo dpkg-reconfigure tzdata
    

    in order to set you time zone properly.
    GPS should work with uNav, but you need to be outside your house for the first attempt and it might need 15 min to get connection.
    Regarding Lomiri with missing file, this is a known issue (that you can experience in other device), so please try an older edge rootfs.img or devel one.
    Camera is working with older version (3.1.0) but the issue came from rootfs packages, rather than from camera-app itself. I noticed that with my available rootfs.img it works on 2GB/16GB model, but not woth 3GB/32GB ... that's weird, isn't it?
    Still working on MTP, maybe it doesn't work because it hasn't still activated CONFIGFS, need to investigate.
    Yesterday I again experienced booting from /systempart, so I was focused on OTA-compliance because it will be the big step further to promote tenshi as community dev.
    If you want to try it, go to twpr:

    guf@GufBookPro:/media/gufdata/halium-7.1$ adb shell
    # mount /dev/block/mmcblk0p24 /tmp/
    # mount -o loop /data/rootfs.img /mnt/
    # cp -a /mnt/* /tmp/ && cp /data/system.img /tmp/var/lib/lxc/android/system.img && sync && umount /tmp && umount /mnt && sync && reboot
    

    Then, stop and go to bootloader and execute:

    guf@GufBookPro:/media/gufdata/halium-7.1$ sudo fastboot flash boot halium-boot.img && sudo fastboot reboot 
    

    (please, use the following halium-boot_tenshi_systempart.img



  • @Guf Thanks for the reply. uNav worked till the update the other day then stopped, which seemed odd. Weird issues with cameras I'm used to with the OP3 and OP3T. Still really enjoying this device so time to try your other stuff this weekend. Thanks again.


Log in to reply