Continuation of rpi effort and how to test

  • Would the approach taken here (with Gentoo running arm64 including camera, sound and display) work for us or is it too far from the way UT works?

  • There has been a lot going on but it is only recorded in the Telegram group.
    The Pi3 is working fairly well (with swap) although sound and wifi are still issues and selection (without a touch screen) has its peculiarities. Morph browser and Dekko email seem pretty stable, Terminal works a treat for installing click packages built for Arm64. Running update and upgrade mostly brings improvements but might break it so consider making a backup.

    Here is what is in the Telegram pinned post:
    Installing Ubuntu touch is pretty easy. The default login is phablet as is the password. It should just login itself but you will need that when using the terminal for things requiring sudo or when changing some settings in the GUI. If you can use an ethernet cable at the setup stage it avoids any wifi issues (that are being worked on). Selection by mouse is a bit buggy still, sometimes selecting with "Tab" then hitting "Return" will be easier.

    Download an image from

    After image #90 (15th December) there was a change which meant that the Pi 4 graphics were broken not just on windows but on the login screen (it works but you can't see that it works on a monitor) - keep trying newer images as that will eventually be fixed. This is not a problem for the Pi 3.
    Feel free to experiment with newer images and let us know your experiences but there may not be someone else to compare notes with yet.

    Flash SD card:
    Use DD in the Linux terminal or on windows to write the image to the sd card once you have unzipped it. Raspberry Pi sites will give details of how to do all this.
    Remember to expand the main partition to fill the card. Easiest to use a card no bigger than 32GB.

    It works better with swap. Type sudo apt-get install dc dphys-swapfile in the terminal if you want a swap partition of 2GB

    Development: and the multiple deb packages that are used are built on with the source on

    Apps: is a good place to start when looking for arm64 apps and how to install and test them.
    Some of the arm64 apps being tested for the pinephone and other arm64 devices work, others just shut down or behave oddly. Openstore is getting more arm64 architecture apps.

    Sound is not sorted yet and neither is the Pi camera. However the Pi touchscreen works. Expect bugs and crashes - we are at an early stage. Probably more Alpha than Beta testing but things are developing quickly. Wifi pretends to work but ethernet works well. Have fun and please use the UBports forums, Github or associated Telegram groups to learn more, to give feedback or to help solve bugs or other issues.

  • Hi @Mark
    I'm not sure what I'm doing wrong:

    I wget
    I flashed it onto an 16GB SD card (which is formatted with Disks) using Etcher.

    But my Pi 3 just flashes the green light 7 times, repeatedly...

    😕 I really would like to try UT on Pi.

  • @3arn0wl Possibly you just need to redo the SD card. Did you unzip the image before writing it? After writing the card did you expand the root partition into the unallocated space and did you use a beefed up power supply and connect up an Ethernet cable when trying to boot?
    Seven blinks suggests that the kernel image is not found.
    I've never used Etcher.

  • @3arn0wl the Telegram group is often the quickest place to get help:

  • @Mark

    Aha! Thank you for the pointers! I will have another go in a while.

    What software do I need to make the root partition bigger? I can't seem to do it with Disks.

  • @3arn0wl I use Gparted. Easy to do when the SD card is in another computer (or in a USB card reader attached to the Pi running Raspian) and you can therefore unmount the partitions to edit them. Good luck.

  • 🙂 Thanks for that, @Mark

  • I've tried image 117 and it seems to work as well on the Pi 3B+ as 95. It still has many of the same issues (wifi, selection and audio). Rodney helped fix the bug where the swipe tutorial covers the screen but won't disappear (because you can't swipe like on the phones).
    If you only have a touchscreen and you find your view is getting blocked by the first run tutorial then edit /var/lib/AccountsService/users/phablet so that the line starting DemoEdgesCompleted reads DemoEdgesCompleted=[‘left’, ‘top’, ‘right’, ‘left-long’]
    You can do this via ssh or (with difficulty) in the terminal squinting through the tutorial screen.
    If you have an hdmi monitor and connect to that it should open in desktop mode and after that it will be fine in the touchscreen next time it is run.
    The Super-a Key opens the launcher just like on Gnome.

  • v44 : no graphic mode available

    v66 : Desktop displayed but application graphical garbage

    v77 : no graphical display at all (black screen)

    v137 :

    • desktop display garbage,
    • resolution seems to change 2 times,
    • black screen after some seconds then HDMI disconnected,
    • able to retrieve HDMI with Shift Key and TV re-selection

    Is there a way to use this with a RPI4 4GB ???


    Following after some seconds
    Stable before black screen

  • Nobody knows ?
    Am I the only one to try with a PI4B 4GB ?

  • @Pulsar33 Several of us have a Pi 4 (mine is also 4Gb) but until someone (who knows how) can put in the work needed to get the tiling vs Unity8 problem fixed we can't get very far. However the more bugs and issues we can identify and fix on the Pi 3 in the meantime the better the Pi 4 experience will be when it comes.

  • On Pi 3 with touchscreen it starts without an external keyboard or mouse. The bug where you needed to unplug the mouse and plug it in again was fixed a long timealreadyThere are still niggling selection problems but lots of improvements. Good choice on the Openstore (though some apps still use oxide and ubuntu.web and they will need to be updated to work on the Pi). For me Dekko, Morph, TELEports, Openstore, Terminal, UT Tweak Tool, Document Viewer and many more work well already.

  • @Mark thank you for the answer

    I'm not able to look in the code, sorry. But when I look at the two pictures below, it's clear that v66 was able to display the background, the menu and the notifications as well as the window borders, and unable to display the content of the windows, "just" because there was a mismatch between the "display port" size and the "window" size. Lines are wrapped because the available pixel size doesn't match the used pixel size. Later versions of the code have the same problem for all what worked in v66 that is, not only the parts inside the windows, but also the background and borders of all the graphical objects.



  • @Pulsar33 I don't know what to think....

    here Marius says that this is a mir problem (January 2020)

    here the mir developers say that is a mesa problem (7 august 2020)
    and here the mesa developers said they had the problem (2 august 2019) but already corrected that ( 15 august 2019)...for them mesa works correctly on rpi4 (and hardware accelerated)...

  • @Aury88 : thank you for alerting me
    I'll give a try to the next distribution as soon as possible and report here.


  • @Aury88 : some news about #371 distribution
    Starting as usual, terminal display is correct but graphical display is garbage as previously.
    I'm connected to a 4k Samsung TV (3840x2160) with a standard HDMI wire.
    I've not tested in 1920x1080 but previous tests have shown no difference with a Full HD monitor.
    So, after some time and automatic reboot, I've seen the same grey lines on white page screen, with some pixels blinking.
    Fortunately, the PrintScreen function has captured a 4k snapshot of the display and it is correct as you can see below (I've reduced the image size for forum convenience). So it is definitely a problem of bad parameters in the frame buffer (correct) to video output (garbage) process (I don't know the code breakdown).
    Good evening

Log in to reply