Continuation of rpi effort and how to test

  • @3arn0wl Possibly you just need to redo the SD card. Did you unzip the image before writing it? After writing the card did you expand the root partition into the unallocated space and did you use a beefed up power supply and connect up an Ethernet cable when trying to boot?
    Seven blinks suggests that the kernel image is not found.
    I've never used Etcher.

  • @3arn0wl the Telegram group is often the quickest place to get help:

  • @Mark

    Aha! Thank you for the pointers! I will have another go in a while.

    What software do I need to make the root partition bigger? I can't seem to do it with Disks.

  • @3arn0wl I use Gparted. Easy to do when the SD card is in another computer (or in a USB card reader attached to the Pi running Raspian) and you can therefore unmount the partitions to edit them. Good luck.

  • 🙂 Thanks for that, @Mark

  • I've tried image 117 and it seems to work as well on the Pi 3B+ as 95. It still has many of the same issues (wifi, selection and audio). Rodney helped fix the bug where the swipe tutorial covers the screen but won't disappear (because you can't swipe like on the phones).
    If you only have a touchscreen and you find your view is getting blocked by the first run tutorial then edit /var/lib/AccountsService/users/phablet so that the line starting DemoEdgesCompleted reads DemoEdgesCompleted=[‘left’, ‘top’, ‘right’, ‘left-long’]
    You can do this via ssh or (with difficulty) in the terminal squinting through the tutorial screen.
    If you have an hdmi monitor and connect to that it should open in desktop mode and after that it will be fine in the touchscreen next time it is run.
    The Super-a Key opens the launcher just like on Gnome.

  • v44 : no graphic mode available

    v66 : Desktop displayed but application graphical garbage

    v77 : no graphical display at all (black screen)

    v137 :

    • desktop display garbage,
    • resolution seems to change 2 times,
    • black screen after some seconds then HDMI disconnected,
    • able to retrieve HDMI with Shift Key and TV re-selection

    Is there a way to use this with a RPI4 4GB ???


    Following after some seconds
    Stable before black screen

  • Nobody knows ?
    Am I the only one to try with a PI4B 4GB ?

  • @Pulsar33 Several of us have a Pi 4 (mine is also 4Gb) but until someone (who knows how) can put in the work needed to get the tiling vs Unity8 problem fixed we can't get very far. However the more bugs and issues we can identify and fix on the Pi 3 in the meantime the better the Pi 4 experience will be when it comes.

  • On Pi 3 with touchscreen it starts without an external keyboard or mouse. The bug where you needed to unplug the mouse and plug it in again was fixed a long timealreadyThere are still niggling selection problems but lots of improvements. Good choice on the Openstore (though some apps still use oxide and ubuntu.web and they will need to be updated to work on the Pi). For me Dekko, Morph, TELEports, Openstore, Terminal, UT Tweak Tool, Document Viewer and many more work well already.

  • @Mark thank you for the answer

    I'm not able to look in the code, sorry. But when I look at the two pictures below, it's clear that v66 was able to display the background, the menu and the notifications as well as the window borders, and unable to display the content of the windows, "just" because there was a mismatch between the "display port" size and the "window" size. Lines are wrapped because the available pixel size doesn't match the used pixel size. Later versions of the code have the same problem for all what worked in v66 that is, not only the parts inside the windows, but also the background and borders of all the graphical objects.



Log in to reply