Testing the upgrade to Qt 5.12



  • Good news everyone!

    Work on the Qt 5.12 upgrade is at a point where more people can test it. Unfortunately though, there are some complications with the differences on Pinephone and Raspberry Pi devices, so it cannot be used there just yet. However, for anyone using an Android based device, it should work pretty well at this point.

    To install (DO NOT DO THIS ON PINE OR PI DEVICES), you should first be on the devel channel, then do the following:

    mkdir -p apt/cache apt/lists
    sudo mount --bind apt/lists /var/lib/apt/lists
    sudo mount --bind apt/cache /var/cache/apt
    sudo mount -o remount,rw /
    sudo ubports-qa install xenial_-_qt-5-12
    

    Then reboot and start testing. Please note if there are any packages removed or such by apt when performing the install. Please test all your apps as you use them, to ensure there are no crashes or such, and if there are any crashes please specify the app and action causing the crash when reporting it here.

    Thanks and enjoy!



  • What update channel is best to be on before testing this? Devel I presume?



  • @arubislander Yes, you should be on devel. (I've edited the original post to clarify, thanks!)



  • @dobey said in Testing the upgrade to Qt 5.12:

    mkdir -p apt/cache apt/lists
    sudo mount --bind apt/lists /var/lib/apt/lists
    sudo mount --bind apt/cache /var/cache/apt
    sudo mount -o remount,rw /
    ubports-qa install xenial_-_qt-5-12

    Are you missing a sudo in front of that last command?

    I ran it on my BQ M10FHD and it said it wanted to downgrade 5 packages.

    The following packages will be DOWNGRADED:
      libqmenumodel0 libsystemsettings1 qmenumodel-qml qtdeclarative5-ubuntu-ui-extras0.2 ubuntu-system-settings
    

    Will report back on testing.



  • I am testing it already a couple days, update seems that worked correctly with just

    sudo ubports-qa install xenial_-_qt-5-12
    

    on OnePlus 3T.
    I've got a couple issues, Telegram and Dekko shows just blank screen, inhibiting of screensaver doesn't work, QQC2 checkboxes and (checkbox or switch) delegates was broken, and Transport app is unable to remember list of transport types.



  • @arubislander said in Testing the upgrade to Qt 5.12:

    Are you missing a sudo in front of that last command?

    Perhaps. Updated.

    @arubislander said in Testing the upgrade to Qt 5.12:

    I ran it on my BQ M10FHD and it said it wanted to downgrade 5 packages.

    It seems there was a versioning faux pas with qmenumodel, and the other two had changes that landed in xenial branch after I created the 5.12 branches. Getting them updated now, thanks!



  • @danqo6 said in Testing the upgrade to Qt 5.12:

    inhibiting of screensaver doesn't work, QQC2 checkboxes and (checkbox or switch) delegates was broken

    Can you clarify a bit more what you mean with these two comments, and perhaps point at something more specific where I can test them as well?

    Not sure why Teleports is blank, as there's nothing useful in the log. Dekko seems to have some components failing to load (likely a bug in the Dekko code simply made more apparent by newer Qt)
    Transport app seems to be in similar situation to Dekko, and its log is filled with QML warnings (it was very unstable when I tried it here, and would crash easily)

    Thanks.



  • @dobey
    Log after loading delegates page from qqc2 gallery app

    file:///usr/lib/aarch64-linux-gnu/qt5/qml/QtQuick/Controls.2/Suru/CheckIndicator.qml:80:5: QML QQuickImage: Invalid image provider: image://suru/checkmark/#ffffff
    
    QQmlComponent: Component is not ready
    
    file:///opt/click.ubuntu.com/qqc2-gallery.ubad/1.0.7/qml/Main.qml:199:5: QML StackView: push: file:///opt/click.ubuntu.com/qqc2-gallery.ubad/1.0.7/qml/DelegatePage.qml:133 Type SwitchDelegate unavailable
    
    file:///usr/lib/aarch64-linux-gnu/qt5/qml/QtQuick/Controls.2/Suru/SwitchDelegate.qml:47 Type SwitchIndicator unavailable
    
    file:///usr/lib/aarch64-linux-gnu/qt5/qml/QtQuick/Controls.2/Suru/SwitchIndicator.qml:64 Label is not a type
    

    And during palying video in Morph browser screen turns off after certain time



  • In battery settings in system-settings app after selecting time from 'sleep when idle' app crashes, short log:

    file:///usr/share/ubuntu/settings/system/qml-plugins/battery/SleepValues.qml:59: TypeError: Cannot call method 'indexOf' of undefined
    
    file:///usr/lib/aarch64-linux-gnu/qt5/qml/Ubuntu/Components/ListItems/1.3/ItemSelector.qml:257:13: QML ListView: Binding loop detected for property "itemHeight"
    


  • @dobey
    BQ 4.5: Got a crash at startup for sfxr: https://paste.ubuntu.com/p/khrnt9xc2R/
    Crash also for Teleport, messaging app
    Blank page for Dekko

    Note that in the drawer, i have only 2 app icon columns (scaling 12 in UTTT) and distorted spash icons on several apps.



  • On E5HD I got a couple of issues:

    I'm pretty sure this is because I have been testing some PR but nothing was installed when I checked with ubports-qa list

    The following packages will be DOWNGRADED:
      messaging-app
    
    Unpacking libqt5webenginecore5:armhf (5.14.2+dfsg1-2~ubports2) over (5.14.2+dfsg-2ubports0) ...
    dpkg: error processing archive /var/cache/apt/archives/libqt5webenginecore5_5.14.2+dfsg1-2~ubports2_armhf.deb (--unpack):
     cannot copy extracted data for './usr/lib/arm-linux-gnueabihf/libQt5WebEngineCore.so.5.14.2' to '/usr/lib/arm-linux-gnueabihf/libQt5WebEngineCore.so.5.14.2.dpkg-new': failed to write (No space left on device)
    
    Unpacking liboxideqtcore0:armhf (1.19.8-ubports2.2) over (1.19.8-ubports2) ...
    dpkg: error processing archive /var/cache/apt/archives/liboxideqtcore0_1.19.8-ubports2.2_armhf.deb (--unpack):
     cannot copy extracted data for './usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0' to '/usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0.dpkg-new': failed to write (No space left on device)
    
    

    Full log (except the download messages):
    https://paste.ubuntu.com/p/NbS3BtFTsv/



  • @danqo6 Thanks. I've pushed the fix for this and the SwitchDelegate issue in qqc2-suru, so those should all be good now after an update.



  • @CiberSheep Seems there was a change in messaging-app yesterday for OTA-13, which I've pulled in now, so should be included in the update as well.

    Otherwise though, is your rootfs full? Did you already install some other things extra in it perhaps from Ubuntu archive?



  • Wow, I come back to find everything I intended to report already reported! It isbgreat to see the community come together like this.

    @dobey said in Testing the upgrade to Qt 5.12:

    I've pulled in now, so should be included in the update as well.

    How should one go about acquiring the updated packages? Just repeat the process in the original post?



  • @lduboeuf said in Testing the upgrade to Qt 5.12:

    BQ 4.5: Got a crash at startup for sfxr: https://paste.ubuntu.com/p/khrnt9xc2R/

    The app crashed? Or the shell? Sfxr seems to work mostly fine on my Nexus 4, though I have noticed a couple issues with the app itself (and I think unrelated to Qt 5.12).

    Crash also for Teleport, messaging app

    Again, are the apps crashing, or the shell?

    Note that in the drawer, i have only 2 app icon columns (scaling 12 in UTTT) and distorted spash icons on several apps.

    Yeah, there seems to be something up with the app drawer column math it seems. Not sure what though, since I'm pretty sure it is untouched.



  • @arubislander said in Testing the upgrade to Qt 5.12:

    How should one go about acquiring the updated packages? Just repeat the process in the original post?

    Mostly. Just do sudo ubports-qa update instead I think (or just sudo apt-get update && sudo apt-get upgrade after doing the mount commands).



  • @dobey said in Testing the upgrade to Qt 5.12:

    The app crashed? Or the shell? Sfxr seems to work mostly fine on my Nexus 4, though I have noticed a couple issues with the app itself (and I think unrelated to Qt 5.12).

    Yes the app crashed. What do you mean by shell, Lomiri crash and reboot ?



  • @lduboeuf Yes.



  • @dobey I made fix for missing images in checkindicator and spinbox, look https://github.com/ubports/qqc2-suru-style/pull/48/files



  • @dobey said in Testing the upgrade to Qt 5.12:

    Otherwise though, is your rootfs full? Did you already install some other things extra in it perhaps from Ubuntu archive?

    I'll install a fresh image and try again to be sure


Log in to reply