webapp creator tutorial

  • @dtarrant I played with clickable and webapps few weeks ago .... this is the result: memrise webapp

    After looking to my history, these were my steps to init, build & deploy to phone:
    on notebook with Ubuntu MATE 18.04

    1. install & setup clickable & docker

      sudo add-apt-repository ppa:bhdouglass/clickable
      sudo apt update
      sudo apt install clickable docker
    2. go to your project dir & create project via clickable (project folder will be created)

      cd ~/projects/ubports/webapps/
      clickable init
    3. after app creation was successful, you should see an dir created in your current dir with the name of the project you typed in clickable initialization. Enter the project dir

    4. try to run (I've figured out, you have to use sudo to run docker)

      sudo clickable -e
    5. edit files, play, debug, etc ...

    6. to deploy to phone, there is a .click package (like appname.developername_1.0.0_all.click) in build folder in your project dir. If not use step 4. or build with

      sudo clickable --output .

      this produces a .click package in current dir & tries to copy it to your phone via adb.

    on the Ubuntu Touch phone
    0) upload .click package to your phone somehow, if not uploaded yet

    1. install uploaded .click package via Ubuntu Twaek (or some other way)
    2. have fun

  • @jezek Thank you so much for taking the trouble to share your experience. That will be most helpful.

  • @dtarrant you're welcome ... try it, have fun and share results & experiences ... maybe it will someday help someone 😉

  • @advocatux said in webapp creator tutorial:

    @dtarrant I don't remember exactly because I just played around with webapp creator some time ago, but the webapp is created in your device so you have it there to install it manually.

    The way to do that is using the terminal pkcon install-local --allow-untrusted path_to_your_package.click

    Once you're happy enough with your webapp, you can upload it to https://open-store.io

    You can login there using your GitHub, GitLab, or Ubuntu accounts.

    I tried webapp creator on my M10 HD tablet and a click package was created. When I used the terminal to run the pkcon install-local command I had very uncomfortable time trying to enter/edit the path name. I was unable to move the cursor with the space bar as is possible with uwriter. It was very frustrating as I really wanted to avoid having to type a long path name again. I came to the conclusion that the way I was trying to use the terminal was very unsuitable and I wondered if you could suggest a better approach. Maybe that is why you originally suggested clickable running on a laptop?

  • @dtarrant the easier way is to type the commands using the terminal on your computer, with your device plugged (using adb shell).

    On the other hand, keep in mind once you've typed something in the terminal, it's there for future use. Bash history and tab autocompletion are very handy 😉

    See here [*] the Terminal tutorials, there are 4 chapters, to learn the basics and some tricks also.

    [*] https://ubports.com/blog/ubports-blog-1/tag/blogs-2

  • @advocatux I was trying to use bash history on my tablet. It worked, but was very fiddly to use. I like the idea of using the terminal on my laptop, I've never had any problem with that. I've not come across adb shell before. I'll have to look that one up.

  • @dtarrant you can also install the click package via UT Tweak Tool

    also check some awesome tutorials

  • @jezek That's useful information. I have UT Tweak already installed on my M10, but I didn't realise you could use it to install a click package. Many thanks for your input.

  • @jezek I've just explored UT Tweak and found the install click utility. The next problem is that it doesn't let me access the click generated by webapp creator. My click was automatically created in:
    and I can't seem to access it from UT Tweak. Do I need to move it elsewhere in order to install it?

  • @dtarrant I created some Web app with webapp creator, and saved the click to my documents, so I could install them with UT Tweak Tool.
    Maybe if you move your click from the .cache to your documents, you will be able to install it 😉

  • @ellypsis Sounds like that's the way to go. I'll give it a try. Thanks for the tip.

  • @ellypsis Amazing!!! That did the trick. Now to finesse it to the point where I could upload it to OpenStore. I've just created my first webapp; how cool is that?

  • I have done all the steps to create a webapp with clickable described here http://clickable.bhdouglass.com/en/latest/getting-started.html#getting-started

    Than, when I run 'clickable' it is downloading the image 'clickable/ubuntu-sdk:15.04-armhf' locally

    So it seems to be only vivid compatible and not xenial compatible. Am I right?

  • @bastos This topic is about webapp creator. Maybe you'd be better to start a new topic about clickable. I would be interested in that once I have got my head round webapp creator. Good luck.

  • I'm delighted to report that with help from @advocatux and @bhdouglass, I succeeded in getting my first webapp, NFB Canada, working and uploaded to OpenStore. The process was as follows:

    • run webapp-creator and complete template

    • run UT Tweak Tool to install .click package on my M10 HD tablet

    • test webapp

    • join Telegram OpenStore Group

    • submit webapp

    All this was accomplished on my tablet. The difficulties I experienced were as follows:

    • had trouble joining Telegram OpenStore Group. This turned out to be an issue with the UT Telegram app. When I switched to the Telegram webapp everything worked as expected.

    • I did try using the UT Tweak Tool to submit my .click package, but was unsuccessfull. This may have been because I hadn't yet joined Telegram OpenStore Group at that stage.

    • my first submission to OpenStore was declined as requiring manual inspection. Brian Douglass suggested that I needed to use the default profile since video_files wasn't needed. That fixed the problem.

    • each time I needed to edit my webapp-creator template, I had to fill out the whole pro-forma again. However I got better at doing that as I moved further up the learning curve.

    In case you are wondering why I chose NFB Canada as my target, let me explain. My first tablet was a Blackberry Playbook. This came with an NFB Canada app installed. I found that it was a wonderful resource. So I thought perhaps some of you UT enthusiasts might also enjoy it.

  • @dtarrant said in webapp creator tutorial:

    @bastos This topic is about webapp creator. Maybe you'd be better to start a new topic about clickable. I would be interested in that once I have got my head round webapp creator. Good luck.

    Ah. OK.
    But me as a real coding noob is exactly searching for a tool to create webapps. Maybe I should do it here: https://forums.ubports.com/topic/291/web-app-generator/27

  • @dtarrant

    Congrats for your first UT app !

    My first tablet was a Blackberry Playbook.

    Not surprised to see a PlaybookOS user here, nice (and solid) tablet with its similar UI similar to that of UT, several years ahead of the competition.
    I got two Playbook always running.
    Would be great to get UT on it.

  • @libremax Agreed. I still use my Playbook, great hardware and a really slick operating system based on QNX. UT could learn from its stylish UI design. The file-based photo app is really a joy to use. Problem is the browser is way out of date now and can't handle youtube. I've moved on and I love my UT tablet.

Log in to reply