Unable to access “MX4 Ubuntu Edition” Unable to open MTP device '[usb:001,012]

  • Hi,

    I'm trying to copy images from my Meizu MX4 to my desktop/laptop (which are both running Ubuntu 16.04). I've tried a couple of different cables, four different USB ports and two different computers but I seem to run into the same problem about 80-90% of the time I try to connect my phone! I get the error message:

    "Unable to access MX4 Ubuntu Edition
    Unable to open MTP device '[usb:001,012]'"

    Is there any way around this? I've read that this is notorious with the MX4, but all I've tried doing so far is changing USB port and cables.


  • @happyzenith It might not be the cables etc. How well does the cable fit into the phone itself? When I used mine daily it was always fun using Ubuntu to see if the phone connected : ) Once had ten different windows open telling me it couldn't open mx4.
    It would only work on one USB port and at the right angle. Try wiggling the cable at the phone end the connection is tricky, that or use Linux mint ; ) that always seemed better.
    Try it on dev if your still on RC just in-case that helps
    Edit Trying to remember now but sure I had best results with a short phone charging cable rather than the longer ones.
    Edit two. Last one honest. If you have UT Tweak Tool on your mx 4 you can check adb settings and that MTP is ok by choosing system from the menu and usb settings

Log in to reply