WifiTransfer not connecting to Ubuntu 18.04 LTS

  • I've used WifiTransfer successfully to connect to my netbook running Ubuntu 16.04 LTS and it's always worked flawlessly. I've just set up a laptop with Ubuntu 18.04 LTS and I have a issue with WifiTransfer. The laptop file manager sees WifiTransfer, but when I click on it to enter the WifiTransfer code, I get a message "unable to access location"; "invalid URI......etc". Please can someone suggest a way forward. My laptop has Samba set up and connects to my netbook OK.

  • @dtarrant can you ping your device from your computer? have you checked the ftp server permissions on your device? do you have installed a ftp client in your computer?

  • Neither gftp nor filezilla are installed on my ubuntu 16.04 netbook and that works fine with WifiTransfer. Also my netbook connects to my ubuntu 18.04 laptop via samba without problem.

  • @dtarrant okay, so probably WifiTransfer has its own ftp client (I've never used it) or you have the basic ftp stuff installed in that 16.04 computer (note: I'm not talking about ftp apps like gftp or filezilla).

    Samba uses SMB/CIFS protocol, not ftp protocol.

    Anyway, what about the other questions? Can you ping your device?

  • @advocatux By "device" I assume you mean my ubuntu touch tablet? I intended to do that, but I don't know how to determine the address to ping. How can I find this information? I've looked in system settings, but didn't see anything there.

  • @advocatux I've tried "ip addr show" from the UT tablet terminal and I get many lines of output. Not sure which is relevant line.

  • @advocatux I found inet listed as part of wlan line in output of "ip addr show". I tried pinging that, but got no response.

  • @advocatux OK, some progress. I can ping and get a response from and from both the netbook and from the netbook. If I turn the UT tablet off, there is no response, so I deduce that these must be the correct ip addresses.

  • @dtarrant yes, that's the way to do it. Find the pertinent IP address for each device, for example running ip addr show in each device, and then ping from one to another to see if there's any kind of communication problem.

    If everything is fine about that, then it's time to try WifiTransfer again 🙂

  • @advocatux Well after fumbling in the dark with my UT Terminal app and ip addr show, I discovered the excellent Network Scanner app in OpenStore. This enabled me to automatically ping A great step forward. This found both my Toshiba-NB200 netbook and my Thinkpad-T420 laptop. I then ran a port scan on each of these devices and the results were identical. So I'm left with the puzzle of why WifiTransfer connects to the netbook and not the laptop. The netbook is running ubuntu 16.04 and the laptop is running ubuntu 18.04.

  • @dtarrant if everything it's fine (devices in the same network, ftp ports listening, no firewall or apparmor problems, etc) it's starting to sound like some kind of issue on how Nautilus (in 18.04) is handling ftp connections.

    Have you tried to connect to any ftp server with your Ubuntu 18.04 laptop to check if it's working correctly?

  • @dtarrant : Hello
    Please read again what I said to you sometimes ago.
    Maybe the FTP client of Nautilus in 18.04 has an issue or a more protected way to connect to the server, I don't know. However, FTP works with clients and servers and you have several solutions, at least to test and detect which element is faulty. For exemple, give a try to Filezilla Client on your laptop. This one should connect to WiFitransfer.
    Good luck

  • @pulsar33 Thanks for that reminder. I had forgotten about that. I will study it carefully and try to get my head round what is going on. As you may have gathered, I'm pretty much out of my depth here, but hope to learn as I go.

  • @pulsar33 As you suggested, I have experimented with filezilla. I installed this on both the netbook (ubuntu 16.04) and the laptop (ubuntu 18.04). After many attempts, I have been unable to achieve a connection between wifitransfer on my tablet and either my netbook or my laptop. I found filezilla complicated to use compared to nautilus on the netbook. With nautilus, wifitransfer appeared like magic in other locations and when selected, a dialogue popped requesting entry of the wifitransfer code. That was all that was needed. I can't understand why it can't work just as smoothly with ubuntu 18.04. I've spent hours trying to resolve this issue and I don't seem to be any futher forward.

  • @dtarrant :
    It seems more complicated because it is more generic and powerfull. This suggest was to verify what's working or not and you can do it ...

    Use this :

    To configure that :

    Then click connexion and you're done

  • @pulsar33 sorry if being daft but did you want the password visible on the first pic.

  • @lakotaubp : no problem, this is a local only exchange and WiFitransfer changes the password each time you launch it 🙂
    This is by the way one of the boring things with WiFitransfer. I use mainly uFtp instead (but that one needs to install a server on the laptop)
    Best regards

  • @pulsar33 Deep joy, progress! Your screenshots did the trick. I found out that my user name is ubuntu. I previously used phablet which I got from the terminal command line prompt. I've also just discovered that the port changes each time you start wifitransfer as well as the password. Anyway, I just managed to establish a connection between my netbook and wifitransfer using filezilla. Armed with this new information, I will now try connecting to my laptop. Many, many thanks for your patience.

  • @pulsar33 Brilliant! Filezilla on my laptop also connects to wifitransfer! What more could I wish for? Many thanks to everyone who contributed to solving my problem.

  • @dtarrant : You're welcome !
    All seems fine on each sides. You can now try to progress in understanding why Nautilus fails under 18.04
    Either the FTP client part of Nautilus has a problem or you didn't tell it the right things to connect.
    Good luck

Log in to reply