Ubuntu Touch on Sony Xperia X



  • On https://github.com/Halium/projectmanagement/issues/98 you can find:

    xsetiadi asked on 21 Aug
    does this will work too for xperia x dual? F5122? @fredldotme

    fredldotme commented on 21 Aug
    In theory yes, practically I don't have the device available. But since I modified the source in a way that's not specific to F5121 it should work just fine.
    The only area I could see issues with is ofono needing an override to support the second SIM tray.



  • @Nikfrager said in Ubuntu Touch on Sony Xperia X:

    On a source code level the changes were the same back then, but recent changes force ofono/rild to default to one SIM slot. This plus the properties probably being different makes calling not work on F5122. If someone wants to step up and provide support for F5122, patches welcome.



  • Today I've got a F5122 and I would love to see it with UT. But I think I don't have the capability to make it happen.



  • If anybody feels up to the task feel free to message me about it.
    Also, if anybody has an F5122 can you please issue the following command on the phone's terminal:

    cat /proc/cmdline
    

    and send me the output privately?

    Also, if people really want me to help out on F5122 support, there's a way and that's the donate button on https://fredl.me/donate, else I'm not going to be able to get the device in the first place.



  • Ok, I have the device and can try that command. I think first I have to install UT on it, right?



  • @Nikfrager yes, UT would be preferable.



  • @fredldotme maybe I'm misunderstanding something ... but if they install ut via your halium image, then the kernel commandline is simply going to be whatever is set in your halium image .. no?!



  • @doniks The bootloader sets additional cmdline arguments



  • @fredldotme I have the result of the command. I sent you an e-mail.



  • Thanks @Nikfrager, it seems possible to create a single release for both F5121 and F5122. I'll implement something next week and hope for owners of the F5122 to test it again.



  • Thank you also @fredldotme. That sounds great. I'm very eager.



  • Hello,

    Thanks for the port of UBports to Xperia X. I have bought one to replace my FP2/UT, because its hardware is about to die (cannot repair the screen flickering symptom).

    I am unable to install UT on Xperia X F5121. I am now back to TWRP+LineageOS (android 8.1) on the phone, because it is on the only way I found the put the phone in a « known » working state.

    I tried several methods to install, both on Ubuntu 19.10 and Buster 10.2. But each time, ubports-installer hangs because I cannot reboot the device in recovery mode. To do that, I must shut down the device, wait for seconds, and replug it with volume down key to boot into recovery mode. Therefore the link with the installer gets lost. Maybe instructions on screen dialog are inaccurate.

    Is there a way to fully install (from start to end) with a simple shell script, using fastboot and adb tools ? Has someone ever done it ?

    Thanks !



  • This post is deleted!


  • @livrecinq

    Wasted a lot of time over this issue with my F5121 which was previously running Sailfish OS using Ubuntu 18.04 LTS and Mac OSX . In my case had previously saved TAbackup prior to bootloader unlock for Sailfish, so downgraded device back to MM with Androxyde Flashtool, restored DRM (Androxyde Advanced settings), upgraded to stock Oreo, bootloader unlocked on latest firmware, turn on USB debugging, installed twrp-3.2.2-0-suzu.img, reboot into "recovery mode" TWRP wipe then advanced wipe for cache, dalvik cache, data and system, fastboot flash oem SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_loire.img and then ran UBports installer 0.14.4-Beta upon Mac OSX to install 16.04/community/fredldotme/devel and got "spinning white circle" this time. Remember to remove any microSD card for any subsequent OTA updates, now on v 10* OS build number 2020-01-01/2.



  • @aspergerguy Thanks for your comments ! For now, the key point is to remove any SD card before any attempt to install or update.



  • This post is deleted!


  • @aspergerguy Hi, I'm also having trouble with a device that had SFOS. Can you tell me where you downloaded the stock xperia images from? There seem to be suspicious sites around.



  • @marklynch
    Stock Xperia images downloaded using Xperifirm within Androxyde Flashtool. If you want to find older MM versions you have to look under "Commercial & Journalists". Another source could be:link text



  • Location toggle won't stay enabled; I didn't see any comments about location beyond it working in late 2018... Was there a regression? Excellent port btw!



  • Hello. I have a problem flashing sony xperia x with ubports. I already follow all the steps. My phone is an android 8 oreo version, i unlocked to bootloader with sony flash tool. i already enable oem and usb debugging and i install the Sw binaries with fastboot. but when i start ubports, everything is working until the phone reboots to install the firmware and it boot in ubports recovery mode so is not anymore in the fastboot mode with the blue light on. And when i tried to put it back it gets disconnect. What can i do ? can i flash it from ubports recovery ?


Log in to reply