Development testers for Anbox

  • I tried the Play Services Patcher that @Xray2000 posted above with one apk so far, but it couldn't be patched for some unknown reason. It went through the analyze process fine and suggested the patch, which then failed.

    Did anyone else try?

  • I noticed that Aptoide is installed by default with UT Anbox. Is it safe to use? Somebody on the Crackberry forum wrote:
    "I would avoid aptoide like the plague btw. Tons of pirated and dubious apps."

  • After further testing of anbox and several different apps I have found that some apps that claim that they require Google Play Services run anyway. Also, some apps that don't rely on Google services run, but are unable to detect the wifi connection in UT. To turn on wifi in the android settings doesn't work, as it reverts back to "off" every time.

  • @tomoqv I also faced the issue of not detecting wifi with one or two apps. one of them was the kodi remote yaste. It would think it is offline, so it would not autodetect my kodi box. But if I entered the ip address manually it would connect. So it seems only wifi detection is a problem, wifi access works fine.

  • @arubislander Yeah, really strange. Unfortunately e.g. the IKEA Tradfri app doesn't let me enter an IP address manually.

  • Could you compile a kernel with the needed modules for flo/deb devices (nexus 7 2013)?

  • Hello, currently I installed Ubuntu Touch 16.04 on OPO and Hammerhead without problems. I installed some android apps as well. But I have an app which can be controlled by the navigation buttons of android phones only, which I found no way to enable on ubuntu touch/anbox yet. I tried some apps which provide a software navigation bar from But even if one of this is enabled in anbox configuration menu its not overlayed on the screen to that app. Is there a way to solve this?

  • If I could add anything to this discussion it would be:

    • there should probably be a step-zero (update to xenial/16.04)
    • there is an unfortunate spelling error in the first sentence regarding what we need... @mariogrip ...
    • I wonder if "microG" would benefit us, as they have (to my understanding) a pretty complete open source google play services re-implementation, and only requires a minor kernel patch (to spoof google's SSL certificate); and it is supposedly far more trim and performant than the true-google variant

  • @osndok fixed the spelling error. Also TIL a new English word XD

  • How can I add a Google account in Anbox?

  • @osndok
    Have you tried installing it ? There is a thread 'root permission' for apps #118' on the Anbox github site which describes installing opengapps on the desktop version of Anbox. Maybe it works with microg the same on Ubuntu Touch?

  • I have another issue. With adb installed on my phone I got problems on OPO because no connection is possible. The command 'adb devices' states the emulator is offline, even though it was possible to start apps. But can't install others. How can Anbox be visible as device again?

  • Can it made possible to use emojis for the Android Keyboard in Anbox for typing? For now they are not usable, because they all are displayed as crossed boxes.

  • This post is deleted!

  • @joe I agree. I would like to draw everyone's attention to this issue, and as I say, we need a way to start from fresh with Anbox without having to reinstall Ubuntu Touch. This is especially important for when Anbox is entirely stable and becomes a part of the system image for a future UT OTA.

    Sister issue regarding the importance of being warned or even blocked from installing problematic apps, as desktop snap-based Anbox implementations already do:

    I'm also wondering if Anbox can be destabilised if users try to install APKs beyond a certain storage level? Like, if we install several apps which are each ~100MB, and this is from a starting point of say 1.5GB free storage space left, is there a point at which things start to break? And I mean before running to to 0MB left.

  • @gb I had to enlarge the system partition on my Nexus 5 to install everything, if I remember correctly. Maybe that's your issue? I think I followed this script with minor adjustments, but caution I don't remember since it's been a while – do it on your own risk 😉

  • @padraic said in Development testers for Anbox:

    anyone successfully get frieza working? I tried but am told that

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!

    Pretty sure I went through the procedures correctly but maybe I missed something. If I don't hear back from anyone I'll try again in a couple of days and open an issue if it still doesn't work.

    I have the same problem

  • @gb

    @gb said in Development testers for Anbox:


    I´m testing it in M10 FHD (frieza).
    I just installed ubports from scratch (16.04 dev) and try the instructions post by Marius.

    Doing "sudo apt-get upgrade", I´m facing:
    "E: You don't have enough free space in /var/cache/apt/archives/."

    How can this be possible? I just installed the system and there is no space left?
    Do I have to install the hole thing into a Libertine container?

    You can try (it has helped me):

    sudo mount -o rw,remount /

    sudo rm -r /var/cache/apt

    sudo tune2fs -m 0 /dev/loop0

    sudo apt update

    sudo apt install anbox-ubuntu-touch

    sudo rm -r /var/cache/apt

    sudo mount -o r,remount /

  • @pawlinski I'm having the same issue. Installation was successful after cleaning the cache several times. but when I try to install anbox-tools I get the same error as @padraic .

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

  • @honigwald What does sudo anbox-tool status say? On my Nexus 5, sudo vs no sudo shows different status.

Log in to reply