Development testers for Anbox

  • @tomoqv No you can not change package name Android reads this out of the manifest file that is into the apk when installing, when you change this the app will never work again.

  • So I wonder if there is any google package that carries the name

  • @tomoqv As far as I know this is the name of a Java library (extension .jar), but I have no idea how libraries are installed in Android, and less in anbox.

  • @wgarcia It seems to me that many android apps just add the google dependencies by habit, without really needing it. I am looking for a way to trick those apps.

  • @tomoqv In my case I tried installing an Android app of my municipality to pay for street parking and it asked for this same thing. In this case it makes sense because it needs location, I believe. In any case I don't think GPS will work inside anbox any time soon.

  • @wgarcia We have an identification app used for authentication purposes with banks and authorities, which doesn't do anything else than asking you to punch in your 6-digit pin. It still asks for Google services to run - crazy!

  • There is mebay an option Gobalt some guy that was working on solution for BlackBerry when the where support Android apps make a tool to remove Google Play Services from a apk, i have try that back to that time and it worked for me, but you need Windows to run the app, so i can not test it now.
    The name of the application is
    But for the guy's who like to test it you can download it here:

    alt text

  • @stefano said in Development testers for Anbox:

    @joe sudo apt remove anbox-tool
    sudo apt purge anbox-tool
    Flash it over with Ubports installer without wipe?

    FYI, none of those were able to remove anbox. I guess it needs to be wiped completely?

  • @joe Yes, I have tried that as well. The placeholders of Android apps stayed on Home screen, but all the files were gone. Ended up restoring the saved TWRP backup.

  • You may be able to work around the Google Play services requirement by installing microG, but I'm not sure if the Anbox image has signature checking patched out. So you may need a tool that will do signature check patching to enable it to be used in place of Google Play.

  • If I try to add an account nothing happens... any ideas?

  • @wgarcia that JAR file ( and any other accompanying JARs should be put in /system/framework. Not sure if the Anbox system image is writable though 😕

  • For anyone having uninstalled anbox after testing it, but stuck with the all the non functional android application icons on the launcher. These can be removed by opening a terminal on the device and issuing the command:

    $ rm .local/share/applications/anbox-*

  • Hi,

    I´m testing it in M10 FHD (frieza).
    I just installed ubports from scratch (16.04 dev) and try the instructions post by Marius.

    Doing "sudo apt-get upgrade", I´m facing:
    "E: You don't have enough free space in /var/cache/apt/archives/."

    How can this be possible? I just installed the system and there is no space left?
    Do I have to install the hole thing into a Libertine container?

  • I tried the Play Services Patcher that @Xray2000 posted above with one apk so far, but it couldn't be patched for some unknown reason. It went through the analyze process fine and suggested the patch, which then failed.

    Did anyone else try?

  • I noticed that Aptoide is installed by default with UT Anbox. Is it safe to use? Somebody on the Crackberry forum wrote:
    "I would avoid aptoide like the plague btw. Tons of pirated and dubious apps."

  • After further testing of anbox and several different apps I have found that some apps that claim that they require Google Play Services run anyway. Also, some apps that don't rely on Google services run, but are unable to detect the wifi connection in UT. To turn on wifi in the android settings doesn't work, as it reverts back to "off" every time.

  • @tomoqv I also faced the issue of not detecting wifi with one or two apps. one of them was the kodi remote yaste. It would think it is offline, so it would not autodetect my kodi box. But if I entered the ip address manually it would connect. So it seems only wifi detection is a problem, wifi access works fine.

  • @arubislander Yeah, really strange. Unfortunately e.g. the IKEA Tradfri app doesn't let me enter an IP address manually.

  • Could you compile a kernel with the needed modules for flo/deb devices (nexus 7 2013)?

Log in to reply