Are we forgetting the little bugs?

  • @ukphil Keep an eye and report back here in a few days. If you could check the bug reports on github and see if one matches this and the fix works you can add it to that if not. Probably best to create a new bug report then add this as a fix. That way it won't get missed. Thanks for thework everyone.

  • Awesom! Thats exactly how users can help the devs. I think now theres a reasonable chance to get that fixed. Well done community! 🙂

  • @hummlbach Quite right a great example of community pulling together to sort through an issue. Once again thanks to all those involved : )

  • I can confirm that the fix given does actually work. Last night there was a system update (version 18) that I installed. After this install the double boot issue came back again. On checking the "/.cache/mediascanner-2.0/mediastore.db" was back again, so I removed it again and since then no double boot.

    No worries about adding the bug report, but do you want to @kristatos as it is your hard work that has found the fix, I am just the tester 🙂

  • Nice to hear that this fix works for other people with this issue also. @UKPhil I'm not sure if there's already a bugreport for this issue, if not you can add one and post my fix.

  • Cool will do and will post the number here.

  • As an update I have noticed that most times I delete this db it will vome back. I think the fix has not worked when I get a double boot, only to find it back again.

  • @ukphil That sounds like proof! Do you have the bug number yet?

  • To be clear, when people are saying "double boot" here, they do not actually mean that the phone reboots right? If so, I don't see how the mediascanner db could cause that.

  • @dobey this has been covered about 17 comments from the top

  • Strange that this issue is coming back to you. I deleted this DB around Ubports OTA-2 and after that there was no double boot again. Also not after installing OTA-3 and OTA-5.
    I've looked at my E4.5 and it seems that this DB is build at every boot again. So could it be that there are some broken files on your system which end up in a corrupt database?

  • I have no idea, but from what you are saying "I've looked at my E4.5 and it seems that this DB is build at every boot again" this is what is happening, but you think the input to this may be broken?

    By any chance, you do not know what files go to make this up?

  • @ukphil Whatever music and videos you have on your device. But at most this db being corrupt would cause mediascanner2 to crash, and your music/videos not available to play.

    I would be extremely surprised if anything remotely like an actual reboot was a result of this database file being corrupted.

  • Maybe you can test if it depends on your media files or something else. It seems that there is an option to prevent mediascanner from scanning separate folders by creating a file named ".nomedia" in the folder you want to prevent from scanning. I think you have not so many folders containing media on your phone so it would be easy to test.
    After that please delete the DB and reboot the phone. I would expect that the DB-file will be rebuild but the mediaplayer will not know/detect any media on your device. If there's no double boot too you have found the problem. If not the search goes on 🙂

  • @kristatos what can I say, you are a star, that idea worked and I was able to determine that I had a bad media file in my videos > folder. I added a text file there saying ".nomedia" and rebooted a number of times. Each time I did not get the double boot issue on either start-up of shut down.

  • @ukphil YES !!! this worked also for me!
    Months of insecure (is there any virus?? that boots my device twice ???) are past!
    thank you very very much !

    < " it is a corrupt media database - "/userdata/user-data/phablet/.cache/mediascanner-2.0/mediastore.db" or /home/phablet/.cache/mediascanner-2.0/mediastore.db.
    I deleted this db and the double boot/shut down did not happen.">

  • Nice to hear, it seems that we're getting closer 🙂

  • @ksalver it sure does, thanks again. Hopefully this fix will be put in and more can have your fix.

Log in to reply