How to go back to OTA-3?

  • @lyovushka it sounds like a hard coded redirection from stable to stable channel then.

    You can try to install 15.04/rc or 15.04/devel, there isn't too much difference between those.

  • @advocatux it looks like the json of 15.04/rc is also pointing to 16.04 and the same for devel.

  • @lyovushka no, I'm seeing the paths now and they are fine. Why do you think 15.04 is pointing to 16.04?

    What happens if you run this in your phone terminal? sudo system-image-cli --switch 15.04/stable

  • @advocatux Is there a way to specify the version you want to flash with that command? Because the last versions of all the 15.04 channels point to 16.04. That is how the automatic update to 16.04 from 15.04 was implemented I think.

  • @arubislander if you run system-image-cli --list-channels it lists the available channels, including aliases.

    At what level is the redirection working? Is it too deep (so to speak)?

    You can see all the options for that command here if you want to give it a try to force a specific version.

    Edit: hmm maybe I'm too tired now but I'm been seeing the "hidden redirects" and I still don't see the full picture clearly (there are some typos btw). I'll give it another try tomorrow 🙂

    Edit 2: if that system-image-cli command doesn't work for you, and you have ubuntu-device-flash installed in your computer, you can try that way too.

  • @advocatux the last section of the file is

                "description": "ubports=20181012-28857,device=20181012-23204,keyring=archive-master,tag=OTA-5,version=3",
                "files": [
                        "checksum": "1308a6e7c6805789bddcd9108f6ab2b430908a3d2a0f0a0253cac0a739431ca4",
                        "order": 0,
                        "path": "/pool/ubports-1e002fd7e685421651a9b8dc15b0147c4460993169acd0519183533f17331c84.tar.xz",
                        "signature": "/pool/ubports-1e002fd7e685421651a9b8dc15b0147c4460993169acd0519183533f17331c84.tar.xz.asc",
                        "size": 397291364
                        "checksum": "3a01afd8a4cbdb42d90ac91dbcc7327d0bc8f6e8973b9a52f59f50a7f885c732",
                        "order": 1,
                        "path": "/pool/device-964a84f55b03eca87dacd34dffc9c61c4b50ae471c6b675eafdc2a2eacfad29c.tar.xz",
                        "signature": "/pool/device-964a84f55b03eca87dacd34dffc9c61c4b50ae471c6b675eafdc2a2eacfad29c.tar.xz.asc",
                        "size": 59352468
                        "checksum": "5b6e870acf8944330acb2a9dad6f5270bd06c377603a3115f805290e989ab421",
                        "order": 2,
                        "path": "/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz",
                        "signature": "/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz.asc",
                        "size": 1504
                        "checksum": "977cf397b86b388539e2d2436e753e618694216a215ad0562b3adf2c8b8bf66f",
                        "order": 3,
                        "path": "/ubports-touch/16.04/stable/hammerhead/version-3.tar.xz",
                        "signature": "/ubports-touch/16.04/stable/hammerhead/version-3.tar.xz.asc",
                        "size": 456
                "phased-percentage": 5,
                "type": "full",
                "version": 4,
                "version_detail": "ubports=20181012-28857,device=20181012-23204,keyring=archive-master,tag=OTA-5,version=3"

    There is a reference to both OTA-5 and 16.04

  • OK, I hacked ubports-installer to install version 3, rather than the latest version and it installed OTA-3 for me.

  • @lyovushka Hey the problem with GPS was on my Nexus 5 too after the Upgrade to OTA-5. It is gone after a reboot. Have you tried this?

  • @lyovushka thank you 🙂

  • @krille For me GPS worked after a fresh install (with wipe) and then stopped working after the first restart. I am back to OTA-3 now and GPS works again. Hopefully GPS and media player will work in OTA-6.

  • At the trip in Vienna GPS always broke again after some time. You were right. 😞 I'm now switched to the rc channel and there it seems to work so far...

  • @lyovushka

    How did you hack the ubports-installer to install OTA3 ?

  • This works for rollback to OTA3:

    ubuntu-device-flash --server= touch --device=arale --channel=15.04/stable --revision=3

  • @advocatux said in How to go back to OTA-3?:

    What happens if you run this in your phone terminal? sudo system-image-cli --switch 15.04/stable

    Today I tried to downgrade back to 15.04... Didn't work. The device was a clean install.

    Just reffering...

  • @jezek have you tried forcing the UT version with that command @mprotic posted?

    If you don't have ubuntu-device-flash installed in your computer [*] you can install Ubuntu 16.04 in a usb stick and install in it all the necessary tools too (ubports-installer, adb, and fastboot).

    [*] Assuming you don't have xenial running in your computer 🙂

    Edit: of course, don't forget to change "arale" for "FP2" in your case

  • Strange. On my notbook, I have adb, fastboot and even ubports-installer installed, but the ubunt-device-flash command is missing. How can I install it?

    edit: notebook is a

    $ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 18.04.1 LTS
    Release:	18.04
    Codename:	bionic

  • @jezek it's only available for trusty & xenial. If you're running anyone of them, you can install ubuntu-device-flash (you forgot an 'u' btw) enabling the "universe" repo.

    Edit: ah, you edited your post. Use a live usb stick then or try to run that package ( on your computer but I don't know if it will work.

    Another edit: Thinking about that now, I think someone (maybe @dobey?) built that tool for 18.04.

  • @advocatux Sorry, where did I forgot an 'u'?

  • @jezek in ubunt-device-flash. I pointed at that just in case you were typing the wrong command 🙂

  • @advocatux ahh... I see... just a typo on this forum... in terminal I tried the right thing...

Log in to reply