Help testing new legacy image

  • @NeoTheThird and where's the check list method ?

  • All good with the E5 image (^-^)b great work guys !

  • @Flohack Yes, I've used this in January when I got my phone back from reparation (well, before sending it and after getting it back to restore) and it worked pretty well. Is it true that if you have used the standard installation everything you installed is in /home/phablet? I believe so, as the above this directory everything is read-only.

  • Administrators

    @ronnietucker The FHD image seems to not work yet... Will post here as soon as there's news on that.

    I updated our bug tracker list:

  • @wgarcia said in Help testing new legacy image:

    you have used the standard installation everything you installed is in /home/phablet? I believe so, as the above this directory everything is read-only.

    The apps are somewhere else, and currently I did not find out a way how to backup the click packages or make a list of installed apps. But tbh I can live with having to reinstall the app itself as long as its data is here. @MariusQuabeck tells me however that /home/phablet is not everything needed for a full backup, so for sure we need a better method over time (system daemon + control GUI probably)

  • @Flohack Yes, I reinstalled the apps first, then I rsync my /home/phablet and rebooted, and the phone was as far as I can tell as it was before reflashing, apart from some configurations here and there that I had to redo.

  • @NeoTheThird - Ah. OK. Thanks for letting me know. I'll keep an eye out for a fix.

    I assume the bootloader screen is the text one with a menu and where you can move up/down with the volume keys? Just checking to make sure I'm on the right screen. 😃

  • Administrators

    @ronnietucker No, that's either the recovery or factory mode screen. It's a little confusing at first. I (on the M10 HD "cooler") found my way through it with trial and error... I hope to be able to write a more detailed guide soon.

  • @NeoTheThird - I was probably in the factory screen as I did see a setting for running tests on the various pieces of hardware (GPS, WiFi, etc.). Well, since the image doesn't work, I'm glad I was on the wrong screen then! 😃

  • Tested a bit of things for the BQ E5 (vegetahd) image so far:

    • Camera: OK

    • Microphone: OK

    • Display: OK

    • BT audio: OK

    • Wifi: OK

    • Apps install/Clicks: OK

    • Push notifications: OK

    • Sensors/Screen rotation: OK

    • Browser: OK

    • Gallery: OK

    • Clock/Alarms: OK

    • Weather: OK

    • ContentHub: OK

    I'm planning to run some further test from the Checkbox suite in the following days.

  • Hmm, Installation on MX4 seems a bit difficult, but that is possibly just because I can't boot any image from fastboot - and I never could.

    So here is a way to make this work (I wanted a clean install, so here is one way to do it):

    1. I had to use this tool to clean my device (albeit booting recovery failed):
      sudo snap install magic-device-tool --devmode
      magic-device-tool (choose arale, Ubuntu Touch installation and a clean install to wipe all data)
      It exits with error that it can't boot recovery, but that should be ok since it fashed some partitions before.

    2. Once cleaning is done, I flashed adb enabled recovery:

    3. After this I first had to boot into recovery and flash regular Ubuntu image for some reason as UBports image didn't work for me initially:
      ubuntu-device-flash touch --device arale --channel ubuntu-touch/stable/meizu.en

    4. Finally I booted into recovery again and executed the following command after which UBports image worked just fine:
      sudo ubuntu-device-flash --server= touch --channel=ubports-touch/legacy --device=arale
      (I had to specify the device as it didin't recognise it correctly.)

  • I'm trying to install the new images on a Bq E5. I'm able to get into fastboot mode in my phone, I connect the phone with an USB cable to my Ubuntu system (I'm running currently Ubuntu 17.04), but it seems that my Ubuntu system does not see my Ubuntu Phone. Nothing appears with "lsusb", and when I try the "ubuntu-device-flash" command, it says it is waiting for the device to be put into fastboot (which it is) and does nothing.

    Can I flash the image directly from the phone? I can upload (with ssh) the "img" file to my phone, so if I could I would do it directly there.

  • @wgarcia

    If fastboot devices doesn't detect your phone while it's booted to the bootloader, try a different USB port and USB cable. Ensure you're plugging in to a USB 2.0 port on your computer.

  • @UniSuperBox Thanks, it turned out I had changed to mtp only with the tweak toool, when I changed to USB I could mount the device and now I'm flashing the uBport image, crossing my fingers....

  • Yes!, success!, I'm in the uBports ship with my BQ E5!

  • @wgarcia Congratulations!

  • Has anyone tested the Aquaris E4.5? My Aquaris I use as a main phone, so I have some fear of flashing the device

  • @wgarcia What is the restoration procedure?
    should you install openssh-server on the phone?

  • What I did is the following. You do not need to install openssh-server, you just need to enable the ssh client in the phone. Get a shell with "adb" and execute this command:

    android-gadget-service enable ssh

    I also use an application called "net-info" to figure out the IP of my phone in the network where it is connected through wifi, say it is

    So before wiping out my data I make a copy in my computer of /home/phablet, say in a directory called bq-phone in your home:

    rsync -avz - - delete -e ssh phablet@ /home/myuser/bq-phone

    This will create a directory called "phablet" in "bq-phone" with a copy of what you have in your phone. Of course you could do this I believe in a SD-card directly in your phone, in this case without "ssh".

    Now, after reflashing the phone, I followed these steps:

    1. I created a passcode and enabled developer mode
    2. I accessed again to a shell in my phone and enables "ssh" again
    3. I copied the public gpg key from my computer to /home/phablet/.ssh/authorized_keys. For this one I had to "adb push" to the phone the file ( generated in the .ssh directory of my computer), and then append it to the authorized_keys file:
      cat >> .ssh/authorized_keys (this in the phone shell)
      Then I installed first net-info to figure out the IP of the phone again, so that I can use ssh.
    4. I reinstalled all the applications that I had.
    5. Then I used rsync to restore all the data in the phone:
      rsync -avz - - delete -e ssh /home/myuser/bq-phone/phablet phablet@

    I restarted the phone and voilà!, everything looks exactly the same, but I'm running now the uBports image.

  • Sorry, in my explanation above, the gpg-key upload and appending to authorized_keys in the phone has also to be done when you first enable ssh to backup your data.

Log in to reply