Help testing new legacy image



  • @timppa
    Hi there,
    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?
    Cheers

    MrH



  • @wgarcia Ohh. Ok. Understood.



  • There seems to be a problem with phone overheating while browsing the net on mobile connection(4g, H) and also on wifi. The same problem was reported on original Ubuntu image. Nothing else makes the phone hot, only browsing the net. And it's eating a lot of battery therefore.

    It might be because of the network strenght or a low signal quality, or long distance from a router, I don't know, but it's happening, there might be a problem with Browser though. Clering the history and cache doesn't help.
    I wonder if on other devices there is such a problem.
    I know there is a problem on MX4 and Pro 5, how about BQ?

    Apart from that, there was nothing else spotted, all running well, not a single crash.crash.

    Meizu Pro 5



  • Hi @MrHoliday

    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?

    Yes, you would need to have at least some Linux distro, preferably Ubuntu of course.
    For installation there is a clear guide which you can follow here: https://devices.ubports.com/#/frieza

    For the boot time, there seems to be a a bug report in LP: https://bugs.launchpad.net/ubports-frieza/+bug/1693055



  • @Lakota
    i had for months problems with usb-conection. the simple reason was the diffrence between otg-usb and normal usb cable. in this case i was the failure ;0)

    https://android.stackexchange.com/questions/51035/what-is-the-difference-between-usb-on-the-go-otg-and-usb-host-mode



  • Have now flashed my m10fhd as well. All went well and at first glance appears to be running quicker in normal tablet mode, have yet to try connecting keyboard etc. Thanks to all involved for keeping this going.



  • Hey guys,

    I'm running my M10FHD with the UBports image. I confirm it's way faster but I really miss the XApps.
    Any news about Firefox/LibreOffice ?

    Edit : I'm using it with a mouse and a keyboard : it works !



  • @dada
    libre office needs a lot of temporary ram...in normal desctop-pc's its run by 2 gb ram shiny. if you have a play-and-fun-old-raspberry with max 1gigabyte ram... os needs ram... abd the rest is not enugh to run all libre-task shiny in ram. so a lot of running libre-task goes to the swap and there its needs time to loading again in the ram. in short i would say.. mobile phones with 1 gigabyte ram would run libre office very lame and lousy... you would not realy like to work so... but newer phones with 2 gb ram ( ubport core-devices...that would be fun)



  • @dada - I have the Ubports Touch on my M10 FHD and the 'Desktop Apps' scope lists LibreOffice, GIMP, Firefox, etc.



  • I don't see the Open Store in Ubports Touch. Should I install it myself, or will that affect currently installed apps?



  • @ronnietucker said in Help testing new legacy image:

    Ubports Touch on my M10 FHD

    Hi Ronnie,

    is the UBports running on your M10 FHD?
    I also have the M10 FHD and tried today flashing it, but it's not working. I tried via commandline by:
    sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=./recovery-frieza.img
    But no success.
    At the end I got this screen for hours: https://img4.picload.org/image/riacglii/grafik.png
    See bottom left "Installing Ubuntu update"
    If I choose reboot manually after 15 min. it's rebooting to install Ubuntu 15.04 OTA-15

    If I use the Magic-Device-Tool, it's the same

    Alex



  • @ronnietucker
    hi mr tucker

    i had a performance-question.
    the bq m10 has 2 gb ram.
    so in personal-pc' its ok for running and working with libre-office. what is your work- expierience with libre-office on the m10 on ubuntu touch?
    is it ok or freeze/ slow down by normal working?



  • French
    English
    FRENCH

    Bonjour, j'ai eu le même problème, il faut remplacer la majuscule par la lettre normale sudo et non Sudo 👍
    ENGLISH
    Hello, I had the same problem, it is necessary to replace the capital letter by the normal letter sudo and not Sudo
    Share this translation

    Improve translations
    Search hands-free
    Say "Translate love into French" with the Google app.
    NO THANKSTRY THE APP
    Read a sign in another language, instantly.
    NO THANKSTRY THE APP
    Tap to Translate
    Now, Google Translate works in any app.
    NO THANKSTRY IT


  • Administrators

    @ronnietucker said in Help testing new legacy image:

    I don't see the Open Store in Ubports Touch. Should I install it myself, or will that affect currently installed apps?
    @dada - I have the Ubports Touch on my M10 FHD and the 'Desktop Apps' scope lists LibreOffice, GIMP, Firefox, etc.

    That is the stock canonical image. The UBports image is not shipped with X Apps, but with the openstore.



  • @NeoTheThird then some is definitely awry.

    I ran the command:
    sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=[Downloaded adb recovery image]

    Using the recovery image from Ubports which did wipe my device, but now I seem to be, sure enough, back at OTA15.

    What the... o_O

    Thought: should I have wiped the cache etc when installing the recovery image?


  • Administrators

    This is weird. Others were experiencing issues with the FHD as well, let me talk to @mariogrip and try to figure this out... You don't happen to have the terminal output of the flashing process at hand, do you?



  • @NeoTheThird I don't I'm afraid.

    I'm trying to flash it again. I've wiped the cache before flashing this time, but I think I might end up the same as @WLBI as I can see the dreaded 'Installing Ubuntu update' in yellow at the bottom of the screen.

    I'll keep the terminal logs this time though.



  • @NeoTheThird Terminal output for this flash:

    ronnie@ronnie-desktop ~ $ sudo ubuntu-device-flash --server=https://system-image.ubports.com/ touch --channel=ubports-touch/legacy --bootstrap --recovery-image=/home/ronnie/Downloads/Linux\ Distros/UBports\ M10/recovery-frieza.img
    [sudo] password for ronnie:
    2017/05/27 13:09:18 Expecting the device to be in the bootloader... waiting
    2017/05/27 13:10:02 Device is |frieza|
    2017/05/27 13:10:03 Flashing version 4 from ubports-touch/legacy channel and server https://system-image.ubports.com/ to device frieza
    2017/05/27 13:10:06 Cache formatting was not successful, flashing may fail, check your partitions on device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/pool/ubports-2fa71268a7de2699e17a1d60f518020e9a26036a57e5add22388cd572f781a66.tar.xz to device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz to device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/ubports-touch/legacy/frieza/version-4.tar.xz to device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/gpg/image-signing.tar.xz to device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/gpg/image-master.tar.xz to device
    2017/05/27 13:10:18 Start pushing /home/ronnie/.cache/ubuntuimages/pool/device-6d8854a9ee3fd34df55940ae6e19a6968b14418a7fd01fbf1e17624d0129ef23.tar.xz to device
    2017/05/27 13:10:18 Done pushing /home/ronnie/.cache/ubuntuimages/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz to device
    2017/05/27 13:10:18 Done pushing /home/ronnie/.cache/ubuntuimages/gpg/image-signing.tar.xz to device
    2017/05/27 13:10:18 Done pushing /home/ronnie/.cache/ubuntuimages/gpg/image-master.tar.xz to device
    2017/05/27 13:10:18 Done pushing /home/ronnie/.cache/ubuntuimages/ubports-touch/legacy/frieza/version-4.tar.xz to device
    2017/05/27 13:10:46 Done pushing /home/ronnie/.cache/ubuntuimages/pool/device-6d8854a9ee3fd34df55940ae6e19a6968b14418a7fd01fbf1e17624d0129ef23.tar.xz to device
    2017/05/27 13:11:21 Done pushing /home/ronnie/.cache/ubuntuimages/pool/ubports-2fa71268a7de2699e17a1d60f518020e9a26036a57e5add22388cd572f781a66.tar.xz to device
    2017/05/27 13:11:21 Created ubuntu_command: /home/ronnie/.cache/ubuntuimages/ubuntu_commands662566973
    2017/05/27 13:11:21 Rebooting into recovery to flash

    ... but hangs with the yellow text (on the M10 FHD) saying: Installing Ubuntu update

    After several minutes I reboot and I'm back in OTA15. Weird!



  • @mariogrip said in Help testing new legacy image:

    Is there someone that want to help us test our new images?

    Hi, I did a little bit more testing on the mx4. With v2 I have the issue that my WLAN connection "freezes". That means indicator still shows connected WLAN, but the mx4 is not able to receive anything. I need to switch flight mode on/off. After that it works again for some time. There is no switching between different WLANs / SSID / Hotspots. I just have a single access point.

    Can anyone else confirm this issue?

    Thanks



  • Decided to try the magic-device-tool to see if that'd make any difference. Nope!

    Pretty much the same output (below) as flashing via terminal.

    =======

    Created filesystem with 11/51296 inodes and 6651/204800 blocks
    target reported max download size of 134217728 bytes
    erasing 'userdata'...
    FAILED (remote: unknown command)
    finished. total time: 0.002s
    Creating filesystem with parameters:
    Size: 4194304000
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8000
    Inode size: 256
    Journal blocks: 16000
    Label:
    Blocks: 1024000
    Block groups: 32
    Reserved block group size: 255
    Created filesystem with 11/256000 inodes and 34123/1024000 blocks
    target reported max download size of 134217728 bytes
    erasing 'system'...
    FAILED (remote: unknown command)
    finished. total time: 0.002s
    erasing 'recovery'...
    FAILED (remote: unknown command)
    finished. total time: 0.002s
    rebooting into bootloader...
    OKAY [ 0.002s]
    finished. total time: 0.253s
    Please wait

    2017/05/27 21:13:42 Device is |frieza|
    2017/05/27 21:13:42 Flashing version 5 from ubports-touch/legacy channel and server http://system-image.ubports.com to device frieza
    2017/05/27 21:14:06 Cache formatting was not successful, flashing may fail, check your partitions on device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/ubports-touch/legacy/frieza/version-5.tar.xz to device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz to device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/gpg/image-master.tar.xz to device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/pool/ubports-f683ce0eac8665810600110821a12e5ad615e5d509507c90cea46a0f254adc23.tar.xz to device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/gpg/image-signing.tar.xz to device
    2017/05/27 21:14:17 Start pushing /home/ronnie/.cache/ubuntuimages/pool/device-6d8854a9ee3fd34df55940ae6e19a6968b14418a7fd01fbf1e17624d0129ef23.tar.xz to device
    2017/05/27 21:14:17 Done pushing /home/ronnie/.cache/ubuntuimages/ubports-touch/legacy/frieza/version-5.tar.xz to device
    2017/05/27 21:14:18 Done pushing /home/ronnie/.cache/ubuntuimages/pool/keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz to device
    2017/05/27 21:14:18 Done pushing /home/ronnie/.cache/ubuntuimages/gpg/image-master.tar.xz to device
    2017/05/27 21:14:18 Done pushing /home/ronnie/.cache/ubuntuimages/gpg/image-signing.tar.xz to device
    2017/05/27 21:14:44 Done pushing /home/ronnie/.cache/ubuntuimages/pool/device-6d8854a9ee3fd34df55940ae6e19a6968b14418a7fd01fbf1e17624d0129ef23.tar.xz to device
    2017/05/27 21:15:20 Done pushing /home/ronnie/.cache/ubuntuimages/pool/ubports-f683ce0eac8665810600110821a12e5ad615e5d509507c90cea46a0f254adc23.tar.xz to device
    2017/05/27 21:15:20 Created ubuntu_command: /home/ronnie/.cache/ubuntuimages/ubuntu_commands360842843
    2017/05/27 21:15:21 Rebooting into recovery to flash

    Wait until it reboots on its own!
    Do not reboot manually!

    Cleaning up..

    Exiting script. Bye Bye

    ======

    And, from there, even after waiting for 25 minutes I see the infamous yellow 'Installing Ubuntu update' text. 😞

    0_1495916544141_IMG_20170527_203521.jpg

    If I choose 'reboot system now' it boots up, again, back to a fresh install of OTA-15!


Log in to reply