WiFi password loss after each and every reboot on MEIZU Pro 5

  • @UniSuperBox I had 3 different Pro 5, 2 of them were 64GB versions, one LTE, one TD-LTE and one LTE 32GB version and have never such a problem. None of those devices were Ubuntu Touch edition. So the issue might be somewhere else? Maybe a different wifi chip/version/revision and therefore not fully compatible?

  • @UniSuperBox
    @UniSuperBox But my Nexus 5 works just fine on Android(any ROM) so how can the efs partition get corrupted, I don't know. I might try to restore the efs from Android backup, will see if that helps. Thanks for the tip. Did not check the wifi address, might do that as well.

  • @Stefano Hm, this doesn't make sense then. If it works with Android sending to manufacturer is certainly not an option here. If that's the case then it would mean the EFS doesn't get destroyed but rather Ubuntu Touch has issues reading it.

    @UniSuperBox Would there be a way for users to debug this somehow? It would be great if this thing could be solved as it seems to be recurring quite often in the forums/on github.

  • @zubozrout well, that's what I think, can't be corupt is is working fine on Android. I tried to switch channels, full wipe, full Official Nexus firmware, wipe, install UT by Ubports and wifi issue appear.
    Btw, I used this phone long time ago as dual-boot with Android, when ta.semnice channel was available and was testing UT back then, yep, wifi worked well. So go figure.

  • @Stefano I had Nexus 7 2013 deb and tasemnice was the only server that provided fully working Nexus 7 deb images. I've had Ubuntu Touch installed there both in dualboot mode as well as the only system present over the years and never experienced any WiFi issues. When tasemnice stopped working, I also tried UBports image from Nexus 7 flo on the device and it was also working fine in this perspective. So I've never seen this issue myself.

    From what you say though it could mean the build was done differently when tasemnice was still active. But maybe you would have experienced the same issue with official Canonical images back then.

  • @ubuntoutou @Stefano @zubozrout I'm the one who first complained about the "Wi-fi" issue in the thread located HERE. I'm glad that finally someone else is raising the problem...I don't feel myself alone anymore in this crusade :). Now, I read with deep interest what you all wrote above and I'd like to proactively contribute to the discussion with my findings related to the Meizu Pro5. Similarly to @ubuntoutou, my device is a 64 GB/4 GB RAM, which was dispatched to me with installed chinese stock FlymeOS and, in order to make this device eligible to be flashed with UT, I needed first to follow the particular procedure to convert it from chinese to international device. Here my findings:

    • What described by @ubuntoutou is exactly the same issue I have every time I re-boot the phone;

    • I'm not convinced it could be a problem due to neither a faulty EFS partition nor to NVRAM as suggested by an other Forum user, because, as mentioned by @Stefano, when I flash again FlymeOS, as I already did many times in order to find the culprit, the wi-fi credentials are correctly stored and pushed at every reboot. When I flash back UT, it just doesn't work anymore.

    • I didn't notice before that the wi-fi address changes at every reboot. I can confirm this behavior, thanks to @UniSuperBox.

    • The only workaround I found to overcome the problem is related to the Anbox installation: when I first installed Anbox, surprisingly the issue was resolved (please read the relevant Github issue). I dug into the Anbox files to find out if I could isolate the part of code responsible for that and to maybe write a script useful at the scope, but, since I'm not a developer, I didn't accomplish completely the task. What I understood is that Anbox setup files create a bridge to the network and this bridge somehow resolves the issue. Since then, I gave up with Anbox because it caused to me other undesirable side effects and never tried to install it again, not even after it was made a sensible progress for the installation procedure and images (I'm talking about this thread by Marius).

    What I believe is that the solution is closer than we think but we definitely need someone who can point us where to look at and who can suggest the path forward. Needless to say, I'm keen to spend some additional time at it in order to resolve that issue.

    Thank you all very much.


  • @matteo Probably only @mariogrip can help here as he also have Pro 5 ( don't know if also have the issue with wifi ) , but like previously he fixed the loss of mobile network on Pro5, he might have more to say to this issue on Pro5.

  • Just to emphasize that the issue is not only the fact that the Pro 5 came with Android, I have a 64GB storage, 4GB RAM international version FlymeOS Pro 5 that I got off of Amazon Italy. It was the regular pain to Flash to UTouch.
    One thing that might be different to how you guys installed UT on your devices is that to get my Pro 5 on 16.04 initially I used the link @Stefano provided in this post. But I don't know if that has any relevance at all ...

    EDIT: I forgot to mention that I do not experience this issue. WIFI passwords are retained on my device.

  • @Stefano I don't think Marius is the only one to have the skills to help us in this. Also Dalton does and even all the other UBports developers. Whoever can point us to the right direction is very welcome. Since this seems not only affecting the Pro5 but also other very well known devices, as the Nexus 5, maybe the interest at this topic will raise.

  • @arubislander I also exploited a TWRP file Stefano pointed to me to install a previous version of UT to boot with, in order to be able to update to the latest image of UT. I don't think the problem could be caused by this let's say "short-cut" to by-pass the UBports installer, because after that I performed several times a brand new UT OS installation, in this case employing the official UBports installer and the wi-fi issue was always there.
    When you say Android which OS are you talking about? I'm asking since I believe the Pro5 only comes with stock FlymeOS installed, which is an Android OS.

  • @matteo said in WiFi password loss after each and every reboot on MEIZU Pro 5:

    When you say Android which OS are you talking about?

    I edited my post to clarify the reason for it. When I say Android I mean FlymeOS

  • @arubislander now your post is more clear, thank you. Anyhow, you have the international version. I believe the problem resides in the combination chinese version + 64 GB sd card, since, if I'm not wrong, @Stefano has got the chinese version, but with the 32 GB sd card.

  • @matteo Could it then be that something important gets overwritten when converting the Chinese version to an International version before flashing to UTouch?

  • @arubislander I don't think so, I just followed the procedure. Yes, I had to struggle a bit since the beginning when I needed to gain root access but then all went smooth. As said, anytime I flash back FlymeOS, the wi-fi connection starts again to work as expected.

  • @Stefano You said you had 3 different Pro 5. Did anyone of them had 4GB of RAM?

  • @matteo Chinese, but LTE version, not TD-LTE ( the latter one might have different wifi chip revision...)

  • I followed this excellent guide when re-partitioning before installing Ubuntu Touch 16.04:

    All went well except that I had this error message:
    Note: sector size is 4096 (not 512)
    Found valid GPT with protective MBR; using GPT

    and then this message as well:
    GPT PMBR size mismatch (15267840 != 15267839) will be corrected by w(rite).

    I have no idea if this is relevant or not.

  • @ubuntoutou yes, 1 of them, TD-LTE Chinese

  • No one has said if it is possible to install the Ubuntu Desktop packages $ lshw (list hardware) or $ hwinfo (hardware info) on Ubuntu Touch. This could tell us if there is any variation at the hardware level between MEIZU phones with the WiFi password issue and those same phones without this issue.

  • @matteo No disrespect to any Ubports developer, I was just mentioning @mariogrip cos he is known to have this device and have the experience with it. Yeah, anyone with knowledge can fix it.

Log in to reply