WiFi password loss after each and every reboot on MEIZU Pro 5

  • @advocatux yes this is it. Thank you advocatux :). @ubuntoutou anyway if you wish to use it, consider this is not an official tool advised by UBports but you have to use it carefully, because apt-get command is not supported on UT OS.

  • @doniks Nexus 7 were built with more hardware revisions, so this is interesting information, seems it might be a hardware compability issue.I couldn't install UT on Nexus 7, untill it got fixed by OTA-7, so this might be simmilar issue for Pro 5 and some Nexus 5 users as well. It's baffling.

  • @Stefano I also have a Nexus 7 (2013) and I couldn't get UT to boot properly until I replaced the version of Android I had with an older version of Android. I have no issue with the WiFi password on this tablet. The nexus 7 works remarkably well with UT.

  • Yes @matteo I would prefer ATU to be on the Open Store. I haven't installed it. I would prefer to install lshw and hwinfo directly with apt-get install or dpkg -i. But there are some dependencies. I know we are not supposed to use these Ubuntu Desktop tools on Ubuntu Touch. However I have managed to install htop with apt-get without much trouble. There is now an app in the Open Store for htop but it may just install htop with one of these Ubuntu Desktop tools, I don't know.

  • @ubuntoutou Good point, you can maybe try to downgrade first your phone on a old flymeos version in order to get different firmware and then install again UT. if that works, try progressive upgrades of flymeos ...

  • The problem is that I am still in the dark as to whether the EFS partition is the issue or not.

    When you wipe or format with TWRP, there are some options to choose what to wipe and what to keep. Could it be that those of us who wiped everything loose the WiFi password while those who didn't have no such loss?

    I also don't know if re-installing Android would restore the EFS partition or not.

  • @ubuntoutou If your phone works well under Android, it is not an issue with a broken EFS partition. Under Android if you get your WiFi, Bluetooth and IMEIs working well, then the problem can be more related to the firmware. This is only my thinking... Do you get access to the log files of previously connected Wifi router to your phone ? If yes, try to read the previous log to see if you can find your old wifi mac address in your dhcp offered lease history, then compare it with the one of your phone under Android, like that you will be able to see if Android is not able to read the EFS partition and take a default MAC. But again, if that was the case, you should see the error message in your logs. what kind of WiFi band is your actual phone compatible ?

  • @AlainW94 I haven't tried to re-install Android and I am a bit reluctant to do so unless I have some evidence that this is the way to solve the password issue. I haven't tried the WiFi on Android. I replaced the factory OS with UT as soon as I got the phone. I have no reason to think that there was any WiFi problem with the factory settings. I don't know what WiFi "log files" are nor where to find them. I also don't know what WiFi band my phone is using.

  • @ubuntoutou I understand that you won't came back to Android ... anyway if you did it it's really easy to do, simply boot on twrp, copy the update.zip on your internal storage then use the install button from twrp and select your zip. The phone will reboot on flymeos. to switch back to UT, flash the recovery of Ubuntu, do a normal boot, activate the dev and debug mode, run the ubports-installer ... you only need the correct flymeos version, the one that has the bootloader unlocked or unlockable. I didn't read all your posts from the begening, sorry, was your issue present since the begening ?or since an ota update?

  • @AlainW94 from the beginning.

  • @UniSuperBox said in WiFi password loss after each and every reboot on MEIZU Pro 5:

    The EFS partition is custom to the phone. Since you have Wi-Fi working correctly when you have Android on the device, it is unlikely that the EFS is the problem. It's more likely that your unsupported device has some hardware difference from our supported devices.

    any idea how to investigate/fix this?

    I do see that I get different mac addresses after reboots

    adb shell ip link show wlan0


    I see "my" mac here


    instead of, I guess this line:

    and that file has a change date of today

    ls -l /android/data/misc/wifi/
    total 48
    drwxrwx--- 2   1010 1010  4096 Mar  3 22:07 sockets
    -rw------- 1 system 1010  6224 Mar  4 22:16 WCNSS_qcom_cfg.ini
    -rw------- 1 system 1010 29776 Mar  4 22:16 WCNSS_qcom_wlan_nv.bin
    drwxrwx--- 2   1010 1010  4096 Mar  3 22:07 wpa_supplicant

    and I have a file

    cat /android/system/etc/init.flo.wifi.sh 
    # Workaround for conn_init not copying the updated firmware
    rm /data/misc/wifi/WCNSS_qcom_cfg.ini
    rm /data/misc/wifi/WCNSS_qcom_wlan_nv.bin
    logwrapper /system/bin/conn_init
    echo 1 > /dev/wcnss_wlan

    that rm's this file

  • @ubuntoutou can you try this :

    cat /var/log/syslog |grep wl0

    For me it give :

    Mar 4 23:01:48 ubuntu-phablet kernel: [ 4877.390473] [4: NetworkManager: 3207] [c4] ** Firmware version = wl0: Nov 24 2015 11:23:00 version 7.45.71.r5 (r587357) FWID 01-ec3fd0c **

  • I might have a fix for my nexus 7. Not sure whether this applies to other devices. And I'm, not sure whether this is save in all cases to do. Proceed with caution

    strace /system/bin/conn_init shows that it looks for this file open("/persist/wifi/.macaddr", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory), but indeed, I don't have this

    root@ubuntu-phablet:~# find /persist/

    After I created them,

    mkdir /persist/wifi 
    echo 001122deadbf > /persist/wifi/.macaddr

    that mac address remains and wifi is reconnected ok after reboot.

  • For a Meizu Pro5 the WiFi MAC address should start by 68:3e:34, this is the vendor id of MEIZU Technology Co., Ltd. the 00:11:22 vendor id is from CIMSYS Inc.

  • @AlainW94 oh, right. You can of course use a different number! You probably should. I just made one up. The "fix" is just that it remains the same after reboot

  • @matteo ok, thought it might help,as it is annoying reentering, as there is no option to reconnect.
    all your "symptons", are the same as on my m10 fhd.
    except the "nvram 0x10 error " .
    did you try the "skyneel" fix tho.

  • @AlainW94 "cat /var/log/syslog | grep wl0" gives no output at all.

  • @ubuntoutou Strange I have two Pro5 and both have this entry, can you please post your syslog ? Is your Wifi activated ?

  • I'm glad to come in here now with my experience. Which is exactly the same as described by @ubuntoutou and @matteo ; and specifically I have a MEizu Pro 5 TD-LTE edition. Albeit, as it is my stable daily driver device, I do not choose to flash it to the devel channel and install Anbox in the hope of getting a fringe benefit that it might somehow fix this issue. I have raised this before on the Telegram supergroup, but unfortunately to little avail. I suggested that the donors could crowdfund the developers to obtain all Pro 5 variants, including the TD-LTE version which has perennial availability on eBay, to triage problems which are observed on device flashes apart from the vanilla 32GB bespoke 32GB version. @dobey said to me in response (partially with regard to hotspot problems on the device, but also to this issue): "and let's say some dev agreed to help with the purchase of said device. what happens if they can't reproduce the same issue?. Well, this concern seems nullified given the confirmations of the problem by other users in this topic and elsewhere. Now if he/the other developers want other users to back up the hotspot problems to further justify the purchase of this specific device, well I'm sure those hotspot problems have been cited by other users in this forum, on the supergroup and certainly on issue reporting pages e.g. Github. But I would be happy to help move that forward by summarising the history of those bugs and clarifying confusion/issue drift where ever possible. So most certainly it seems that the next step is to create a funding tier to permit the 64 GB variants of the hardware to be purchased by the devs, and so that they can then look into these problems and hopefully triage them.

  • @AlainW94 I tried again and I got the following output for syslog:

    cat /var/log/syslog | grep wl0
    Mar  7 14:44:23 ubuntu-phablet kernel: [    8.877130]  [6: NetworkManager: 3204] [c6] Firmware version = wl0: Nov 24 2015 11:23:00 version 7.45.71.r5 (r587357) FWID 01-ec3fd0c

Log in to reply