Desktop apps

  • @matteo Good. What device device are you using ?. Mine work on the Bq devices but wont run on my nexus 5

  • @zubozrout Hi. Thanks for this "How to" - it's very useful.

    I have a Libertine container. And I have two apps showing in it. However, when I click on either app, they don't boot. Did I miss a step?

  • @3arn0wl If your using a nexus 5 they wont run but they should all work on the Bq devices. Dont know about the others as I don't have them.
    Not sure about a fix for the nexus as yet or even what the problem is.

  • 🙂 Thanks for that, @Lakota - I am running Touch on a Nexus 5.

  • @Lakota I have BQ Aquaris E5. I installed also Gimp and it seems working good.

  • Yeah I can confirm that libertine is not working -well at least- on the N5.. (not at all for me)

  • I'm now running r12 from the release channel. The Xapps still don't work on the nexus 5. Has anyone tried to delete and re install libertine container to see if that fixes it? If not I'll give it a go in the next few days

  • When you say that it does nothing, does the script literally output nothing and then quit? Or does it attempt to run debootstrap and debootstrap fails?

    You may possibly be able get away with remounting your root as read-write using sudo mount -o remount,rw / and then reinstalling libertine from the overlays using sudo apt-get --reinstall install libertine python3-libertine-chroot python3-libertine libertine-tools liblibertine1 which should reinstall ALL of the libertine packages (mind you I made this list from my 16.04 WSL so this list may differ from the list in 15.04 stable-overlay).

    After reinstalling, try building a container using a command like libertine-container-manager create -i applications -n Applications -t chroot with no other options (for instance, the distribution argument is useless on our systems because if you aren't using an LXC container for libertine, you are restricted to Vivid.

    I'm actually wondering if your libertine installation is for some reason attempting LXC containers (what version of Ubuntu are you running 15.04 or 16.04? That could tell us a lot, 16.04 SHOULD attempt LXC by default since 16.04 should support LXC.)

    As for device unauthorized, open System Settings and go to Developer Mode options, then revoke all authorizations and plug it back into your machine, see if you get a device authorization pop-up on the tablet.

  • @Tonoxis Thanks for the advice. I am currently on 15.04 r14 on the RC channel and have not tried a reinstall since swapping over from stable. As mentioned above(somewhere 😉) I used the same process as on my bq m10 and 5 hd and they are both fine still and both are on RC now. So it still appears to be a nexus 5 issue.
    Will give it a go over the weekend. Thanks again.

  • @Lakota I'd be happy to try to help you out with this issue. Any logs or behavior you may see while attempting my previous suggestions will help me troubleshoot with you.

    If those suggestions help you, feel free to let me know so I can help others.

    As for the package list I posted in my earlier post, you can omit libertine if you choose as that is the GUI tool for managing the containers and won't be useful for creating a container on 15.04 and also isn't a required package for libertine support, though it can be useful for adding PPAs and standard repositories, adding or removing packages, etc and can be much more intuitive than managing it with the CLI.

    I did forget to add xmir to that list though, wouldn't hurt to reinstall it as well.

  • ok have destroyed old container. Followed your instructions then reinstalled firefox and libreoffice to -i applications. Restarted phone and the problem is still there. tap on app to open it, get black screen with app name, screen goes totally black, shuts down and back to the X app scope. Logviewer has the following
    fatal service error:
    (EE)failed to conect to Mir:failed to connect:not accepted by server

    Sorry but cant spend more time on it just now. Thanks for the help so far. any further help much appreciated. will rerun above again tomorrow if I can just to see

  • That's really odd. It seems as though the application isn't connecting to the Mir server, however I'm afraid that, at that point, I'm no longer very helpful as I'm not sure how to troubleshoot connections to Mir. Perhaps a dev could shed some light on what's going on here? (anyone?)

    Sorry about that... specifically, it sounds like Xmir isn't connecting to the Mir socket, says not accepted by server which implies that the connection to Mir was rejected.. But it doesn't say where, how or why it was rejected 😞

  • @Tonoxis Thanks anyway fir the info. Thats two methods now with slight differences that get the same result with libertine on the nexus 5, and same output on logviewer.
    Same here its way more than I can work out but I'm willing to try any other methods that may come along to get this fixed.
    Thanks again for the help

  • @Lakota Had a good look at bug reports and looks like waiting for 16.04 to get this fixed. The fix should come for nexus 5 but understandably not top priority at present.

Log in to reply