Ubports with a jbl go speaker

  • I have the old JBL Go version and yup it has issues with bluetooth. it connects but won't work and it'll hang the bluetooth connection. Haven't tried the new version though. Hopefully it'll work so that I can use my speaker before it breaks 😃

  • @advocatux said in Ubports with a jbl go speaker:

    @Ghostrider there's a new bluetooth version for testing. If you know what you're doing and you are comfortable tinkering, you can give it a try. Run sudo ubports-qa install xenial_-_new-bluez. If after doing that your device gets stuck (because it's trying to restart bluetooth) you just need to reboot your device.

    That new version works way better than the old one btw 🙂

    I'm an FP2 & JBL GO user too and I can't use the speaker with Ubuntu Touch too. I've tried your advice and use new bluetooth version, but the outcome is the same. You connect to speaker, speaker beeps, that it is connected, but no music is allowed to play in music app, and you can't disconnect the speaker, or shut down bluetooth. You have to restart device.

    However my other JBL Clip 2 speaker works with UT. And both, with the JBL GO speaker, are working with my Ubunu Mate 18.04 laptop.

  • @advocatux I tried your suggestion, I've a terminal return : no space on /var/cache/apt/archives
    Even if I've debian since many years, I'm still a newbie, can we use UT terminal like a debian terminal ? Can we use apt-get dist-upgrade ?
    Or may I use libertine to install ?

  • @Ghostrider said in Ubports with a jbl go speaker:

    @advocatux I tried your suggestion, I've a terminal return : no space on /var/cache/apt/archives

    This is normal for FP2, since last 2 or 3 OTAs. You can try to free some space using these commands extracted fom another post:

    $ sudo mount -o rw,remount /
    $ sudo rm -r /var/cache/apt
    $ sudo tune2fs -m 0 /dev/loop0

    If previous commands can't free enough space for /var/cache/apt/archives, you can temporary mount-bind the folder to somewhere else with more space, as described in this post:

    $ sudo mkdir -p /userdata/system-data/var/cache/apt/archives
    $ sudo mount -o bind /userdata/system-data/var/cache/apt/archives /var/cache/apt/archives/

    After this you can try the @advocatux suggestion and it should work without free space problems. Maybe you will have more luck.

    I tried the sudo ubports-qa install xenial_-_new-bluez, but it didn't finish and got stuck on bluetooth restarting. After rebooting, as I wrote in previous post, no improvement was observed. And because of the freezing on bluetooth restart, I couldn't revert things back with sudo ubports-qa remove xenial_-_new-bluez, so full image reinstall was needed. Has anyone more luck with this, as I had?

  • @jezek after the freezing and rebooting, it should be working fine but it seems it wasn't like that in your case (no idea why though).

  • It doesn't work for Pro5 either. It gets stuck and then, upon reboot, if I run again sudo ubports-qa install xenial_-_new-bluez it says "E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem." And when run sudo dpkg --configure -a it gets stuck again at "Setting up bluez (5.50-0ubuntu3) ...".

  • Tried the new-bluez install today on my OPO. All appears to have worked OK. Tested with Bose Soundlink Mini. This is just for info really and proof it works at least on OPO.

  • @mihael

    Has an issue been raised against this on GitHub?

  • @arubislander I don't know, I didn't even know there is work done in this direction but I am so glad there is and I wanted to try it...

  • @mihael Same issue on my nexus 5. Now the BT is broken 🙂

  • @malditobastardo bluetooth is probably broken on all devices. I hope the Pinephone won't have such an issues, as it might be mine next UT device 🙂

  • @Stefano bluetooth protocol itself is pretty broken IMO 😉

  • @advocatux Yeah, but PinePhone should come without Halium and with mainline kernel, so that should help, or not? On Canonical builds bluetooth worked( not perfectly, but worked {apart from Pro 5} )

  • @Stefano IIRC even on Canonical times bluetooth was a hit or miss.

  • Fail test on nexus 4, need to reinstall UT...
    I hope that the developers will have an idea for the future, I would like listen music with jbl speaker !

  • @Ghostrider use an audio jack for now 😃

  • @kugiigi What a pity... More practical to connect with bluetooth.
    I've already explained in Q&A post why UT can't seduce more people, bluetooth management is a good example.

  • @Ghostrider Bluetooth issues will be sorted, it's on the list to do, after more important issues and upgrades. I know, it's a long waiting for that to be fixed, but with limited workforce, there is no other way around it, unfortunately.

  • @advocatux I've been trying to get my Leitz Mini Bluetooth Speaker working with UT, but without success. I then tried to get it working with my Ubuntu 18.04 laptop. Also not working. After searching on line, I found I needed to install 'pulseaudio-module-bluetooth', after which it worked fine. This package doesn't appear to be installed on UT. Could this be relevant?

  • @advocatux BTW, my Nexus 4 UT pairs and connects to my Bose Sound Dock via a cheap chinese bluetooth adapter which fits in place of the iPod. I can stream both ogg and mp3 files to the Bose from my N4. Cool eh? (Wish I could remember how to make commands appear in red on this forum.)