How to use Spotify on Ubuntu Touch

  • Followed the instructions recently, still works like a charm! 🙂

  • Sweet...!
    Has anybody tried this method with a bq aquaris e4.5 ?

  • @hadrianweb How did you get mopidy keep on playing with the display off? I am trying to use spotify using librespot or spotifyd but the audio becomes teriibly choppy when the display goes off.

  • Yeah, it also works well with screen off

  • Banned

    This post is deleted!

  • Sorry it don't work. See this Screenshot:

    Screenshot von 2020-04-04 12.30.27.png

    Any Ideas?

  • If I remember correct, you need to use newer python library with Mopidy. Xenial has too old..

    I installed Mopidy with Ubuntu Bionic 18.04 - chroot and it is working fine.

  • @HendriXXX Thanks for your reply! But what exactly do I have to do now? What commands do I have to enter?

  • @hackthisut

    I have the same problem; I followed the instructions, but mopidy won't run on my xenial-based libertine container. I tried running

    phablet@ubuntu-phablet:~$ libertine-container-manager create -i lxc-experiment -t lxc -d bionic

    to get a container based on a newer distribution, but that doesn't work:

    libertine-container-manager:76: ERROR: create(): System kernel does not support lxc type containers. Please either use chroot or omit the -t option.

    Not sure how to proceed; note that I'm making my first baby steps with ubuntu touch, so it's well possible that I messed up some initial step, making the guide non-appicable in the first place.

  • I have installed again from zero making all the steps on guide and works well on xenial container

  • @dispanser said in How to use Spotify on Ubuntu Touch:

    -d bionic

    The problem there is that you are not continuing the guide, try without using "-t lxc"

  • Hello.

    Thank you for this instructive tutorial. Most of the steps went well. But there were some problems.

    (There 's the minor issue, that the referenced icon audio-x-generic isn't there. But I guess, that 's something, I'll figure out by myself. I just wanted to keep you informed.)

    Sadly, it won't work: If I click on the Mopidy icon, there 's a wheel for a moment. Then it stops and vanishes. Is there a way to get a log file?

    libertine-container-manager list-apps

    I had to do some version upgrades for Mopidy-Iris wouldn't start with python2.7. Could the problem be originated in the parallel installation of different versions of python?

    Ubuntu 'Xenial Xerus' 16.04
    OnePlus One
    Ubuntu 16.04 (OTA-12)

    Could it be a problem with the Spotify authorization? Do I have to use "..."? I am not sure, if I have to use the (kind of cryptic) username mentioned on

    Please, let me know, if you need further informatoin. Any help would be welcome.

  • @connochaetes
    There is work being done on a native Spotify client by @manland. Look here to help testing the beta version of his app.

  • OK. Obviously, I had to do some homework. (To all the readers: Thanks for your patience. Hopefully, my posts could be useful for UBports learners.)

    It 's a standard that you the libertine container's version is the same as UBports' - in my case 16.04 (xenial):

    libertine-container-manager create -i xenial

    I am switching as root into the newly built libertine container. It 's a GNU/LInux system where packages could be installed via apt:

    libertine-container-manager exec -i xenial -c "/bin/bash"

    For example, I am installing vim:

    apt install vim

    I am leaving the libertine container:


    Outside the libertine container, I can see the installed packages this way:

    libertine-container-manager list-apps

    I added the matching mopidy repository. If I am right, on a 16.04 (xenial) system, it has to be jessie:

    wget -q -O /etc/apt/sources.list.d/mopidy.list

    I am installing mopidy and mopidy-spotify via apt. I do the (hopefully) appropriate configuration. I am starting mopidy using the new icon in my OnePlus One's GUI. Here 's the appropriate log file:

    cat ~/.cache/upstart/application-legacy-xenial_mopidy_0.0-.log

    Yay! So far, all went well. - Now, I have to install Mopidy-Iris as a Python package. Therefore, I have to install Python3.7. This is, where the road is starting to get bumpy (for me), for I am not too familiar with Python packages:

    apt install software-properties-common
    add-apt-repository ppa:deadsnakes/ppa
    apt install python3.7
    apt install python3-pip
    python3.7 -m pip install Mopidy-Iris

    Now, thing's are getting out of (my) control:

    • A message is requesting me to upgrade pip.
    • I guess, mopidy is installed as a Python package in another version as the previous one.
    • I am not able to start mopidy via icon. I am not able to see a file ~/.cache/upstart/application-legacy-xenial_mopidy_0.0-.log.
    • Starting mopidy in the libertine container's console via command line, I see that (another version of) gstreamer is requested.

    I guess, this dependency mash-up is caused by Python3.7 from the deadsnakes repository. At this moment, I am not able to fix this.

    Any suggestions?

  • Is there an alternative to Mopidy-Iris. (So far, mopidy itself was working for me.)

    @arubislander Thanks for your suggestion. I'm going to have a look.

  • OK. I just tested authentification and Mopidy-Iris on another GNU/Linux machine. It 's working there.
    So, right now, I 'll "only" have to get things (e. g. Mopidy-Iris in a libertine container... or Futify) running on my UBports device.

  • Earlier, @arubislander mentioned:

    @arubislander said in How to use Spotify on Ubuntu Touch:

    There is work being done on a native Spotify client by @manland. Look here to help testing the beta version of his app.

    I tested the app. For me, it's the solution. - Spotify-Iris still won't work on my OnePlus One (bacon). I hope, my long postings weren't bothering you. Perhaps, someone can learn some things about libertine containers by reading them.

    Thanks to the community.

  • As this thread is now obsolete, and to avoid confusion I will now lock this thread.
    If you are looking for a Spotify client for Ubuntu Touch, you can check out this thread:

    It is already in a good state, but it will be available in the Open Store when the copyrights issue will be solved.

    Thanks @manland for your very appreciated contribution.