Sony Xperia X (suzu/F5121 & F5122)



  • Thanks @Flohack



  • This post is deleted!


  • @fredldotme Thank you for your great work. Except of the fingerprint reader everything is working.

    I have I have two things to comment.

    First of all. It was really pain to update to android 8 first. But it is nessecary. I tried to install without updating from 6 to 8 because the Android won't update and I was to lazy using Flashtool.

    Second. The power consumption is really high. The System sucks 70% in idle mode overnight. What is your experience? Is there a possibility to reduce energy? I installed sim, telegram, mail, nexcloud sync for calendar, files and contacts. But that should not need much energy.



  • @RubbelDeCatc
    Hello
    Little bit unrelated but just something that crossed my mind reading your comment and maybe getting myself Xperia X later for Ub.Touch.

    1. Updating to Android 8.0 isn´t that something you can do with Sony Emma Tool easily?
    2. After I installed Lineage OS on my Xperia X Compact I had much more battery drainage than before.


  • @ToxyPoxy said in Sony Xperia X (suzu/F5121 & F5122):

    1. Updating to Android 8.0 isn´t that something you can do with Sony Emma Tool easily?

    Well... I was optimistic and tried it without updating. I don't have windows installed.

    1. After I installed Lineage OS on my Xperia X Compact I had much more battery drainage than before.

    So how long last a full battery in idle mode wifi and mobile on?



  • Without updating to android 8.0 it will not work, because the bootloader is not suitable.



  • @RubbelDeCatc Aha I understand, well I installed a sim card and charged it to 100% last night and now 13 hours later in Idle the battery is down to 61%.



  • @japsi said in Sony Xperia X (suzu/F5121 & F5122):

    As I see that Anbox should work in X is there any instructions how to install it? It's not on "supported devices" list yet.

    Just follow http://docs.ubports.com/en/latest/userguide/dailyuse/anbox.html and skip "flash a specific boot image" step.

    In my case (F5122) it works. I used UT Terminal app:

    sudo mount -o rw,remount /
    sudo apt update
    sudo apt install anbox-ubuntu-touch
    anbox-tool install
    sudo apt install android-tools-adb
    sudo mount -o ro,remount /
    cd /home/phablet/Downloads
    wget https://f-droid.org/FDroid.apk
    adb install FDroid.apk
    

    and reboot... (not sure if it's needed)

    There is no sound by default, see https://github.com/anbox/anbox/issues/904. You need to override system/etc/media_codecs.xml file. I was trying to figure it out via rootfs-overlay (https://docs.anbox.io/userguide/advanced/rootfs_overlay.html) with no luck. I repacked android.img with fixed media_codecs.xml file and now there is a sound and even choppy video via NewPipe app. I used this fixed media_codecs.xml file: http://dpaste.com/2H2CP58, it's all in one from these files: https://github.com/anbox/anbox/tree/master/android/media because "Include" and "Included" tags don't work yet.

    Is there a way to apply anbox rootfs-overlay?



  • @c4pp4 Thanks a lot for this !! Just installed anbox and it works great !
    For the audio issue I've tried to modify /system/etc/media_codecs.xml without success despite having mounted with write permissions. It made me ask myself, is the /system/etc/media_codect.xml file for ubuntu touch system or the android system ?
    Could you post your modified android image or just tell us how to repack the image and how to upload it. Not sure where to start. Thanks in advance !



  • @henri2h You can't modify the file directly, it's Squashfs filesystem (see https://en.wikipedia.org/wiki/SquashFS). The best way to override it is via rootfs-overlay as I wrote.

    To repack the image, you need some linux distro. Download the right android filesystem image from https://cdimage.ubports.com/anbox-images/. According to https://cdimage.ubports.com/anbox-images/devices.json it's android-armhf-64binder.img. You also need to have installed squashfs-tools package.

    Uncompress the filesystem as root to keep uid and gid identities:

    sudo unsquashfs android-armhf-64binder.img
    

    you will see something like this:

    Parallel unsquashfs: Using 4 processors
    1429 inodes (5270 blocks) to write
    
    [=================================-] 5270/5270 100%
    
    created 1239 files
    created 274 directories
    created 190 symlinks
    created 0 devices
    created 0 fifos
    

    it creates squashfs-root folder, locate squashfs-root/system/etc/media_codecs.xml file, rewrite it (as root) by the fixed one (http://dpaste.com/2H2CP58) and set the right owner:

    sudo chown 100000:100000 media_codecs.xml
    

    compress the filesystem into android.img:

    sudo mksquashfs squashfs-root/ android.img -noappend -no-xattrs -comp xz
    

    you will see something like this:

    Parallel mksquashfs: Using 4 processors
    Creating 4.0 filesystem on android.img, block size 131072.
    [=================================] 5080/5080 100%
    
    Exportable Squashfs 4.0 filesystem, xz compressed, data block size 131072
    	compressed data, compressed metadata, compressed fragments,
    	no xattrs, compressed ids
    	duplicates are removed
    Filesystem size 212128.35 Kbytes (207.16 Mbytes)
    	39.95% of uncompressed filesystem size (531034.87 Kbytes)
    Inode table size 23934 bytes (23.37 Kbytes)
    	33.61% of uncompressed inode table size (71204 bytes)
    Directory table size 16322 bytes (15.94 Kbytes)
    	43.33% of uncompressed directory table size (37666 bytes)
    Number of duplicate files found 38
    Number of inodes 1703
    Number of files 1239
    Number of fragments 229
    Number of symbolic links  190
    Number of device nodes 0
    Number of fifo nodes 0
    Number of socket nodes 0
    Number of directories 274
    Number of ids (unique uids + gids) 4
    Number of uids 2
    	unknown (100000)
    	unknown (101000)
    Number of gids 4
    	unknown (100000)
    	unknown (102000)
    	unknown (101000)
    	unknown (101003)
    

    Copy the new created android.img file into the phone's home folder into anbox-data and rewrite the original one.



  • @c4pp4 said in Sony Xperia X (suzu/F5121 & F5122):

    sudo mksquashfs squashfs-root/ android.img -noappend -no-xattrs -comp xz

    Works like a charm, thank you very much for the help and the introduction to image building ! Very appreciated !!



  • @fredldotme said in Sony Xperia X (suzu/F5121 & F5122):

    Missing:

    • Libertine

    I've installed Libertine support according to http://docs.ubports.com/en/latest/userguide/dailyuse/libertine.html.

    OS Build of UT was 2020-04-20/2 in my case.

    The phone’s Settings interface didn't work when I was trying to create a container. I think it uses command without extra option 'type' and that's why it always falls to use lxd type. It's because the kernel version is >=4 (4.4.146-g16d456d in my case), see https://github.com/ubports/libertine/blob/503b05c5b99ee1d7d71c1bbfc2a733acc5ee5c73/python/libertine/HostInfo.py#L27.

    To create a container, you need to do it via adb or ssh connection. In my case I've done it via adb.

    As you can see lxd is not supported (command without type option):

    phablet@ubuntu-phablet:~$ libertine-container-manager create -i test
    Enter password for your user in the Libertine container or leave blank for no password:
    Password: 
    libertine-container-manager:123: ERROR: create():	Failed to create container: 'No module named 'libertine.LxdContainer''
    

    as you can see lxc is not supported as well:

    phablet@ubuntu-phablet:~$ libertine-container-manager create -i test -t lxc
    Enter password for your user in the Libertine container or leave blank for no password:
    Password: 
    libertine-container-manager:123: ERROR: create():	Failed to create container: 'No module named 'libertine.LxcContainer''
    

    the only working command to create the container was with type chroot:

    phablet@ubuntu-phablet:~$ libertine-container-manager create -i test -t chroot
    

    here is the output http://dpaste.com/2E0615B

    After that you can use the phone’s Settings interface to install some packages into the container.

    e.g. I've installed Firefox:
    screenshot20200421_061405340b.png
    It's too slow and I had to set Firefox's 'Network Settings' to 'Auto-detect proxy settings for this network' and use Libertine Tweak Tool to make the text and the scrollbar larger.



  • @henri2h Maybe you want to push the fix to https://github.com/ubports/anbox so that every device can benefit from it. 🙂



  • Hi everyone.

    It seems that GPS isn't working on my device. And it never worked. The sensors Appllication tells me that GPS is supported and active.
    Source Staus no error
    Last updated empty

    Anyone has the same problem?





  • @RubbelDeCatc In my case something gps related is broken but I dont have any idea what it is. I have chanced the mainboard an the antenna. It didnt fix it.



  • @makeixo said in Sony Xperia X (suzu/F5121 & F5122):

    . I have chance the mainboard an the antenna. It didnt fix it.

    I don't think it's a hardware problem. The Xperia is new. Maybe something disabled.

    Here is the test_gps output
    https://oc.dirk-hoeschen.de/index.php/s/WtZzxJ64Biecoyq

    My System

    • Sony Xperia X
    • Ubuntu 16.04 (22.04.20)


  • @RubbelDeCatc Did you walk around outside a little like @fredldotme has stated above?



  • @RubbelDeCatc Have you read this article?

    It seems you have to keep the display active and the GPS app in foreground to get a GPS fix.

    That made ist working for me.



  • Hi,

    Just wanted to share that I managed to install successfully Ubuntu Touch on my Xperia X which was running SFOS before.

    Here are the steps performed :

    • flash using Emma tool "F5121 34.4.A.2.107 Customized_FR 1302-3046 R4E User-Live COM" (Android 8.0) : kernel was not upgraded and mobile wanted to shutdown all the time
    • flash in fastboot mode twrp-3.3.1-0-suzu.img for recovery
    • boot in recovery mode and from twrp : wipe Cache, System and Data
    • reboot (oops can't boot, stalled with Sony image)
    • boot in fastboot mode and run UBports Installer 0.4.18-beta
    • select channel 16.04/community/fredldotme/devel, Wipe Userdata and Bootstrap
    • let the installation process run and discard any display on mobile
    • and it worked !

    OK. I have to admit I stressed a lot while performing the different steps 😧.

    Now, I am discovering UT on Xperia X and I am impressed by the work done on this phone 😀 !

    For the moment, I have noticed following issues :

    • front and back camera zoom are not working
    • back camera autofocus is not working

    Congrats @fredldotme !


Log in to reply