Sony Xperia X (suzu/F5121 & F5122)



  • @Stef7773 You seem tho have sorted the issue which is good but as pointed out posting the same thing twice is not helpful. It's confusing for people, you get the same people, in most cases answering and to be honest it is a little annoying. Something to remember for the future.
    So welcome aboard and enjoy Ubuntu Touch.



  • @Lakotaubp Ok is good to know. just one post. Cool. Thanks. Im enjoying Ubuntu Touch already.



  • Thanks to the community!
    Agree with provide more hints for newbie. In my case, i spent 2 days to figure out the pre-install steps on brand new Xperia X, its a bit lack of clue for me.

    Some suggestions

    • Add back up your TA partition warning in this post
      More clue for TWRP, cuz I think its requirement
    • like command fastboot flash recovery ....img
    • and key press to get in it (vol down + power)

    In the end, I success by "wiping ART cache, cache, System, Data, and installing UT" twice. Even the guide are clear enough, I've still got panic several times during installation. Personally, I think the Sony unlock and UT installer's feedback is the most confuse part.



  • @miao The backup TA partition was also an issue for me because since it was in the step 5? I left that after I started updating my brand new Xperia X so I was unable after to go back and downgrade to android 4.4 just to backup my DRM keys. @fredldotme I think it would be helpful for others if we add an issue to the documentation about step 5 and make it more clear since the begining. 🙂



  • I got my hands on a sony xperia x F5121, and it is upgraded to android 8.0 with the standard software updates from sony. Is it now in the same state as install android 8.0 with emma? And i can jump to the second step of the installation process.



  • @ola If you are in 8.0 already you can continue with the process



  • Hi guys,
    after the last update (387?) some apps don't work, in alphabetical order they are:

    • 500px;
    • Axolotl;
    • DeviantArt;
    • Minds Social Network;
    • Onion Browser;
    • Pinterest;
    • uDiaspora;
    • uMastonauts;
    • uNav;
    • uPixelFed;
    • YouTube.

    If we knew what has changed, we could edit the apps and make sure that doesn't happen in the future. Some of these apps are mine.

    Thanks



  • @Giampy QtWebEngine has been upgraded on the development channel, so that's probably the reason things don't work as expected anymore. Could you please file a bug report? We definitely should find out what's broken.



  • @fredldotme I can't see the log of the apps because they crush at splash screen so I don't know what is the bug. The QtWebEngine version that I use is the 1.7. If you want you can see my apps on gitlab. My apps are Pinterest, Minds, DeviantArt and 500px.



  • Hello. I already have install Ubuntu Touch on my Sony Xperia X (suzu/F5121). But i can' t access to the camera: "Camera app doesn' t have permission to access the camera hardware or another error occured.

    if granting permission does not resolve this problem, reboot your device. "

    I can't grant the permission for the camera, what can i do please ?





  • @fredldotme After this update nothing has changed! Tonight I will try to change something and recompile my apps. What version of QtWebEngine is there now?





  • @Lakotaubp Thank you.



  • @malditobastardo ok, I will have to test if in qml the version is 1.9 or 1.10. I suppose that the morph version has changed, what is the version now?
    Thanks very much to all



  • @Giampy

    • Weather App - rain radar
    • Seabass2


  • @c4pp4 It's true, but after the last update (400) all work fine. The developers of the apps have to change the code to store the cokies!



  • @Giampy 400 did it, works again, thanks! 🙂



  • Hi,

    I've been a long time Ubuntu Touch user, having moved to the platform back when the (official Canonical) Meizu MX4 came out.

    My old phone has finally started to have battery issues, and my wife wanted an upgrade from her Xperia X. She's now moved on to another device and I decided to see how well the Xperia X port worked.

    I'm blown away.

    It's working great, albeit with some (very minor) issues. So firstly I wanted to say thank you for your hard work on this. It's very much appreciated.

    I thought I'd mention the issues I have in case it helps:

    1. Camera occasionally fails (black screen for rear camera) and won't work until a reboot.
    2. On first reboot when rear camera works again, it only partially displays an image. Top half of image is solid green, although the bottom half displays fine. At some point this fixes itself - I haven't figured out why yet.
    3. Rebooting is a bit odd - when I try to reboot first time after running the device for a while, it just restarts Lomiri rather than restarting the whole device. If I then select reboot again, it reboots properly.
    4. UBPorts OTA updates are a bit strange - when doing an update, it seems to go OK, but will always take me to the UBPorts Recovery on reboot giving the impression something went wrong with the update. If I then just select to reboot the device, it all works fine.

    I also have a question. On installing (via the UBports installer) I had the option of selecting the 'fredldotme' channel or the 'edge' channel. I selected 'fredldotme' as I was aware this was the handle of the person who ported it to suzu in the first place. Was this the best option? Also, I've noticed I must be on a bleeding dev channel as I get very frequent OTAs (just installed '409', and '410' is already available).

    I want to use this device as a daily driver, so I'd like to understand how these releases are made and whether it's fairly safe for me to be applying these often? Will suzu ever be available in a stable channel? Also, is there a changelog for these OTAs? I noticed '409' was hundreds of MB, whereas '410' just came through in only ~1MB so I figure these are deltas and wonder just how much changed in '409'?

    Sorry for all the questions 🙂



  • @Kamikaze for a fully functioning device the choice in channels was good, arm64 still has issues with GPS & video recording (using gst-droid).

    A stable channel is in the taks, altough for the arm64 release only. We still need to fix up a few things until that's ready but it's getting there. Until then just don't update as often as it's possible currently. 🙂


Log in to reply