Sony Xperia X (suzu/F5121 & F5122)

  • Nice!!! Does this support anbox? I'm still deciding to get a oneplus 3 or xperia x to help testing. Any suggestion?

  • @extraymond It should as all the necessary kernel changes are in, but the installation will fail for now. I'll ask if it's possible to whitelist the Xperia X to gain Anbox support.

  • @fredldotme Thx! Looking forward to use this as my n5 replacement.

  • Thanks for this port !! Having a great time using Ubuntu touch for the first time !
    Using the last release in the development branch I am not able to pair with any device using bluetooth. (I have tried to connect to a bluetooth headset and a speaker). Trying using the terminal with bluetoothctl doesn't work neither. Is it something specific to this branch or I have missed something.

  • Hi Guys, there is an error connecting the Xperia X via USB cable under KDE Desktop.
    I fixed the bug by adjusting the following file:


    The entry:

    ACTION! = "Add", GOTO = "libmtp_rules_end"

    must be changed to:

    ACTION! = "Bind", ACTION! = "Add", GOTO = "libmtp_rules_end"

    It is important for the time being that the developer mode is deactivated on the Xperia X and in the UTtweaktool in the ADB settings RNDIS is activated.

    Thus, in the file manager via USB to the phone memory can be accessed.

    This works for me.

    Best regards

  • I also encountered

    Cache formatting was not succesful, flashing may fail, check your partitions on deviceFailed to enter Recovery

    with the old instructions. With the new instructions with the installer, the installer is stuck at Flashing firmware forever.
    I am not sure if I followed the instructions correctly.

    Even though the output looks correct, the OS looks the same after booting, not like AOSP:

    [root@localhost platform-tools]# ./fastboot flash oem ./SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_loire.img
    Sending 'oem' (220783 KB)                          OKAY [  6.926s]
    Writing 'oem'                                      OKAY [  3.553s]
    Finished. Total time: 10.536s

    It says Make sure to upgrade your device to the latest stock Android 8.0 before continuing. The Xperia X does not support Android 8, does it? Does it matter which service I choose in the Emma flash tool?

  • @hxa5e Xperia X support Android 8

  • This post is deleted!

  • @hxa5e

    • Make sure to upgrade your device to the latest stock Android 8.0 before continuing:

  • This post is deleted!

  • I'm using a Nexus 5 with Ubuntu Touch (with no problems) and I'm about to buy a Sony Xperia X 5" 3/32gb Black F5121P.
    I read than its fine with the F5121, can you tell me if UT works well with the F5121P?

  • @fredldotme Hi! I accidentally tried installing F5122 using the F5121 option in the ubport installer, and it went on installing successfully. It even let me booted one time before failing to boot again.

    If you need to test anything to get ubport on F5122 as well. I'm willing to help.
    Thx again. Awesome stuff you're doing.

  • @PjsP I wasn't aware of there being a F5121P model. It looks the same as F5121 but don't take my word for it.

  • Halium recovery does not clear the cache completly. For a new device it is necessary to install TWRP first after unlocking the device. It can be downloaded from here: and flashed in Fastboot Mode (Power on + VolumeUp = Blue LED) using:

    fastboot flash recovery Downloads/twrp-3.3.1-0-suzu.img

    Afterwards boot into TWRP and select Wipe / data, system & cache partitionen. Continue with the installation (OEM Binaries / UBports installer)

  • On my device the location service is not working at all. Neither in the Weather app, nor in apps like puremaps or uNav. Does anyone else experience this issue?

  • Today i installed ubports on my xperia x, but app store is not opening and when anyone calls it just vibrates once then i dont see aything to accept call

  • @hsabun Have a look here for apps including OpenStore. As for calls there is the same issue for OP3/t at present bug report here for OP3/T

  • Since todays update I don't have the circle of flash anymore but a Yumi and "Installing update". Very nice 🙂

    Is there any progress on the content-hub bug? I don't know how to help but maybe I could take a look at the sources and play around with it if you send me a link.

  • Hi,

    today I have tried to flash UT on my X. Everything went fine until the UBports installer gave out an error:

    Error: systemimage: Error: Error: Failed to push file 0: Error: Push failed: stdout: adb: error: failed to copy 'home/user/etc... to '/cache/recovery/ubports-910eb8d940df68e751cd1e047a1b438b85bc24471aade397242765009a6c4d.tar.xz': remote write failed: Read-only file system 
    /home/user/etc.../.cache/ubports/pool/ubports-910eb8d940df68e751cd1e047a1b438b85bc24471aade397242765009a6c4d.tar.xz' 0 files pushed. 9.7 MB/s (139115944 bytes in 13.724s)

    Now the phone has an bootloop. It always boots into the android recovery, shuts down and boots again, even if I get to the option "reboot to bootloader".
    The only thing I can do is to power it off.

    Anyone who can help me to solve this.

  • Wipe data,system&cache partition with TWRP before Flash the OEM binaries

    Remove SD card before run the UBports installer

Log in to reply