Oneplus 3/3T



  • @ernest

    Ah I see, I thought it was strange that you chose that button, I know there's some code in Ubuntu Touch itself for finger print scanners, but I remember Dalton basically banging his head over fingerprint sensors because apparently they are a nightmare, I didn't realize that you needed the fingerprint sensor to be active for the button to be detected, IDK why but I thought they where, or could be separated some how, but that was just an assumption.

    I can't confirm for button signifiers, but from what I've played around with, you shouldn't need to recompile anything if you're just modifying some qml.



  • I tried to flash my oneplus 3 with the factory image first and after that ubports and it seems like that helped a lot on the performance and stability part. Even anbox runs pretty well for some of the apps i need. I now ordered the pinephone ubports edition to sponsor this project.



  • @ernest said in Oneplus 3/3T:

    @FBrain
    try that I've just compiled the bluetooth app file transfer for arm64 : https://drive.google.com/file/d/1Y7sV-ofWqCpfUvlUmKHals9eUFs7MVFD/view?usp=sharing

    Seems that it creates two bluetooth icons... It would be great that somebody gives some love to this app

    I would love to do it, but I don’t have the necessary knowledge, can I read the manuals somewhere?

    I tested bluetooth, with WiFi everything is fine when using Bluetooth, but can I somehow send files?

    Since from time to time I update packages through the console, I got an update for the bluez, but it cannot be installed.



  • This post is deleted!


  • I just tried the flashlight, but it doesn't work anymore (neither the button in the indicator bar nor the uTorch app). Does anyone else have the same problem? Thanks



  • @ma If you read back up in this thread there is a method to reinstall it. On mobile working so can't find it just now.



  • @ernest said in Oneplus 3/3T:

    Seems that it creates two bluetooth icons... It would be great that somebody gives some love to this app

    The two bluetooth icons bug appeared with RC/ota-12, even with open-store BTFT app.



  • @ma Care of @Stefano

    open terminal
    type: sudo -i
    you'll be prompted to type in your password, do it
    then type: sudo ubports-qa install PR-22
    confirm by : y when/if asked
    then type: sudo apt install indicator-power
    reboot

    after reboot, on dash under battery icon will appear a flashlight.



  • Thanks. It works again. It doesn't matter but the uTorch-App is still not working.



  • Since yesterday I have two problems:

    1. The OP3T can only be started if the power button is pressed very long.

    2. When I select "reboot", the phone does not reboot. It only turns off.



  • I saw somewhere that Bluetooth things for the OP3 are now merged, but I'm in devel and I haven't got Bluetooth working, are the merges I've seen around bluetooth, work like backporting newer bluez, or other stuff, thats not meant to be active yet?

    can I install the ability to test bluetooth using Ubports-qa command or something, or do you still have to install by downloading the OS via the links provided above to try it?

    I'd prefer to wait because I am a big fan of OTA updates, and just flashing the device via the UBports installer if anything goes wrong, you know.

    Thank you 🙂



  • @PhoenixLandPirat The advice on testing the new Bluetooth stuff was only if your confident. I'm going to wait till an OTA gets Bluetooth working on my OP3. Which it is not as yet. You can toggle the switches on and off but nothing happens.



  • @PhoenixLandPirat

    I don't know when the bluetooth should land to you. yes it has been merge to halium repos.
    can you give the output of :

    dmesg |grep toot 
    

    right after a boot

    hciconfig
    

    thanks



  • is battery consumption increased lately or it's just me ?



  • @stan It does vary over updates I have noticed.



  • @Lakotaubp thank you for answering back



  • @Lakotaubp Can you try the command mentioned above ?





  • @ernest
    0e29f9d7-3e89-4ce7-98af-548b7aaa280d-image.png file:///home/lakotaubp/Documents/Screenshots/screenshot20200422_192720843.png



  • Thanks both of you, the updated kernel didn't land yet.

    you should have :

    phablet@ubuntu-phablet:~$ dmesg |grep toot
    [    0.627820] Bluetooth: Core ver 2.20
    [    0.627870] Bluetooth: HCI device and connection manager initialized
    [    0.627886] Bluetooth: HCI socket layer initialized
    [    0.627899] Bluetooth: L2CAP socket layer initialized
    [    0.627951] Bluetooth: SCO socket layer initialized
    [    1.667348] Bluetooth: RFCOMM TTY layer initialized
    [    1.667381] Bluetooth: RFCOMM socket layer initialized
    [    1.667402] Bluetooth: RFCOMM ver 1.11
    [    1.667423] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [    1.667433] Bluetooth: BNEP filters: protocol multicast
    [    1.667448] Bluetooth: BNEP socket layer initialized
    [    1.667461] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [    1.667475] Bluetooth: HIDP socket layer initialized
    [    1.667488] Bluetooth: HCI UART driver ver 2.3
    [    1.667499] Bluetooth: HCI UART protocol H4 registered
    [    1.667508] Bluetooth: HCI UART protocol LL registered
    [    1.667518] Bluetooth: HCI UART protocol IBS registered
    [    1.667527] Bluetooth: HCI UART protocol QCA registered
    [    3.208558] initrd: checking mount label bluetooth
    [    3.209217] initrd: mounting /dev/disk/by-partlabel/bluetooth as /root/android//bt_firmware
    [   10.994931] Bluetooth: HCI_IBS open, tx_idle_delay=600, wake_retrans=1
    [   11.539105] Bluetooth: received HCI_IBS_SLEEP_IND in rx state 0
    phablet@ubuntu-phablet:~$ 
    

Log in to reply