Oneplus 3/3T



  • Hi!
    I have a question about USB tethering on Oneplus 3.
    Internet connection works well.

    In terminal I've entered commands:
    $ android-gadget-service enable rndis
    rndis enabled
    $ sudo tethering enable
    Device "rndis0" does not exist.
    Error: Connection 'tethering does not exists.

    Does it work at all?
    Or it's a bug.
    Where I should report a bug?(additional question)
    Thanks in advance.



  • @Kyrylo i have the Oneplus 3t and it works for me; it doesn't always show the tethering icon up top though, so it looks like it's not working maybe that's your issue?



  • @soupbowl nice to hear that. Enjoy. 😉



  • @vince1171 said in Oneplus 3/3T:

    This is a port of Ubuntu Touch for the Oneplus 3 and the Oneplus 3T.

    I want to use UBports as daily driver. Which will be better Oneplus 3T or Sony Xperia X if I need tethering from time to time. Will tethering and video recoording will be implemented soon?



  • @thilov How does the Aquarus M3 run? I know it's made for that...

    Not sure if it works in USA though.



  • @Nathan123 said in Oneplus 3/3T:

    @thilov How does the Aquarus M3 run? I know it's made for that...

    Not sure if it works in USA though.

    Aquarus M3? Don't know what that is. Sry.



  • Wondering if there's any news about the qtUbuntu camera for OPO 3T. I know it's a known and long standing issue and is worked on 🙏. I'm aware that GSstreaming app is considered to be an alternative, yet would rather use the native app.



  • on my Oneplus 3 the bluetooth connection with my old pebble watch lasts only about 10sec and then it's disconnected again...
    and wifi is still unreliable, after a reboot the smartphone sometimes does not connect to my network - so I have to stop and start wifi and then it works
    and I'd love to use the fingerprint reader in the future 😷 😛
    I'm on Ubuntu 16.04 (2020-06-10)



  • @strutter66 I had the same issue with my pebble time. I unpaired the devices and completely started again. The result is that my pebble works well but I am still unable to dismiss notifications.



  • I have tested music (no suspend was set) over bt Speaker:
    If the wifi is on the music has many clicking noises and sometimes the wifi connection was lost for short. If the phone was connected to a repeater the connection was lost permanently. Strange, had to reenter credentials.
    Switching off wifi the music plays without clicking noises over bt.
    Using a headphone (cable, no bt) I had no problems with the music and the wifi.
    It looks like bt and wifi having problems to work at the same time. I remember I read years ago, that op3(t) has a rome chip and that there are similar problems, have no source to cite, but maybe I read it for a sailfishos port (hope one developer has time and knowledge to investigate).



  • Hello! Thank you to support the oneplus 3(T). I have an issue to enable the developer mode.

    I'm running Ubuntu 16.04(2020-06-12) on Oneplus3.

    When I enable the Developer mode button and setup the Lock security with passcode, I connect the device to my computer, and nothing happen (no popup to trust the device...etc).
    So when I run adb device is not listed or unauthorized.
    Tested to run adb from ubuntu 20.04 and macOS (same issue).
    The issue should come from the devices.

    If you have any solution please?

    Thank you



  • @pierro777 Don't know if this helps but from memory when I had UT on my OP3T nothing worked when plugging in to computer. I set up ssh to enable working from terminal on pc to do the things I needed.

    Also, at the top of this thread ADB/MTP is listed as 'not working'



  • MTP works adb does not as yet.



  • Thanks for your responses @ziggutas and @Lakotaubp 🙂
    Okay so I'll play with dd to set Antbox on partition 😉

    Thanks



  • If I have to enter the SIM-PIN, the check-button for the confirmation is missing since a few days. Does anyone else have the same problem? Thank!



  • @ma Yes. It went when the new icons in pull down bar arrived. Still works if you tap where it should be.



  • Anyone else tried tapping just to the right of the finger print sensor. OP3



  • @Lakotaubp
    Tapping/holding the right button on the OPO 3T opens the left task/app bar and numerics in the app logos in chronological order from bottom to top.



  • @Lakotaubp : It's great to see the physical button functional. It would be awesome to have all buttons to our disposal, preferably having the option to asign the home button to a specific launcher. In my case I would like to have it be a shortcut to @syper Launcher Modular.

    Functional physical buttons could contribute to lowering the threshold for newcomers to convert to UT.

    Thanks for the good work!



  • @3T_Ed Just to be clear it's absolutely nothing to do with me all this good work but @vince1171 port


Log in to reply