Oneplus 3/3T

  • @poVoq said in Oneplus 3/3T:

    1. I think there was some talk regarding this for the Yolla Phone to avoid the display notch. Might be upcoming.
    2. The pull-down is gesture based. You can try to hit the right icon with your finger directly (so it isn't random, but based on where you place your finger), but otherwise just move the finger left or right to swap the menus.

    Thank you for that. I will search for the Yolla Phone comment mentioning that. It would be nice to have the feature be implemented for all devices. Pulling down the top bar needs to be done with pinpoint precision to swap menus. I'm getting the hang of it. Thanks again.

  • Hmm, I seem to have problems installing this on my Oneplus3 coming from a Linage OS 17 😞

    Initially I tried to just use the installer, but had to manually select the OnePus3(T) and it installed the bootloader and went through the installation process resulting in a success message, but the Phone itself ended up in a non bootable state. First it went strait back to the Ubports recovery and after another reboot would show the Linage OS boot logo but not proceed.

    So I reflashed TWRP wiped all the partitions under "advanced wipe", made sure all is in EXT4 (had to reformat one) and then restarted the installer. This time it recogized the device fine and would again say all installed fine. But now I am stuck in a bootloop to the Ubports recovery.

    I will try flashing TWRP again to see if I might have missed something, but I am a bit stuck 😞

    Edit: After reflashing TWRP I also used the "reformat" option on the partitions in TWRP. Then used the installer again. Again it found the OnePlus3 correctly and claimed to have installed correctly.
    Then it rebooted, was stuck on these swirly multicolor rings for a while, then rebooted again and now I seem to have a working Ubuntu Touch πŸ™‚

  • Adjusting display brightness isn't working on OTA-13 with the OnePlus3?
    Edit: working after a restart. Phew, I was starting to worry about my eyesight πŸ˜‰

  • Anyone has a suggestion how to fix the silent mode slider button? It was working on first boot of the system, but now it doesn't seem to register any longer.

  • @poVoq said in Oneplus 3/3T:

    Anyone has a suggestion how to fix the silent mode slider button?

    Do you mean the physical button (top left)?
    When sliding that button the speaker icon in the top bar/toggle is striked through/muted on my 3T

    edit: I'm on stable channel

  • @3T_Ed said in Oneplus 3/3T:

    @poVoq said in Oneplus 3/3T:

    Anyone has a suggestion how to fix the silent mode slider button?

    Do you mean the physical button (top left)?
    When sliding that button the speaker icon in the top bar/toggle is striked through/muted on my 3T

    edit: I'm on stable channel

    Ah a reboot seems to have fixed it. Odd.

  • Any idea what could be causing my OnePlus3 to be partially in Window mode, despite being set to staged?
    See related discussion:

    I noticed that the BottomEdge is displayed as if there was a mouse connected, and sometimes I shortly see a mouse-pointer on the circle screen appearing.

  • My OP3 runs an edge version from 2020-07-21. I would like to switch to another channel ("dev"), but only "edge" is offered under Updates|Update settings|Channels.

  • @sven You should be able to move to dev iirc and you are upto date with updates. So recheck updates and channels. If not rerun through the installer don't select the wipe option and do it that way.

  • @Lakotaubp Thanks for your suggestions. I checked again: no other channels available (probably the installed one was an early one). Now I am trying the ubuntu installer 0.5.2-beta. My OP3 is running, developer mode is on, but the installer is only showing Waiting for device.

    If I select the model by hand, installation ends with lost connection. I am using the official OP3, red USB cable.

  • @sven Perhaps try dropping down an installer version or two. I must admit to not trying the new beta one yet.
    Edit Or 0.5.3 from here

  • @sven said in Oneplus 3/3T:

    red USB cable

    That means quite nothing.

    USB 2.0 capable cable is required, and usb 2.0 port is needed (not 3.0 one!).

    Then if you can access your data under androΓ―d on your PC with usb 2.0 cable on usb 2.0 port, USB data is working well and that should work for installing ubports.

  • @Lakotaubp I tried 0.5.3 beta without any change. Probably the reason is simple: fastboot devices won't show the OP3. In syslog, the following appears when I plug in the USB cable:

    Oct  9 22:07:53  kernel: [101154.624051] usb 1-3: new high-speed USB device number 16 using xhci_hcd
    Oct  9 22:07:53  kernel: [101154.774090] usb 1-3: New USB device found, idVendor=05c6, idProduct=f003, bcdDevice= 3.18
    Oct  9 22:07:53  kernel: [101154.774095] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Oct  9 22:07:53  kernel: [101154.774099] usb 1-3: Product: Android
    Oct  9 22:07:53  kernel: [101154.774102] usb 1-3: Manufacturer: Android
    Oct  9 22:07:53  kernel: [101154.774104] usb 1-3: SerialNumber: 0123456789ABCDEF
    Oct  9 22:07:53  systemd-udevd[59957]: 1-3: Process '/usr/lib/snapd/snap-device-helper bind snap_ubports-installer_ubports-installer /devices/pci0000:00/0000:00:14.0/usb1/1-3 189:15' failed with exit code 1.

    Should I move this to a new topic?

  • @sven Just tried 0.4.18 with OP red cable selected device myself and all worked. Just updating snap now to try latest version of installer.

  • @sven That'll stop things. Have you checked with fastboot devices via a terminal?

  • @Lakotaubp Yes, I see no output from the terminal command fastboot devices.

  • @sven did you enable usb debugging and allow it for the specific PC via the popup that should appear on your phone's screen? Without that it will not be shown on fastboot devices.
    Ah, wait you are already on UT and want to switch versions via the installer? I think adb isn't supported on the OnePlus3 UT port so I doubt it will show up unless you have booted into fastboot already.

  • @sven Not trying to be funny but had you rebooted to fastboot mode first. if you had try another cable just in case.

  • @Lakotaubp Booting to fastboot mode before starting ubports-installer did the trick. Thanks. Maybe a message in the start screen of ubports-installer would help ("If your device already runs some version of UT, please ...").

  • @sven If you stuck with 0.5.3 installer there should be a new way of reporting errors ( Or give it a try and see if it is the same on there then report it. That will probably be the quickest way.

Log in to reply