Nexus 5 Wifi problems with AnBox



  • So recently I installed on a Nexus 5 Ubuntu Touch using the installer. Everything went well (very easy!), and wifi worked well.

    Then I installed AnBox, following this instructions, and after finishing all the process the wifi was not working anymore. Meaning that the toggle button to turn it on and off was gonne from settings and the top menu with the connections. Wifi was not connecting and could only see in the settings the previous connection information.

    I am very certain that it has to do with AnBox because I did the process twice, and right after installing AnBox is when wifi disappears.

    What is the solution for this problem? Thanks.



  • I can't really help you, but there are open issues about this already
    https://github.com/ubports/anbox/issues/36
    https://github.com/ubports/ubuntu-touch/issues/1280

    Also someone already asked about the problem in the general anbox topic
    https://forums.ubports.com/post/24251



  • Thanks for the info!



  • Just want to say that it happens to me as well.

    If I have time I will try to help with this, but I am not sure I can... 🙂



  • Someone on Telegram posted today

    ohh! I see what happened. I tried to get anbox working, but now the kernel modules are for the wrong kernel
    [ 9.095380] bcmdhd: version magic '3.4.0-cyanogenmod-gc95a726 SMP preempt ARMv7 ' should be '3.4.0-cyanogenmod-g2669fa0 SMP preempt ARMv7 '

    See https://t.me/WelcomePlus/46274



  • Same happened to me with my Nexus 5 😞



  • This is the output of nmcli in my case (wifi type is missing, and I am at home). It seems pretty clear that anbox connections is kind of masking wifi connection somehow.

    phablet@ubuntu-phablet:~$ nmcli device
    DEVICE      TYPE      STATE        CONNECTION 
    anbox0      bridge    connected    anbox0     
    ril_0       gsm       unavailable  --         
    vethG7IQOI  ethernet  unmanaged    --         
    sit0        iptunnel  unmanaged    --         
    lo          loopback  unmanaged    --
    

    Unfortunately, I do not have a clue about why Anbox is doing this, and therefore how to solve it. u.u

    Any help is appreciated!



  • Can you please try to install latest devel with the installer and the bootstrap option set? The issue is fixed there hopefully. Then you can switch back to stable with no bootstrap, and it should stay ok.



  • @Flohack I will definitely try it when I have a moment, thanks for the info!



  • @ThrillSeeker Video guide.. https://youtu.be/dOfVTp1XtX4



  • I had the same experience when I tried to install Anbox on stable but when I reflashed to devel and reinstalled Anbox, the wifi is working.



  • So, basically, unless I'm some sort of programmer, I can't put Anbox on this system, and install Spotify on my phone...



  • @polyglossia You can try, but as said before, you need at least the kernel from the devel channel. With next OTA-12 update this will go to stable, then its easier to install Anbox.



  • Also, Anbox probably cannot playback any sound right now.



  • @Flohack I am having this issue even after freshly installing the devel branch of Ubuntu Touch on my Nexus 5. After installing the Anbox boot image and restarting the phone I only have LTE connection but no WiFi connection. Any advice?



  • @wilson You don't need to flash a different boot image with devel. If you want devel + anbox, then reflash UT from devel and don't change the boot image.



  • @dobey Thanks! I'll try that and see how it goes.



  • I just ran into this issue as well. Perhaps it's time to update the official UBPorts documentation to mention the problem and solution? I would be happy to submit a change for the documentation, but I don't think I'm the best qualified person to do it.

    However, now that I have reflashed to devel and installed the software, I have a new problem. When I run anbox-tool install it throws out a warning "start: Unknown job: anbox-session" and seems to hang. If I break out the trace says it is in a loop waiting for anbox to start. Then when I run anbox-tool status it says it is enabled but not running.

    So any suggestions on how to resolve the issue? If not, is uninstalling the packages sufficient to uninstall anbox?



  • Hello,

    I had the same problem with my Nexus 5 today when I tried to install Anbox.

    First, adb is not working with my Nexus 5 on Ubuntu Touch, so I used the terminal to reboot in bootloader, then I was able to flash the boot-img with fastboot.
    Since this moment, the Wifi controller was not detected :

    ifconfig wlan0
    wlan0: error fetching interface information: Device not found
    

    Since the boot image for Anbox broke the Wifi, and no simple mean exists to repair it, I tried to put back the original boot image with Wifi working : I can't understand why it doesn't solve the problem at all.
    I am reinstalling Ubuntu Touch in devel version, I'll let you know if it corrects the problem.

    I think the doc page (https://docs.ubports.com/fr/latest/userguide/dailyuse/anbox.html) should not consider that Anbox supports the Nexus 5 and the buggy boot image (http://cdimage.ubports.com/anbox-images/anbox-boot-hammerhead.img) should be urgently removed to save hours of labor to people that finally get a completely useless phone...

    As proposed by @nontrivial on July, I can help to correct the doc. What should I do for that ? Send a corrected version of the HTML file on the forum or to a particular person ? Don't hesitate to tell how we can help.

    Thanks,



  • As @nontrivial did, after reinstalling Ubuntu Touch in devel version, I got :

    start: unknown job: anbox-session
    

    I think I got that because I ran "anbox-tool install" as root whereas it is not asked. I was able to correct this with :

    sudo chown -R phablet: anbox-data/
    anbox-tool upgrade
    

    Now anbox works fine and I was able to install an APK.