Call for testing: Google/Huawei Nexus 6P (angler) owners



  • @DjDeets said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    the 32 mb of cache are filled. I can avoid them by manually limiting my app usage to two to four apps at a ti

    This is a different thing, I had freezing camera for example, or freezing navigation app, it would continue to work normally only after an endless number of minutes where nothing works, no touch input, no keypresses etc.



  • Somewhat unrelated, but is navigation supposed to work well? The device fails to give any estimate of my position at all, but it may also be a hardware flaw in my 6P.



  • @potet GPS was working last i checked it. Check with Sensorstatus or Meswerk available in the app store



  • @Flohack That does indeed sound like the four core problem - phone heats up while doing something, then stuff stops working, strange errors or actions, and reboots. Once cool, works again, until it doesn't.



  • This post is deleted!


  • Great! The sound problem for incoming calls is fixed now. 🙂 👍



  • @rocket2nfinity Looks like my GPS might be broken then.

    SensorsStatus claims it found supported backend and that the GPS is active, and returns "Source status No error". However, "Last updated" is blank, and all the position indicators (longitude/latitude etc) just show a long dash.

    The GPS was sometimes acting up on Android towards the end as well, so if nobody else is experiencing these issues it's probably safe to assume it's a hardware problem. 🙂



  • @potet My GPS works fine. You have to note to try it outdoor. 🙂



  • @potet What he said ^^^

    GPS sensitivity is not so good indoors. Your sensors are indicating they are ok, but don't have lock. Try outside. The N6P is pretty quick to lock on with sufficient signal. If it doesn't, and the battery has been changed, then someone likely diconnected or damaged a connector/cable.



  • @rocket2nfinity No luck, but it's quite likely that it's broken hardware. My 6P has been subject to some serious fall damage, it's a wonder it's alive at all. 🙂

    After the latest update (developer channel) it gets stuck at the boot screen though - might be because I upgraded to the newer version of Qt. In either case it's not booting any more, so I'd recommend others to upgrade with caution. 🙂



  • @potet Just updated Dev channel. Reboots just fine. No strange behavior. Are you on 4 or 8 cores? If 8, then try 4.



  • Just replaced the battery on my N6P yesterday. Previously, the phone was just sitting unused in my closet until I saw this release. Had some problems with random shutdowns, but that was due to the battery being unable to sustain voltage under high load. With the battery replaced, no random shutdowns, and battery life is incredible.

    The new battery cost only $10, but I definitely needed a heat gun to get the adhesive off of the glass and plastic panel. The battery took just time, and a plastic spudger, and 2 playing cards.
    Best ten bucks I've spent.

    Thanks so much for your work on this. I'm on the dev channel and noticed several things:

    1. wifi won't reconnect after suspending until I turn wifi on-off again.
    2. The anbox thing where no other app other than the defaults will run.

    Thanks again!



  • @rocket2nfinity My Android install was 4 core, but I used the normal UBports image provided by flohack. Not sure what that makes me.

    The device is stuck in the same situation as after the failed installs: It opens the boot screen, loads for a while, reboots, and then continues "loading" forever. The dots on the boot screen are moving, but nothing is happening.

    Edit: Re-flashed developing channel, worked fine.



  • Hi all, I am not a developer, but I am trying UBports out on various devices. For the life of me , I cannot get it to install on my Nexus 6P (angler). I have followed all the steps and what people have done on this forum and every time it hangs at preparing system image. It won't go past that point. I have a semblance of UBports recovery, but no operating system. I am flashing it through my windows 10 machine, I have an unlocked phone which I also tried with rooting. Android 6 to 8.1 installs fine. I have dropped it back to 7.1.2, bootloader is unlocked, TWRP is installed, partitions wiped and so forth. I must be missing something somewhere, I have retraced steps, tried stable, edge and the other two, but it always hangs at Preparing system image (I have left it for a couple of hours and nothing changed). This is the only phone I have had an issue with so far. Has anyone any ideas?



  • @MrT10001 the current version of the windows 10 installer is bugged 😕 I had the same thing happen to me. You have to use the linux installer as far as I know. Maybe you could use windows subsystem for linux. Or perhaps the mac installer works. If you can't do either then maybe you can use the manual method described at the beginning of the thread or simply wait for the next installer release.



  • @DjDeets Can you please send a log file from the installer when it hangs? It should be in %APPDATA% directory somewhere...



  • @DjDeets Thanks for that. I was going to give Linux a go next (time is the limiting factor at the moment) as I was wondering if it was a windows thing.



  • @Flohack I'm looking at 2 log files which I think are from that time (October 11th), but they're .OLD files for some reason. When I open them with notepad they don't seem to be functioning log files. Here's an example of the contents of one:

    2020/10/11-13:37:37.233 60e4 Reusing MANIFEST C:\Users\Admin\AppData\Roaming\ubports-installer\Session Storage/MANIFEST-000001
    2020/10/11-13:37:37.236 60e4 Recovering log #3
    2020/10/11-13:37:37.238 60e4 Reusing old log C:\Users\Admin\AppData\Roaming\ubports-installer\Session Storage/000003.log 
    

    The files it's referring to seem to be gibberish, I don't know what to do from here. I would reinstall on windows to replicate the error, but I'm on day 5 of the Endurance test. (I think it was mentioned in the ubports podcast as "silently failing?" But I don't trust my memory.)



  • Rip, I accidentally let the 6p run out of power on day 6 and a few hours.



  • I'm just posting again with an update to other issues I've noticed with the 6P vs the Oneplus One.

    1. Bluetooth doesn't work.
    2. The lowest light setting is like a blinding torch in the dark at night
    3. Some web apps don't work that do work in in the OPO. I suspect this is a 64 vs 32 bit issue, but don't understand why that would occur in a webapp. Windy is a example of this. Interestingly enough, using webber to create a webapp works fine.
    4. I'm able to install a libertine container, but installing any app fails in a weird way that I don't really feel like typing up as I suspect this may be a known issue I just couldn't find when googling. I also suspect 64/32 bit architecture issue here, as well.

    Previously reported observations that are still in effect:

    1. Wifi needs to be turned off/on again after locking

    unrelated: The battery life after replacing the battery is fucking insane. For everyone complaining about that, I cannot recommend how much better it is enough. Get a heat gun, watch a youtube tutorial on how to do it, and get it done. It is so worth it.

    This port is getting really good, though, thanks so much!


Log in to reply