Call for testing: Google/Huawei Nexus 6P (angler) owners



  • @kodaxx said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    shing other files does not work either until I remount or wipe, and running the tool again immediately fails

    Can you try to psuh those files manually with adb? Lets at least see if that works. I dont want to tell it, but it might be that your flash ram is faulty.



  • Try to push which files manually? I can push pictures or other random files manually using adb without issue. If you mean to push the image files, I'm not sure where those are located - they seem to be created in a temporary directory and then deleted?



  • @kodaxx said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    ey seem to be created in a temporary directory and then deleted?

    You can push the downloaded rootfs and the system.img for testing - they are bigger and hopefully trigger this error too.

    You might also want to try another cable to be sure.



  • Sorry guys, I somehow destroyed the device during a repair, and now I need to see to get a replacement coming. So I wont be able to work on the port for some days. But believe me, I want this to be done still!



  • @Flohack That's the one I've been using. I'm gonna see if I can dig a little bit deeper. Sorry if it's a few days, though. Work is wiping me out.



  • So I tried it again and it actually built and installed. When you say "Wait with some patience," how long are we talking?



  • @phillip-walters Not sure, maybe 2 or 3 minutes. Do you get anything in dmesg -w on the host?



  • No. No RNDIS interface or anything. I'm wondering if my phone is hosed up.



  • @Flohack I'm a hardware guy. I'd be happy to help you troubleshoot your 6P if it wasn't something catastrophic



  • @rocket2nfinity Well I changed battery, and that went fine, though one of the connectors became loose, so I planned another investigation for the next day.

    On the next day, while being able to remove the parts which need to be warmed up with a hairdryer worked well, I could not get the cover off, and I used too much force and accidentially came between the screen and the PCB, instead between PCB and case. So the screen broke, and I have a full length of damaged area plus a crack in the screen.

    I´m an idiot, I did not take out my contact lenses this eve, and so I couldnßt really see what I was doing 😉

    I wanted to get this as a daily driver, when I see that the porting status is well enough, but with that screen I cannot use it anymore. Instead I will look for a used one in medium condition, max € 100,-

    It would be possible to change a screen (but then this unit also has the CPU bug and cannot run on all 8 cores, so I would not invest in it further) but I dont feel like doing this, or paying for that.



  • @Flohack Not an idiot. These things are getting harder to service everyday. I especially hate the ones with locking latches. They are designed to break, thus rendering the device unserviceable (unless you get crazy with the glue).

    I agree, not really worth it for a device with the cores disabled. However, ebay has plenty in your price range, and if you go on xda-developers and tell the community what you're doing with Ubuntu touch, I'm betting you'll get donations. I'd donate here if there was a button to, and I certainly will there if you do.

    There are a lot of us with Nexus 6Ps who would love to get Ubuntu Touch, or any of the other halium based ports on it.



  • @rocket2nfinity said in Call for testing: Google/Huawei Nexus 6P (angler) owners:

    Nexus 6Ps who would love to get Ubuntu Touch, or any of the other halium based ports on it.

    Great motivation, thanks. I am already chasing 2 devices. So sad that it might not be here for FOSDEM. I wanted to show it off on the conference 🙂 but lets see

    I am not really active on XDA, do you think it makes sense for UT people to hook up there with the "real" Android community?

    BR Florian



  • @Flohack very sad, but still exciting.

    I do think it's worth putting up UT ports up at xda-developers - for the devices that are known mostly working, on their specific device page. It might encourage the curious among the greater Android developer community to give UT a try. I myself have tried several OSes I wouldn't have (or even known about) if it hadn't been posted on XDA.

    But if you don't, then add a donate button on ubports so we can encourage developers who are having successes with some monetary incentive. I have a few devices lying around that I would gladly put a port bounty on. For those of us who know enough to follow along and install a successful build but nothing more, this is how we can contribute to the project.



  • @phillip-walters Can you boot into recovery right after it locks up with PWR + VolUp, and then get the contents of /sys/fs/pstore/console_ramoops? We might try this



  • Good News! Tomorrow I should get a new device 😛



  • The new device has arrived. Unfortunately I somehow lost a few updates, so now I am back to a state where modem and network does not work...



  • @Flohack Sorry for taking so long to reply. I will give that a try.



  • I just found out that I linked the wrong halium-install release, in case you dont want to clone. Please use only this: https://github.com/JBBgameich/halium-install/releases



  • I don't know how to colaborate with your color coded word document, but I have successfully booted Ubuntu Touch on my Nexus 6P!

    It took me many many hours of trying combinations to find out the only 7.12 Google images I could boot was the OTA. Factory would not install, lineage 14.1 builds would install but not boot. As soon as I loaded the last 7.1 OTA, and ran the halium script, it came right up. Someone more knowledgeable than I will have to figure out why the others did not work.

    Quick rundown of what works:
    -gui
    -WiFi and cell 4G LTE
    -audio
    -video

    What does not work:
    -camera (it crashes the OS hard requiring power + volume to reboot)

    Don't know if it works:
    -dialer and sms (I have a data only sim in it. will test again after I swap it out)

    This is awesome!



  • Bluetooth is not working 😞

    And random UI freezing requiring reboot. So do I start filing bug reports or do I collaborate with your alpha testers document since you said this isn't linked to a standard build yet?

    I really like how it performs though - fast and smooth....


Log in to reply