Xiaomi Redmi 4X (santoni)

    • sorry for mistake - the first one was
    fastboot flash boot ../../fastboot/imgs/halium-boot.img

  • @Danct12 all LOS 14.1 roms I found works. ( ROMs before official LOS) I have twrp 3.3.1, I formatted data as ext4. I have 3GB version of redmi 4x, my LCD display was changed once. My logs seems ok, but I am unable to get even telnet working. Other my halium 14.1 devices are working fine using this method (hammerhead and kenzo). I am not sure what else to do.

    [dano@dano-80qd Downloads]$ ./halium-install/halium-install -p ut ubports-touch.rootfs-xenial-armhf.tar.gz system.img 
    [sudo] password for dano: 
    Debug: Chosen rootfs is ubports-touch.rootfs-xenial-armhf.tar.gz
    Debug: Chosen android image is system.img
    Debug: Chosen release is ut
    Debug: Compress images before pushing: false
    I: Writing rootfs into mountable image
    I: Writing android image into mountable image
    I: Running post installation tasks
    enabling Mir ... [done]
    enabling SSH ... [done]
    Please enter a new password for the user 'phablet':
    Enter new UNIX password: 
    Retype new UNIX password: 
    passwd: password updated successfully
    I: Shrinking images
    e2fsck 1.45.6 (20-Mar-2020)
    resize2fs 1.45.6 (20-Mar-2020)
    Resizing the filesystem on .halium-install-imgs.KFoU8/system.img to 129406 (4k) blocks.
    Begin pass 2 (max = 32743)
    Begin pass 3 (max = 24)
    The filesystem on .halium-install-imgs.KFoU8/system.img is now 129406 (4k) blocks long.
    I: Unmounting images
    I: Pushing rootfs and android image to /data via ADB
    I:    Pushing rootfs to /data via ADB
    * daemon not running; starting now at tcp:5037
    * daemon started successfully
    .halium-install-imgs.KFoU8/rootfs.img: 1 file pushed, 0 skipped. 13.2 MB/s (3221225472 bytes in 233.033s)
    I:    Pushing android image to /data via ADB
    .halium-install-imgs.KFoU8/system.img: 1 file pushed, 0 skipped. 13.1 MB/s (530046976 bytes in 38.671s)
    real	4m32,192s
    user	0m0,484s
    sys	0m4,332s
    I: Cleaning up
    umount: .halium-install-rootfs.ttgv0: not mounted.
    [dano@dano-80qd Downloads]$ sudo fastboot  flash boot halium-boot.img 
    [sudo] password for dano: 
    Sending 'boot' (16084 KB)                          OKAY [  0.557s]
    Writing 'boot'                                     OKAY [  0.137s]
    Finished. Total time: 0.699s
    [dano@dano-80qd Downloads]$ sudo fastboot reboot
    Rebooting                                          OKAY [  0.000s]
    Finished. Total time: 0.050s
    [dano@dano-80qd halium-install]$ sudo dmesg -w
    [15392.651927] usb 1-3: new high-speed USB device number 19 using xhci_hcd
    [15392.669563] usb 1-3: New USB device found, idVendor=18d1, idProduct=d001, bcdDevice= 3.18
    [15392.669569] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [15392.669573] usb 1-3: Product: Redmi 4
    [15392.669576] usb 1-3: Manufacturer: Xiaomi
    [15392.669579] usb 1-3: SerialNumber: 225ac30a7d04
    [15400.207598] usb 1-3: USB disconnect, device number 19
    //reboot from recovery to fastboot
    [15400.531883] usb 1-3: new high-speed USB device number 20 using xhci_hcd
    [15400.549566] usb 1-3: New USB device found, idVendor=18d1, idProduct=4ee2, bcdDevice= 3.18
    [15400.549572] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [15400.549576] usb 1-3: Product: Redmi 4
    [15400.549579] usb 1-3: Manufacturer: Xiaomi
    [15400.549582] usb 1-3: SerialNumber: 225ac30a7d04
    [15438.269896] usb 1-3: USB disconnect, device number 20
    //reboot from fastboot to system(no other logs)
    [15440.886720] audit: type=1100 audit(1585657060.387:1823): pid=46212 uid=1000 auid=1000 ses=2 msg='op=PAM:unix_chkpwd acct="dano" exe="/usr/bin/unix_chkpwd" hostname=? addr=? terminal=? res=success'

  • It would be nice to have an option to install ubports with
    Xiaomi tool v2, with dual boot option.
    Not sure it's an open project though.

  • @suoko UBports does not support duel boot I'm afraid, sorry.

  • @maciekrz12 said in Xiaomi Redmi 4X (santoni):

    Failed to boot

    If your device's userdata partition is encrypted then unfortunately you'll have to format it, meaning you'll lose all your data.

    To do so, goto TWRP -> Wipe -> Format Data (the button is in red)

    After that reinstall Ubuntu and hopefully it'll work. If not please telnet and give me dmesg (put it on pastebin or something).

  • Hi
    Can i install this just from my phone using TWRP or i must connect to pc and install it from pc terminal using linux? Do you have instructions for dummies i dont get this.I use Ubuntu on pc so i would like to try it on the phone as well. Thanks

  • @aceclan I'm trying to understand this dual boot since I don't see any resize of any partitions.
    Can you explain how that works ?
    I understand you flash the boot image according to the os you want to boot, but where are located the two images of android and ubuntu ?

    One question then: my TWRP folder only contains a .twrps file, is that fine ?

  • @Danct12 THANK YOU!
    I've been wiping all the time instead of formatting. Now it works just fine 🙂

  • I'm trying to flash ut but I got this error:

    ./halium-install -p ut ./ubports-touch.rootfs-xenial-armhf.tar.gz ./system.img
    basename: not valid option -- "p"
    Try 'basename --help' for more information.

    cleaning up
    error: no devices/emulators found

    Using files from:

  • @danqo6 Can you try to upgrade the firmware to the latest? I use this https://xiaomifirmwareupdater.com

  • @suoko Distro?

    You should try this one instead: https://github.com/JBBgameich/halium-install

  • @Danct12
    I successfully installed the version of ut found here : https://forum.xda-developers.com/xiaomi-redmi-4x/development/unofficial-ubuntu-touch-redmi-4x-santoni-t3982389
    These are the steps:

    • rooted and installed twrp with Xiaomitool v2
    • in twrp I wiped the data partition and enabled write access to system
    • installed the zip via twrp

    Now, how can I create an update zip package with the latest image?

  • @Danct12
    I found a way to create the zip, tell me what you think:

    wget https://ci.ubports.com/job/xenial-rootfs-armhf/lastSuccessfulBuild/artifact/out/ubports-touch.rootfs-xenial-armhf.tar.gz
    mkdir rootfs-build
    dd if=/dev/zero of=rootfs-build/rootfs.img seek=500K bs=4096 count=0
    mkfs.ext2 -F rootfs-build/rootfs.img
    mkdir -p rootfs-build/cache/system
    mount -o loop rootfs-build/rootfs.img rootfs-build/cache/system/
    cd rootfs-build/cache/system && zcat ../../../ubports-touch.rootfs-xenial-armhf.tar.gz | tar xf -
    • put back the img files into the zip according to their original position: system and rootfs into data, and boot into the root position (the rootfs img is in the rootfs-build folder)

  • @Danct12
    Thanks, it worked, I used the standalone version.


    cat /var/lib/lxc/android/rootfs/ueventd*.rc|grep ^/dev|sed -e 's/^\/dev\///'|awk '{printf "ACTION==\"add\", KERNEL==\"%s\", OWNER=\"%s\", GROUP=\"%s\", MODE=\"%s\"\n",$1,$3,$4,$2}' | sed -e 's/\r//' >/usr/lib/lxc-android-config/70-santoni.rules

    Cons: neither system nor apps have sound. With the unofficial zipped port in xda at least apps had sound

    Can we try create a script automating the creation of the flashable update zip ?

  • @Danct12 i am on android 10 rom
    can i flash ub directly or i must flash Los 16 first?

  • @Danct12 I tried, it didn't help. I will wait probably for ubports installer support, would love to see it soon

  • Hi @suoko ,

    The switch is based on boot image flash (restore from TWRB th boot) and the Ubuntu is just two .img files : rootfs.img and system.img which will be mounted, during the boot. So the partitions won't be touched...
    The locations of img files (browse from TWRP) is on /data/ , while the location of Internal storage that You see in MIUI is /data/sdcard or /data/media/0 .

    Work like a charm...

    Best regards

  • Capture.PNG

    it gets stuck here infinitely, no error is shown, its just stuck here
    what to do pls someone help me regarding this issue

  • Hi,
    just wanted to confirm - is anbox supported within this build?

  • This post is deleted!

Log in to reply