Nexus 5 - no connection; Sprint

  • Hi,

    I've just flashed Ubuntu on my Nexus 5 using magic-device-tool. (I've used desktop Ubuntu for years, but this is my first time using it on a mobile device.) Everything seems to be working fine on wifi, but when I switch wifi off, I can't get an internet connection. My network connections show Cellular Data is enabled, with "Sprint 4G" appearing under that setting (that text is gray; not sure if that means anything), and bars are full.

    I've had problems with Sprint data on this phone when using Cyanogenmod (there's a thread on the subject at XDA Developers); not sure if that's relevant or if this is a different problem.

    I tried poking around under "Cellular Settings" but haven't had any luck; setting either "Automatic" or "Sprint" under "Carrier" doesn't seem to work, and I don't know what to set under APN (if anything).

    Appreciate any ideas; thanks.

    EDIT TO ADD: It turns out it wasn't just data; phone calls didn't work either. I tried calling my wife's phone; I heard one ring on my phone and then nothing, and her phone never rang.

    Since this is my primary phone, I switched back to Android (LineageOS) for now, but I'd like to try Ubuntu again in the future if anyone has any suggestions. (Maybe I'll wait for 16.04.)

Log in to reply