Feedback for the Seabass

  • @kugiigi Hm, actually, I've just been able to build the Seabass on my Xperia inside a libertine container using clickable, so the integration with a build engine might be possible 🙂

  • @mikhael Awesome! Are you using the latest clickable version? I'm a bit more hardcore because I resize my rootfs and install stuffs there directly and when I tried clickable, it's looking for docker images even though I used --container-mode.

    Anyway, I guess you just need to find ways to execute commands in a libertine container then pick up the click package install and run. That would be really cool!

  • @kugiigi said in Feedback for the Seabass:

    it's looking for docker images even though I used --container-mode

    Yes, the latest clickable and it gives me the same error.
    So... I had to comment out this line in clickable script where the error about Docker images is thrown 🙂
    Then --container-mode seemed to work for me.

  • @Capsia said in Feedback for the Seabass:

    The three lines icon on the top left is confusing: user would expect a drop down menu, but it actually opens a file chooser

    @Giiba said in Feedback for the Seabass:

    I have to agree about the hamburger menu not being clear.

    Hm, thinking of a suitable icon... What do you think about the three lines icon in a File browser (it opens list of directories)? Is it less confusing here then in the Seabass?
    File browser

  • @kugiigi said in Feedback for the Seabass:

    remember, there was an app before called OnTheRoad. It basically provides a full container and I remember I was able to make clickable work on it. Maybe something like this can be integrated into Seabass

    I'm actually thinking about integrating Seabass with Clickable for the next release.
    I've found no major issues with executing Clickable from the Seabass so far 🙂

  • @mikhael said in Feedback for the Seabass:

    Hm, thinking of a suitable icon... What do you think about the three lines icon in a File browser (it opens list of directories)? Is it less confusing here then in the Seabass?

    Actually no, it opens a list of bookmarks to directories. A subtle difference, I will admit, but a significant one.

  • @mikhael How do you plan to do it though? chroot or integrating with libertine?

  • @kugiigi Libertine (with hardcoded chroot backend for the first release).

  • @mikhael that's a fair point, and I think more than anything consistency could be important. Maybe just sticking with the two icons like the file browser, the top right one is clearly settings which only leaves so many things the hambuger could be (a file browser in a coding app seems logical).

    It could be worth asking the famous @CiberSheep for ui advice. But it is not like there is a problem as is, it doesn't take very much poking around to find a file and you only need to do it the once to learn.

    A tangential though related feature request would be two things:

    1. Connecting with the content hub to allow opening files with Seabass from the file browser
    2. The ability to view system files in a read-only mode (ie navigating to / and exploring) - as a newbie to linux os's in general I spend a lot of time reading and viewing system files just to learn. Currently uText works for this, but something with syntax highlighting to view qml and bash scripts would really be great for UT. On desktop I use gedit happily, but that's not going to work for us here.

  • Thank you for your thoughts on the Icon!

    @Giiba said in Feedback for the Seabass:

    A tangential though related feature request would be two things

    Thank you! Content Hub for the Seabass is definitely on my todo. It'll take a few releases before Content Hub is implemented though:

    • v0.5 release will feature building packages with Clickable
    • v0.6 will probably contain ability to delete files (seems to be the only blocker left before Content Hub integration)
    • and then v0.7 will probably contain Content Hub integration.

    Well, at least this is what I think for now 🙂

  • @mikhael Hi,
    I agree with @arubislander for the difference between the favorites menu in the file explorer app and the files menu in Seabass.
    In the file explorer the menu is used as a bookmark menu to access favorites more quickly, while in Seabass it is used to choose a file and navigate directories. Probably after the first use it will be easy to understand what the icon does, but if you opened the app for the first time it isn't very clear.
    I would also prefer the icon to be separate from a settings menu, because it is one of the most frequently used ones.

  • v0.5 is up and it has support for building projects using Clickable.

    The feature is very experimental and somewhat limited for now and (although I've tested it as much as I could) there should be bugs. To build a project you need to open a corresponding clickable.json file and click the "Build" button:

    When starting a build process for the first time a new chroot Libertine container with ID seabass2-build will be created.
    So the first thing required to build packages with the Seabass for now is... patience :-D.
    Because creating a chroot container might take a while. About 30min was usually enough for my Xperia X during testing, but the experience for sure may vary depending on your device and Internet connection. The app should also be active (not sleeping) while the container is being created. The good thing is that you only need to create container once.

    If for some reason the container creation failed, Seabass will try to delete the container, so that the next time you run Build it could try to create container once again.
    And if for some reason the deletion wasn't successful, libertine-container-manager is here to help: libertine-container-manager destroy -i seabass2-build. You could also use this command if anything goes wrong with the container 🙂

    There are also a few limitations:

    • Project files should be located inside ~/Downloads or ~/Documents directories. Not really a strict requirement, just these directories are automatically mounted to Libertine containers. Alternatively you could create additional bind mounts using libertine-container-manager or maybe even System Settings application.
    • clickable.json file should be named 'clickable.json'. Because the "Build" button is only visible for "clickable.json" files.

    QML, HTML, C++ and Python clickable templates are supported for the first release (Go and Rust require additional packages that are not installed in seabass2-build by default). By "supported" I mean I've tested building "HelloWorld" applications using these templates 🙂

    Please let me know if there are missing packages in the container required to build your favorite application!
    Your feedback is very appreciated!

  • A few notes on v0.5.0:

    • Container creation fails constantly for me because of mismatching package versions in the xenial repos.
      How to fix: update to v0.5.1
    • Seabass can't delete the container in case of initialization errors
      How to fix: delete the container manually using System Settings app
    • And in case you've managed to create a container, desktop applications from the seabass2-build container are visible in the app grid.
      How to fix: libertine-container-manager exec -i seabass2-build -c "bash -c 'rm /usr/share/applications/*.desktop'"

    The issues should be fixed in v0.5.1

  • @mikhael I am getting crash on oneplus 3t edge channel during start.

  • @danqo6 thank you! I can reproduce the issue on Pocophone with GSI. For me the same happens when trying to run other apps that use qmlscene from terminal (I tried it with uNav). But running the applications from the app grid works fine.

    Just a guess, but maybe the app grid provides environment variables, that are required but missing when trying to run qmlscene from terminal?

  • @danqo6 does the app works for you when running from the app grid?

  • No, just crashes, not sure how to get log when running from appgrid

  • @danqo6 logviewer from the open store should work for getting logs

  • I am pretty sure that launching apps from the terminal is not a supported feature of UT. Some sort of permissions thing (appArmour) blocks the execution of graphical applications.

    Crashing from the grid is a different issue. Try going into


    and delete the seabass folders, then try launching the app from the drawer.

  • You can run apps via terminal using ubuntu-app-launch. Other than that, it might and or not work.

Log in to reply