Nexus 5 does not show any wifi networks

  • Hi stanwood,
    Yes I did, but it doesn't solve the problem. Still the same. Also adding SSID and PW to hidden networks did not help.

  • Ok, it's weird. Wifi is working fine on my N5. If reboot than turn wifi off + on do not help, there might be a failure with your radio firmware, or something went wrong during installation process.
    Try first to reinstall UT from UBports Installer (NOT choosing "Wipe data") and try again. If still not working you might flash your firmware.

  • Update to dev channel try that if it fixes it move back to stable and you should be ok.

  • Thank you both for your assistance. Today I realized my phone receives wifi signal if I am very close to my router. So network signals are only identified if they are very strong.
    App "wifi scanner" shows significant drop of signal strength even if I move 10m away with no wall inbetween.
    Is it possible to be a SW issue? In this case I would like to follow your instruction and reinstall the UT (dev first than stable)

    best regards

  • @Bernie Have you checked the connectors going to the antennas inside the case? It is possible one came loose or got crimped if someone changed the battery.

  • @Bernie Dev update using System Settings, Updates, Update Settings, Channels.

  • @Bernie said in Nexus 5 does not show any wifi networks:

    Is it possible to be a SW issue?

    It's always possible, but given your observations I highly doubt it.
    Mostly a hardware issue and possible failure of the wifi chip or antenna as @rocket2nfinity suggested.

  • @Bernie Just to share my experience: When I first installed UT on my N5, I had a trouble with my display which was shift on the screen. Was unable to fix it. Finally I solved it as following:

    On a Windows 10 PC, install and run « Nexus Toolkit »
    Flash latest Android version back. (It also updates all firmwares)

    Activate Developer mode + enable Android Debug Bridge

    Reboot in bootloader

    Run UT installer and install UT again

    Than everything runs smooth & fine.

    If you don’t have a Windows PC you can flash your N5 manually using an official Google factory Image.

    Maybe this can help you (?)

  • I had the same issue a while ago. Wifi stopped working (i.e. would not detect any network) no reboot or even a clean reinstall would fix it. I ended up buying another N5 to use as daily driver. The other day I got back to the broken N5 because I needed a "phone only" phone for travel and voilà wifi was was working again up until last week, when it stopped again (no network detected at all). I think this is a hardware issue (lose contact are ailing wifi chip). I did not open it to check because i was afraid to break something and the phone would become completely unusable.

  • Dear all, thank you for your support.
    Meanwhile I have checked Wifi antenna, but could not find a visible failure. In addition I have flashed latest Android version and realized also here wifi receiption to be poor. So I think it is definetly a hardware issue.

  • @stanwood Same for me, happened a few times in the beginning, but that was before the OTA 12.

  • My N5 had the same problem before.
    I switched wifi on/off for several times and again and again but it didn't get well.
    Then I reboot N5 but wifi settings did't display any wi-fi stations, just empty.
    After all I reinstalled Ubuntu Touch from firmware. Wifi had worked fine again.
    So It was not hardware malfunction.
    At first I also doubted wi-fi malfunction, but wifi anneta indicator shown it was receiving radiowave.
    And I'msure this was happened after I tried wifi tethering.
    Wifi tethering worked but unstable so sometimes I could see N5 via bluetooth from my PC but sometimes not.
    After I was doing wifi tethering on/off again and again I had noticed N5 didn't display any wifi station at all.
    I've never wifi tethering on after reinstalling ubuntu touch.
    This is what I experienced. Thank You.

  • You can try to install the last android version avalaible from Google (to get last firmwares) and then intall back UT.

Log in to reply