Anbox - apps have no internet


  • I updated Anbox and now the apps do not have access to the internet, but fdroid still does.

    Any way to fix this short of completely re-installing Anbox? I searched the forum and the web but could not find an answer.


  • Updated Anbox? What ecxactly did you do? AFAIK there hasn't been an Anbox update lately...


  • @hankschwie I used the Anbox-tool upgrade command


  • And ended up with an android.img file in /home/phablet/anbox-data, dated 08.08.19, size 217.2 MB?

    I guess you just have to retry installing. What is the output of the command
    anbox-tool status executed in the terminal app or via ssh/adb shell?


  • @hankschwie All enabled and ok


  • @rocket2nfinity
    What channel are you using? After an update of RC I usually have to go through the whole installation process again on my Fairphone 2.


  • @hankschwie stable. Anbox runs as it always did, just no internet for all apps except fdroid. I found several posts on gitlab and Anbox forums with the same problem, but no solution.


  • Did you restart the device? Anbox is far from stable...


  • @hankschwie Multiple times. At this point, I think I just need to groan and re-install everything.

    I updated it, because I could not play videos in Anbox apps. There is a fix for that with Anbox, I applied it on my X86 tablet, and now I can watch videos and make VoIP calls on that tablet. I was hoping the same patch was included for the arm version. Instead, I just broke the network bridge somehow.

    Strange though that fdroid still has internet access and the other apps don't.


  • I would like to have videos playing in anbox as well but now I am afraid to update... Anybody else updated their anbox? Are videos working? Is internet still working? By the way, I use anbox for whatsapp and I have internet. But I never had internet in any browser in anbox. Was your Internet working in a browser in anbox before?


  • @mihael No, browsers never worked in Anbox, but I think I know why. I re-installed my anbox, paying attention to app permissions before and after. Quite a few apps I have discovered have custom permissions. So jitsi works, facebook works, other apps work, but browsers do not because of a custom permission applied. Before I start tampering with that, I need to figure out, first how my permissions changed when I updated, second why are the custom permissions set that way? It must have taken some time to go through apps and pick which ones had full internet access and which would not, so I'm wondering if I found the wall of the sandbox meant to protect UT from Anbox, and what are the ramifications if I mess with it?


  • So, after further research, the premissions don't seem to be causing the trouble, it appears it may be a problem with the setup of the network bridge. This is the same problem that caused me to not be able to watch videos or use Voip on my x86 tablet. In that case, I could load webpages, but no video or audio streams would play, nor could I use the microphone or camera.

    Someone with a higher level of knowledge of adb can hopefully figure out how to try this with Anbox in UT

    https://superuser.com/questions/1395384/internet-not-working-in-anbox-on-ubuntu-18-04

    @Flohack could you direct this to whomever has been working on Anbox? A similar fix got my mic and camera working on my x86 Anbox. Maybe it might work for UT