apt-get install fails with read-only filesystem

  • Hi,

    I'm tying to install a little command line tool. But I get the error

    read-only filesystem

    That concerns /usr/local/bin/.
    I have developer mode enabled but that doesn't help either. Is there a way to do this?


  • I believe you should use libertine contener to use apt-get in it.
    Read-only FS is wanted on the major part of the system, uTouch works that way to prevent security issues.

    You can bypass this by enabling r/w access, for example with UT Tweak Tool, but it's very not recommended.
    You could break your system making it unusable, or break OTA update, and such things...

    Try it at your own risk... Or use libertine contener to be safe.

  • @jojuma
    Apps are expected to be click packages from the Open Store or any other mean you might have.
    Installation using apt is enabled within Libertine, so "desktop applications" can be tried on tablet or within external mouse, keyboard and screen.
    Libertine is a bit experimental though.

    As @Keneda mentioned the rootfs is mounted read only for good reasons.
    Tweaking is always possible, that's open sourced and we cannot prevent people from doing what they want, but it's completely not supported.

  • Thanks for your replies. That means, I also can't use neither curl nor wget for the same reason, right?
    Sorry for asking, I'm not that experienced yet.
    I'll definitaly follow your recommendations since I absolutely don't want to risk breaking the system.

  • To be able to write once on read-only filesystem

    sudo mount -o rw,remount /

    But as said, the rootfs is mounted read only for good reasons.

  • And the reason for that s among security that we are doing delta OTA upgrades, so if you modify your root file system you will eventually break this functionality. Instead you will get a new, fresh, read-only image of / and so all your things installed with apt are lost. Also it is very hard for us to help users with issues if we don´t know what they have installed.

    So as suggestd, create a libertine container in system settings and install it there. This is not a traditional desktop environment, the design choices for mobile devices have been made a bit different here.

  • Got it, thank you for your help.

  • @jojuma You can also take a look at this blog post. It is a bit old, but still relevant. Scroll down to the bottom to get right into it.

  • Related to this, I find also that many packages are simply missing from apt -- no vim, no git, no irssi... but looking at the apt config it looks like it's just using the normal Ubuntu ARM repos (plus some extra stuff) -- anyone know why many common packages apt simply cannot find?

  • @singpolyma apt is still not supported as a means of installing things in the rootfs. All of those things can be installed inside a libertine container and it works fine.

Log in to reply