Google Pixel 3a (sargo)





  • @dieharddan I remember going back to an older 9.0 based factory image to get rid of the qcril_google_init() Fail. line, maybe it's related to the SMS receive issues.



  • @fredldotme ill give it a shot and see what happens



  • @fredldotme Downgraded to the oldest 9.0 and also tried the newest 10.0, no sms on either



  • The Pixel 3a does not have a notification led. I have heard the led screen uses such low power when black that you can simulate one.



  • I'm currently working on the Pixel 3a port again. We're not going to use the GSI for an initial release, we'll require device-specific Halium builds instead for now. This means that for the 3a XL variant someone has to step up and work together with us to support it, as subtle differences make that the better approach.



  • @dieharddan still rocking the 3a XL? If you want to help us support the device, I have made changes so that the Halium build can start now. We'll soon have Installer support for the 3a, which means there is very little for you to do to support it.



  • @fredldotme Had to sell it unfortunately, I plan to repurchase later and will contact you when I do



  • Hi @fredldotme , I know from the ubuntu touch Q&A that sargo is coming and you are looking for users with bonito users.

    However, how similar are pixel 3 & pixel 3 XL with the sargo ? Will they work or is it too different ? Currently thinking of getting a bonito as they are available locally but there are more pixel 3/xl available than bonito



  • @kaiyes The Pixel 3/3XL would need a new port, that I can't help much with. So it would be better to get a sargo (or bonito if you want to help).

    In other news, I haven't been able to reproduce the SMS problem as of late, so that should be fixed on sargo.



  • @fredldotme I found a great deal on another pixel 3a xl which I will receive in a couple days, I would like to assist in getting this supported alongside sargo



  • @fredldotme I received my device; are you able to share any details on installing ut?





  • @fredldotme So I was able to install UT and everything I tested so far works flawless!! The only issue I have is I'm still not able to receive text messages; sending texts seems fine. Any ideas?



  • @dieharddan So I think there's two things we could try: debugging ofono or rolling a separate build for bonito too. I would prefer not having to do this second one but there's, luckily, some other ways I could propose to speed up XL enablement, but maybe I'm too slow, I don't know 😛

    I'm testing this configuration file right now, which I'm in the process of determining whether ofono is doing everything right (it certainly doesn't by default on my sargo) or not.

    Enable adb via Developer Mode, reboot into bootloader, choose recovery, wait for adb devices to properly connect to your device (it could take some time) and run following command:

    wget -O ril_subscription.conf https://gist.githubusercontent.com/fredldotme/f95acc04d8ec7e470955359b570d24e7/raw/d89b29790029e952611599273c40e9b144d63a54/ril_subscription.conf
    adb shell mount /system_root
    adb shell mount /system_root/var/lib/lxc/android/android-rootfs.img /tmp
    adb push ril_subscription.conf /tmp/system/halium/etc/ofono/ril_subscription.conf
    adb reboot
    

    I can't test it with my own phone right now, due to it requiring a reboot and breaking testing daily-driveability of this configuration of ofono, in case of an error you might have to change the values using busybox vi manually, that's how I created the config.



  • ./adb push ril_subscription.conf /tmp/system/halium/etc/ofono/ril_subscription.conf

    adb: error: failed to copy 'ril_subscription.conf' to '/tmp/system/halium/etc/ofono/ril_subscription.conf': remote write failed: No space left on device
    ril_subscription.conf: 0 files pushed. 1.5 MB/s (10559 bytes in 0.007s)



  • @dieharddan In that case maybe removing the existing file and pasting it using busybox vi would solve the issue. The ofono config though seemed unhelpful in resolving all issues I keep having, maybe it has to do with different carriers behaving differently now, I certainly receive SMS anyway but sometimes signal drops without indication and stays unresponsive. I don't know why the ofono-ril-dance doesn't work the way it's supposed to work yet so it might be interesting to find out.



  • You may be right, but I'm willing to try it anyway, though I'm not certain how to use busybox as I am not familiar with that



  • @dieharddan In case something went wrong with the config you can re-install without wiping using the Installer of course, but what you could do to get some details is (in the running system, ie not the recovery):

    setprop persist.vendor.radio.adb_log_on 1
    sudo reboot
    

    And after the device is back up:

    sudo env LD_LIBRARY_PATH=/vendor/lib64:/system/lib64 /system/bin/logcat -b all
    

    It hopefully shows what the error in your case is, else you would have to figure out a way to debug on your own.

    Btw, does your device report itself as bonito or sargo in the recovery adb shell and in system-settings?



  • I dont see a model listed in the recovery screen, the system settings say "Google Pixel 3a"


Log in to reply