Google Pixel 3a (sargo)

  • @Louie Could you please try the following:

    sudo mount -o remount,rw /
    sudo cp /home/phablet/Downloads/ /usr/lib/
    sudo reboot

    Also interesting for you, please try to replicate the change here:

    In case you don't know how to do this:

    sudo mount -o remount,rw /
    sudo nano /etc/init/ofono.override

    Remove the provision, from the file and save (Ctrl+o and enter, then Ctrl+x to exit) and sudo reboot for good measure.

    Please make sure to try the combinations separately, if any of the changes fixes it it would be interesting to know which combination it was, so please remember that and let me know! 🙂

  • Is it hard to get UT on a Pixel 3a? I think I tried to root it, and it was having issues. I'm fairly tech savvy...just not in this area of Android and Linux.

  • @Nathan123 rooting is not required but you need to unlock the bootloader. Follow this guide to unlock it:

    After that follow the guide, including reverting to the last Android 9.0 factory image and installing via the UBports Installer.

  • @fredldotme Thanks for your kind help 😎 . I tried both options in different order without success. However, when turning airplane mode on messages come through after around 40 seconds. Then when turning airplane mode off message can be received for a few seconds. Please let me know if there's anything else I can try...

  • @fredldotme Oh ok. I didn't go back to 9.0. I'm currently on android 11. Will do that.

    Here's the errors I'm seeing.

    Screenshot_20201118-025657.png Screenshot_20201118-025709.png Screenshot_20201118-025746.png

  • @fredldotme I really want to root. Don't I need it to have "complete control" over the phone?

  • @Nathan123 I'm sorry but this is not a support forum for Magisk and rooting. Installing Magisk is not a prerequisite so please follow the instructions on how to install UT.

  • @Louie What you could do too is make ofono run in debug mode and figure out what is hanging here, or send me the log in private (it will contain dialed numbers and such):

    Connect to the phone via adb shell, then run

    sudo mount -o remount,rw /
    sudo nano /etc/init/ofono.override

    And append -n -d to ofonod's launch flags.
    After a reboot you can obtain the log file from /var/log/upstart/ofono.log.

  • @fredldotme Just wanted to say, thank you! I have been dying to move away from Android/iOS, and was looking for the perfect device to do it on. I just got my hands on a Pixel 3a, and didn't even set up Android as I was so excited to try Ubuntu Touch. I'd like to mention, installation through the UBports Installer was an absolute breeze.

    Thus far, the experience is awesome! I look forward to seeing Ubuntu Touch grow, and I'm sure as I get my hands dirty I'll be revisiting this page many times.

  • @fredldotme I would like to try this, but im not quite sure what it means to append -n -d to ofonod's launch flags, could you elaborate?

  • @dieharddan I am trying this as we speak. What he means is if you edit the ofono.override, you'll see a line:
    exec ofonod -P provision,udev*,dun*,smart*,hfp_bluez5,stktest,sap

    Asking to add -n -d as flags for when ofonod executes.

  • @dsimmons Ok, thanks, I did edit the file as such: exec ofonod -P - n - d provision,udev*,dun*,smart*,hfp_bluez5,stktest,sap

    But i didn't see the log in the upstart folder, so I figured i did it wrong

  • @dieharddan I think the order matters here. Not familiar with ofonod, but it looks like the help page suggests that the -P is for noplugin, followed by a list of plugins not to use. So reading through here, provision,udev... and the others need to follow -P directly. I'd edit it to reflect this instead:

    exec ofonod -P provision,udev*,dun*,smart*,hfp_bluez5,stktest,sap - n - d

    I was able to get the log... now I'm trying to get it off my Pixel 😆

  • @dsimmons lol nice, i will give this a try thanks again

  • hah, yeah I am having a rough time of it. Default SSH config isn't working, trying to sort that so I can use SCP, if I try to email the file or copy over from the /home/phablet/ folders, it seems to think the files empty, even though when I look at it in nano it's not.

  • @fredldotme hey, I was able to get the ofono.log (I also have the SMS issue, but airplane mode on/off doesn't resolve)

    I'm not sure about pastebining this whole thing, is there anything in particular you're looking for, or a section I can parse out? It looks like there is a lot of identifying information, and I don't want to just slap it all in a public pastebin.

  • @dieharddan / @fredldotme looks like I may have found something interesting, I think short enough to drop here:

    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_list() 6 cell(s):
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=1,mcc=311,mnc=480,ci=78151704,pci=166,tac=1280,strength=18,rsrp=107,rsrq=11
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=0,pci=172,strength=12,rsrp=107,rsrq=10
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=0,pci=166,strength=13,rsrp=107,rsrq=11
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=0,pci=172,strength=13,rsrp=111,rsrq=16
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=0,pci=167,strength=13,rsrp=114,rsrq=15
    ofonod[2048]: drivers/ril/ril_cell_info.c:ril_cell_info_parse_cell_lte() [lte] reg=0,pci=200,strength=13,rsrp=116,rsrq=19
    ofonod[2048]: plugins/sailfish_manager/sailfish_cell_info_dbus.c:sailfish_cell_info_dbus_cells_changed_cb()
    2020-11-19 20:55:18 slot1< [00000146] RESPONSE_ACK
    2020-11-19 20:55:18 slot1< 0000: 20 03 00 00 46 01 00 00 ...F...
    2020-11-19 20:55:22 [gbinder-radio] WARNING: /dev/hwbinder:slot1 died
    2020-11-19 20:55:22 [grilio-binder] ERROR: slot1 radio died

    It looks like right after ACK, the radio hardware binder up and fails. Possibly related to the issue? Maybe driver failure?

  • @dsimmons that's interesting, thanks for finding that! I have built updated versions of some components and would like to see if they work for your use case:

    sudo mount -o remount,rw /
    sudo cp ~/Downloads/ /usr/lib/
    sudo cp ~/Downloads/ /usr/lib/
    sudo reboot

    It's certainly interesting that the rilmodem would just disappear from binder, so I'm eager to find out if that somewhat fixes your issue.

    EDIT: Also, could you please verify with dmesg -w | grep -i binder in a separate terminal window if there are binder transaction failures coming up when your issue appears?

  • @fredldotme Duped the two files to the /usr/lib/ location and rebooted. Here's the grep... ouch!

    [    3.842925] binder: 1661:1661 transaction failed 29189/-22, size 0-0 line 3047
    [    3.962031] binder: 1680:1680 ioctl 4018620d 7ff1452850 returned -22
    [    4.552391] binder: undelivered death notification, 0000000000000000
    [   10.773000] binder: release 2586:2586 transaction 6162 out, still active
    [   10.773011] binder: undelivered TRANSACTION_COMPLETE
    [   10.792496] binder: 2554:3673 transaction failed 29189/0, size 164-32 line 2987
    [   10.792508] binder: send failed reply for transaction 6162, target dead
    [   10.851370] init: bluebinder post-start process (3720) terminated with status 1
    [   13.790649] audit: type=1400 audit(1605921619.678:71): apparmor="DENIED" operation="open" profile="/usr/bin/media-hub-server" name="/proc/4541/timerslack_ns" pid=4415 comm="Binder:4415_1" requested_mask="w" denied_mask="w" fsuid=32011 ouid=32011

    As an aside - do you have any pointers on if this solution can be dual-bootable with an Android build? I'm excited about trying to push UBports forward, but the SMS/GPS issue is a major deal breaker as this is my daily driver now. I think I'm going to have to roll it back to the default Android build, but would like to keep helping.

    Else, I might make a bad habit of toggling back and forth between the two when I don't need my Pixel at full health 😄

    Are you not seeing any of the mentioned issues on your 3a? Maybe it's a carrier problem? I'm on Verizon (US).

  • @dsimmons i have the same issue on at&t

Log in to reply