Pinephone as a daily driver: test report

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    • Camera: it works but it doesn't 🙂 The app will open the camera, but the rate frame is like 1 frame/2 seconds, the image is in mirror. It works both photo/video mode. Strangely, the photos will be displayed correctly by the Gallery app. The picture quality is 2.1Mp and changing it will make the app turn dark and non-responsive.
      One thing to mention that caught my attention: at booting or when the Camera app is opened, the camera (I mean the hardware itself) makes a strange noise like a click which I think is because the camera is making a calibration test (or is going to the 0 (zero) point).

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    -GPS: Officially it doesn't work. But sometimes it does: PureMaps does nothing, but uNav is able sometimes to get my location and display the route. The SensorStatus app won't display any information about the GPS, but that might be the apps problem so is inconclusive.

  • Hi @C0n57an71n, Just going to move this to OS for now as it's is more about issues with the OS than porting the device. Thanks

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    -File transfer: Connection with a desktop computer via USB is not working. I use WifiTransfer app and Filezilla on the PC. The way it works: open WifiTransfer app and Filezilla. Make sure phone and PC are on the same Wifi network :). Copy the host IP, port, user and password from WifiTransfer and paste them in Filezilla where you should. Once the connection is established you can transfer files between them. As an advice: transfer one file at a time as bulk transfer might make the connection to drop. The downloaded files will be in /home/.local/share/wifitransfer.costa
    To copy or move them where you want to use the terminal since copy/paste function will make UT crash and reboot. To do that just type in Terminal:

    sudo cp -Ri /home/.local/share/wifitransfer.costa/ ~/home/Music/ 
    sudo mv -Ri /home/.local/share/wifitransfer.costa/ ~/home/Music/

    Of course, you can change the destination folder as you wish.

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    -Music playing: The Music player will import the music files, but most of the time will refuse playing them without any error or crash. A work around is: go to the folder where your music is, choose a file to be played, open it with Music player. The file will be played and sometimes the app will continue to play the next files, but that isn't always the case.
    I found that the CloudMusic app works really well and can play entire albums (online). It crashes sometimes, but I think this is more because of UT and less of the app fault.

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    • Calling: Did a test with the SIM from 3AT carrier (Austria) and all is ok in terms of sound, connection etc. The only exception is when calling numbers that starts with + (regardless if internal or international call): Pinephone won't manage to establish a connection. As a workaround use the 00 format and should be ok.

  • @C0n57an71n
    Hi, most issue you reported here are also reported in gitlab.
    I understand the need to share it in the forum, but it will be good if you can add the link to the gitlab for each problem so people can refer to it helping debug or test a PR...

    If you didn't know you can find them here:

    If you can't find your problem then please create a new issue there. Developers don't use the forum as a bug tracker.

  • Booting: from SD card.
    OS version: 12
    Channel: RC

    • Radio: Tested Wifi, Bluetooth, Hotspot. All seems to work fine without major issues. In fact, they work better than on my Nexus5 (except when changing from mobile data to WiFi and back seems to loose my mobile data connection, but no problem with WiFi.)
      Wifi: ping 38ms, download 25Mbps
      mobile data: ping 29ms, download 20Mbps
      [edit]: Switching from Wifi data to mobile data and back will make the mobile data connection to drop. This I noticed as well on version 8, stable.

  • @AppLee I know,I had a look over them, but I'm not a developer and I'm not up to date with which one was reported, which one was resolved and so on. My thread is a log more than a issue report in the hope that somebody might find useful information.

  • @C0n57an71n
    Yes I understand.
    Issues in gitlab are closed only when an OTA integrates the fix.

    And the issue itself may contains explanations about working around or asking for logs so people can help developers.
    That's why a link to there can be useful to both users and developers.

  • @C0n57an71n My carrier is bob, but my SIM can't connect to the netwok.
    I updated my PP CE to OTA 12 rc-channel. Searching for carriers gives 2 times 3AT and bob, but it does not connect. Automatic search leads to endless search. Putting APN information didn't change anything.
    SIM is ok, checked with old N5, there it connects fine. With A1 SIM it was the same.
    Which hardware version of the mainboard do you have?
    Did you do something else?

  • @htc_tattoo Mine PP came with Postmarket OS, but I deleted and installed UT on the eMMC. Have you tried booting from an SD card? OTA 12 on PP? I have version 8, stable. Are you on Wifi when trying to call?

  • @htc_tattoo Yesterday, after I have installed UT version 8 on my PP, someone tried to call me like 3 times, but I haven't got any call. Today I found out. I'm switching now to version12 rc and give it a try. My SIM card is making me problems as well: unable to make a call, loosing data connection, but is annoying since I can't figure out a pattern for this behavior. I'll be back to you as soon as I have something. I'm on 3AT, Hutchinson.

  • @htc_tattoo I have updated to version 12, that is the rc channel. Calling works fine with or without Wifi, but do not play with the hotspot since you'll have to restart the phone to be able to call again. When calling, if the small loudspeaker icon with the cross is illuminated, then your call won't work. If dark, then is ok.
    I must say that i'm really impressed on how good the mic from PP works. I was more than 5 meters away from my PP, talking normal, and I could hear myself loud and clear on the CATS60 Android.
    Write the version 20 on a SD card, or update the phone to it and give it a go. Tell me how it went and if helped.

  • @C0n57an71n Thanks a lot, i found the problem. I was always questioning the settings and the software/firmware. It found my carrier, but it could not connect.
    After trying your settings and trying all the other systems (PM-OS, ...) without any success i finally opened my phone and found the problem:
    The antenna cable was unconnected from the mainboard... So i connected it and after booting it connected immediately to the carrier.
    Unfortunately this error is hard to detect as the SIM works, it detects carriers, but it can't connect. I just saw, that on manual carrier choosing only few carriers were shown...
    ![0_1601070625356_20200925_234456.geaendert.jpg](Uploading 100%)

  • @htc_tattoo Glad you found where was the problem. If you need APN settings you can find them here for Austria and for entire world: , although it might be impossible to change anything since in the phone settings, the APN section of my carrier is gray and inaccessible.
    I am right now on the latest development channel version 217 and I have no issue with calling. I have deactivated the Wifi though since it seems to interfere with one another. Both Wifi and SIM works with no problem, but they can't work together :)). If I turn the Wifi on, I might be unreachable on phone and that will turn the entire "PP as a daily driver" useless.

  • @C0n57an71n I also removed a piece of tape with something handwritten in an unknown language ;-), no idea what it means...
    Does your vibration motor work? Mine does not.
    The APN i put corectly, but i can't activate mobile data in roaming mode (button greyed out). I think its bob that uses the A1 network which makes the phone think it is abroad.
    Is there a setting for national roaming? In the N5 it was working.

  • @htc_tattoo Vibration works, I think. It started vibrating once and I couldnt stop it until restart. I can activate my roaming, make calls with wifi on without crash, now the APN option is active and I can access it... I'm on version 217, development channel.

  • Booting: from eMMC
    version 217 (development)

    This update seems to have fixed the issue of initiating calls with the Wifi on that I have experienced before. The phone is able to receive and initiate calls, even though the APN settings data is still inactive, but it does the job and it connects automatically, it restarts mobile data connection when Wifi its turned off, Morph browser is a lot more snapy to the point that I don't use webapps anymore since the browser does the text scaling hole better. The notifications works from Fluffychat and Teleports, led lights up during charging when screen turned off and shuts down when screen is on.
    I must say that Morph is amazing right now. You can watch a video on youtube and skip within an instant. Not the same on Lbry and Odysee though, but that's their problem.
    I must say that I'm delighted with this latest update that brings Pinephone closer to the average user. Until then, I'm still running it as a daily driver and continue so.

  • Booting: eMMC
    version/channel: all

    After almost a week of switching channels and countless reboots, I can say that Pinephone is not ready to be used on a daily basis at this moment.
    The biggest issue, in my opinion, is the unreliable radio management, especially the calls handling.
    It cannot be used, even as a dumb phone, since that will leave the user unreachable via calling and he'll have no clue about this.
    The phone showed some promising results with the versions 217-218 (development), but is really hard to say exactly if it was just a coincidence or not. As with the version 219 and 220, the issue seems to have reappeared (if it was ever gone in the first place).
    If the other bugs are more or less important (from my point of view), the calling problem is a critical one.
    Unfortunately, I'll have to wait with my test until at least this problem is solved.