Unable to mount MX4 on Ubuntu 17.04 & 16.04 computer

  • Hi
    Is there anyone out there who knows of a solution to the problem of an MX4 Ubuntu phone being unmountable on a Ubuntu computer.
    This seems to be the problem stopping me port my phone to UBports version of Ubuntu Touch.

  • This is your third thread of the subject!

    Have you tried both methods available to your phone?

    Have you enabled developer mode in your phone?

    Is your cable data cable or just for charging?

  • Thanks for the reply.
    The reason for the multiple post is that the questions are different. As yet the question for"how to mount the phone" hasn't been addressed.
    In answer to your questions.
    I have tried multiple cables which mount other phones like my Nokia N9
    On the subject of previous post, I have tried both porting methods.
    My phone has been in developer mode as per instructions.

    I need a method to make the computer see the phone, it does occasionally does see it for say 1% of the time. I have looked on other Ubuntu forums for an answer to this and there are some alledged fixes but none have worked for me.

    Going back to the porting problem, do the commands on the UBports website work on a Windows computer as well as a Linux one.

    Thanks for looking into my problem



  • @Ignorance With my pro5,,,,I have it unplugged,then I set it to developer,then plug it in,and I get a window asking if I want to * allow* the computer to access device,it does not stay there for very long.

  • That doesn't happen to me. I just get a message, unable to mount MX4.

    I think it's a computer thing but I am not sure.

  • It shows 1% of the time? Maybe your phones connector is broken.

    What does lsusb list when phone is hooked in PC?

    Have you tried to reset phone settings?

  • @Ignorance I get that with one of the usb ports on my laptop. If yours has more than one try them all. Not sure but does it need a usb type 3 port. Also the cable that works best is very short only about 15 cm long, think it was from a htc phone but can't be sure. All this is on an laptop running ubuntu.

  • @Ignorance Also I know it might be obvious but make sure the phone is awake and the lock screen iron whatever is not in operation, that always gives me the unmountable message. Sometimes unto 4 messages on screen at the sometime as the laptop tries to connect.

Log in to reply