Wifi hotspot and Nexus4

  • For couple of days I have been trying to get hotspot working in my nexus4 with ubports OTA-2. I really need that when on the road. I am not any developer, I can't code anything. I just like to try to get things working..

    First I tried this script. It worked really great, and with WPA-PSK security. I tested it (3hours) with all my phones and computers at same time and performance was good. Phone warmed a little bit, but it wasn't hot or anything. But problems started when I shutdown hotspot, then my wifi went totally off, it didn't do anything anymore. It died totally. Only clean reflash resolved problem. I think it really messed up some files.

    Second I did experiments with nmcli command line tool. I did work good.
    BUT I only get open wifi hotspot. Speed was good and it was reliable. It doesn't even need sudo. And I can enable it and disable all nite long and it just works..

    WPA-PSK didn't work with this way. BUT when shutting off hotspot, it did need only reboot and wifi was back.

    Here are commands that I used:
    Create a connection
    nmcli connection add type wifi ifname '*' con-name my-hotspot autoconnect no ssid my-local-hotspot

    Put it in Access Point
    nmcli connection modify my-hotspot 802-11-wireless.mode ap 802-11-wireless.band bg ipv4.method shared

    Set a WPA password (you should change it)
    nmcli connection modify my-hotspot 802-11-wireless-security.key-mgmt wpa-psk 802-11-wireless-security.psk myhardpassword

    Enable it (run this command each time you want to enable the access point)
    nmcli connection up my-hotspot

    Disable it (run this command each time you want to enable the access point)
    nmcli connection up my-hotspot

    If someone knows how to configure WEP or knows how to get WPA-PSK work with nmcli tool?
    Maybe someone could find why first script works with WPA-PSK but second way wont.
    Simple gui would be nice if someone know how to put it together?

    Thanks! 🙂

  • This post is deleted!