Meizu Pro5 fastboot mode locked

  • @halucigenia Enjoy the Ubuntu Touch on your Pro 5 🙂

  • If I get the chance I will see if I can compile an instruction set for a step by step how-to.

  • I am glad for you! 🙂 Congratulations for not giving up! It took me about three days to do it a year ago... Welcome! 🙂

  • Hi,
    thanks for ubuntu touch, I had same problems with a meizu pro 5 with flyme 6.0.0G firmware installed. I solved installing previous flyme firmware from here:

    then I installed beta firmware from xda developer site and I unloked the bootloader.

  • Hi all.
    I read with interest this thread. I got a Meizu Pro 5 just one week ago and since then I'm struggling to make it eligible for UT installation.I guess it's a chinese version, since it is coming from China and when I first booted it up, it showed up a lot of chinese app. The main problem I'm facing is that the OS arrived locked and when I go into fastboot mode the device is not detected by the Desktop terminal and I cannot unlock it.
    Therefore, I followed all the useful threads indicated here but without any luck up to now. Here following the steps I made:

    1. To double check the version I typed the following:

    As you can see I got a [none] which sounds very strange to me.

    1. I then tried to change the region:
      • I installed the chinese Flyme OS and then, to get root, I installed KingRoot, which does pretty well the job to gain the root access;
      • then I installed SuperSu 2.76 (by Chainfire) and BusyBox v1.24.1-meefik. The installation from apk went smoothly but if I open each app by tapping on it, it states it cannot install the binary.
      • BTW if I enter the root mode, I can follow the next step without any issue:

    The "machine_type=M576_intl_official" specification to make the phone international seems properly set. However, If I reboot the phone, and I type again "su", "id" and "cat /dev/block/platform/15570000.ufs/by-name/proinfo" I don't see anymore the specification above. It seems like if the "busybox cp -f" doesn't take effect at all and the modification is only temporary. Can you give me some advice on that, please? Any hint would be highly appreciated.



  • @matteo I think there might be a problem with root privileges. On Meizu phones you need to go FLyme account and register there, or if registered then just log in. There is option to ROOT the phone. Only this rooting actually works. ( The FLyme log in onFlyme OS Then install the Bysybox and SuperSU, exactly those mentioned here:
    Then just follow the instructions there and here:

    Any other rooting method or different Busybox or SupeSu , will cause only the temporary changes. I have experienced the same issue.

  • Grazie Stefano! You have been very helpful!
    I'll try as per your suggestion. I'll report here as soon as possible 🙂


  • Apparently it seems I made some progress.
    Finally, I succeeded to create a Flyme account (it was not a straightforward process indeed) and I gained the root permission. I realized that BusyBox wasn't actually working before because it couldn't install the binary; now, set it properly, I proceeded with the root permission and after that I finally was able to save the "machine_type=M576_intl_official" name to the Pro 5 phone. I double checked it by rebooting with "cat /dev/block/platform/15570000.ufs/by-name/proinfo" and this time that name was already shown. Yay 🙂
    I thought the worst part was just behind the back, and I passed to follow the instructions on the page I installed the version Flyme OS, as suggested, and rebooted in fastboot device isn't recognized at all.....
    Any clue?



  • @matteo have you enabled developer menu, usb debugging?

  • @stefano Yes I did but it doesn't change anything. This is what I got (as you can see I tried many times to wake up the phone in fastboot)


    P.S. the international name is there this time, so it shouldn't be recognized as a Chinese device anymore...

  • @halucigenia I thought you had to flash old ubuntu touch,to get partitions sized correcly,then flash ubports, ( updates by flyme,put on the root of internal drive ,and flyme recovery can find them and go to work). Recovery install from fastboot= sudo fastboot flash recovery ~then your recovery location,drag n drop or or

  • @matteo try to flash recovery again,: sudo fastboot flash recovery recovery-turbo.img

    And if it won't work, unplug the phone and :
    sudo adb kill-server

    sudo adb start-server

    plug in the phone and try again

  • @stefano thanks ,i was trying to throw some ideas in.
    i am waiting for 16.04 to be released for my pro 5.
    my sim no good for ubuntu/ubports.
    most likley need help then ,cant remember my flyme login ,and on a different cell number,should be fun

  • @marathon2422 No, I did not have to re-partition, although I did think that I might have to. However, it looks like for 16.04 it needs more room on your cache partition than 15.04, see

  • @stefano you know what Stefano? Reading again this post from the beginning, I found out something that I missed before, i.e. you sent a link to an file. I downloaded that and saved in the phone in order to upgrade the phone. Once started the process, it came out the "Firmware corrupt" issue. Why is so? My phone is now supposed to be fixed as international, weird....

    Going to your suggestion regarding the flash recovery thing, I didn't do any flash recovery before nor I know how to proceed with this procedure. Should I exploit the Ubports installer to do so?

  • @matteo did you mean the " "

    This is the one which you are suppose to flash after you change the ID to I (global or international)
    This version can have the bootloader unlocked, no other firmware version of Flyme is known to work.
    Be careful, if you flash again any A firmware ( Chinese ) you will need to unlock the bootloader again.

    So, If you flashed firmware Flyme OS first, then changed the ID and followed the steps, you should have now International (global)version of FLYME and the next thing is to flash that, start the phone, enable developer options, usb debugging, then rebooting to FASTBOOT and unlock the bootloader.
    After that reboot to fastboot and check the screen down, is small print and shoud say "FASTBOOT MODE (unlocked, rooted )

    If this is true, you can then flash UT, otherwise it won't do nothing.

  • @stefano yes exacly, the " ". If I try to flash it, it gives me the "Firmware corrupt" message.
    I already flashed back Flyme OS (before reading your warning though). I gained root mode again by accessing the Flyme account and then I wanted to check again the international name and it seems all good so far:


    It should work! I'm out of ideas...

  • @matteo just to be sure,type in:
    sudo fastboot oem unlock

  • @matteo download this recovery:

    move to your Home folder on PC

    Start terminal and type in with phone rebooted to bootloader mode:

    sudo fastboot flash recovery TWRP_3.0_m86.img

    it should flash you phone with custom TWRP recovery, then you reboot to recovery and flash International version of FLyme, boot in the FLYME and enable developer mode, usb debugging.

  • @matteo SORRY man, I probably forgot to mention that you need to rename the Unlocked bootloader zip to " "
    And flash it, I only renamed it for recognition while downloading, the FLYME recovery won't flash any other zip. While selecting to update it, you need to select the WIPE option as well ,on original FLYME recovery. Otherwise you might loose IMEI. ( But you probably know that, as I hope you read tutorials on Flyme forum ,how to upgrade the FLYME )

Log in to reply