OnePlus One model 64 GB Sandstone black A0001 not compatible!!!!!

  • It seems Ubuntu touch cannot exchange files via usb with a pc;
    When I click bacon it says: Unable to access "bacon"
    Unable to open MTP device [usb:003,003]

    On my pc (Debian 9) I installed the mtp-tools package but nothing changed.
    Anyone found a solution for this or can I connect only with Putty?

  • I looked for alternatives ways to connect my smartphone to my pc.
    By bluetooth I can send files from pc to bacon but not the opposite.
    With WifiTransfer (Ubuntu Store or OpenStore) you can connect to your phone from pc as a server by ftp.
    LOL it's a bit extreme and funny but okay 🙂 , the important is to solve the necessary needs in some way

  • @mark-volpetti this is a known issue since May:

    BTW help wanted on this bug!


  • @flohack From May?
    That's very sad 😞
    I should buy a bluetooth headset (only one ear) in few days, does anyone know if Ubuntu touch connects it normally or if actually is not possible?

  • Wooow I just found out that to change my account password on Ubuntu touch the only possible way to go is using the terminal LoL :-))
    No Gui for this X-D
    I see Ubuntu touch doesn't like easy ways to do things, well, that's funny and interesting 🙂
    So for change the password (called passphrase) you need open terminal and type passwd just as you do on the general linux desktop distributions

  • Awww, wifi doesn't remember connections, or better it does but it doesn't allow connect automatically or manually to it, so the bypass is just to open the old saved connection, read and write the password in a line than copy and paste it in the empty line field for a new wifi connection.

    I see there are few bugs to fix for the next update of Ubuntu touch

  • @mark-volpetti

    Bluetooth is not very stable, it's a pain point that we plan to improve on. You can search the forums to find reports of different devices that may or may not work.

    You can change your passcode by going to settings, security and privacy, locking and unlocking, lock security. Pick "No security" to disable your passphrase then pick "Passphrase" to set a new one.

    For Wifi, check if the networks are appearing in the "Previous Networks" settings screen.

  • @unisuperbox Okay, I have just bought this mono bluetooth headset from Amazon:
    I will post results as soon as I try it on my OPO.
    I just hope to use basic functions.
    For the rest Ubuntu touch seems work fine for the moment, wifi is working better, not asking anymore for passwords 🙂

  • can we change the title of the subject ? 🙂

  • @ernest Nope, for only one reason, that's the installation part of ubuntu touch which actually is still not updated (just checked) , so if a new opo user try to install ubuntu following the website could still find it impossible.
    Still too many links but nothing working.
    Why don't they just post the app installer link page they gave me on this topic as unique method?
    That's working 100%

  • @mark-volpetti Mark, this a community project, so there are no "they" and "we", there is only "we". You can go to the web-site repository and open a ticket ("issue"):

  • @wgarcia DON'T SAY??? I thought I was on Apple customer service....
    "Of"____"Course" BUT there are members who manage the website and there are member who obviously cannot do it directly if not asking it by a request to those other members.
    I can see there is already a request for the CPT but guess what? it's still there in the middle of the other methods to just cause panic and confusion...
    Okay I admit my post could look very critic and decisively not pleasant, BUT I don't want forget all the S### I went through on just because my opo is now fixed.
    My post is for a next opo user to not feel the same panic after spending 270 euro on eBay and realize to have wasted money (that's very unpleasant),
    so please don't take it as a critic to the community or whatever it could look like.

    It's just a "coloured bug report"
    I wish you a good time mate

  • @mark-volpetti

    I'm sorry you went through that, but it's important to note that the installer is still in beta. We're still working out all of the bugs, and the overwhelming majority of the people working on Ubuntu Touch are volunteers.

    I encourage you to cut the passive aggressive attitude if you would like to be a member of our community, since it's detrimental to our work. Please read the Ubuntu Code of Conduct since you accept it by participating here. If you feel that you have found a bug, please report it according to our bug reporting process. You can also check our issue tracking guidelines to see how the community will be responding.

  • @unisuperbox okay m8 sure I'll just cut it off, but still I have to insist on one point.
    Of course the whole project is driven by volunteers and I cannot stop thank them for the great job, and of course my post isn't the normal way to process a bug.
    BUT there is a limit for anything, because okay for a bug, okay for a not working functionality etc. but you just CANNOT keep outdated and >>not working<< installation files on the opo(or other models) webpage driving poor people crazy for days looking for an answer like desperates......
    MONEY IS NOT A JOKE... I just ask respect for people who try to join this community because at first I just felt lost and tricked with about 270euro less.
    Apart the fact that you need plug in your opo in fastboot mode since the begin, the last updated installer runs very smoothly and with 0 errors.
    So the problem is not about the installer stage (like beta or other) but the grave fact that the correct installer is not updated as it should be on the public website where people can consider to collect REAL MONEY to have a SAD surprise later, and mate sincerely this is just NOT ACCEPTABLE ... and new useless chatter from members like you won't fix that.... sorry to say that....

    Anyway after this I'll just delete myself from forum because I'm already tired of people who don't understand and keep attack me like if I am just overreacting for a normal problem.
    I won't be able reply anymore so please avoid your pointless replies and try to understand the value of money and the current economical crysys before post your s###.

    Goodbye all and thanks for anything

  • Who shit in his christmas stockings?!

  • Eh, no big deal. Enjoy your Christmas day, @RandomUser!

  • Thank you for reading this and long live this project! My hardware is very same as of the title of the thread.

    I'm stuck at the installer's (currently posted "snap" download running on Ubuntu v.16.04 "LTS" desktop host), screen saying " waiting for recovery mode " after have manually selected my model at the installer's first prompt, and having switched the smartphone to " fastboot mode " first. I'm currently stuck now having the " UBPORTS Recovery " environment showing into the smartphone and no progress on the installer's side.

    Please advise. Much appreciated.

  • @fgs

    In the future, please open new threads for new support topics.

    Could I get you to download the AppImage from and run it from the terminal with Sudo? That seems to work fairly well for most users.

  • I use linuxmint 17.04. Installation was no problem. I am thinking of the advantage I have now...

  • @fgs I tried the snap package too, but that stalled as it did by you. The .deb package worked fine for me.

Log in to reply