Pro 5 - basebands

  • Hello.

    I have permanent problems with mobile network and data on my pro5. Recently I have found out, that there are newer basebands available. I would like to try installing them.

    However, making image read-write does not allow me to write to /system. I cannot remount it as rw as well, because it is write-protected.

    Recovery mode shows me Ubuntu logo and nothing else, and I don't know if fastboot allows me to flash only modem.bin file (if I correctly recall its name).

    How can I replace the baseband and check ouf if it works better for me?

  • So normally radio firmware needs to be flashed in fastboot mode, not recovery, not normal OS. Then, a bin file cannot be flashed, it should be a .img file - I dont know if those are available for Pro5 TBH. Other users with more Pro5 experience might help.


  • All basebands on XDA are published as .zips, which are to be flashed in TWRP, as it is written in the topic by the people who are uploading them. That's why I guess it is intented to be flashed in recovery.

    Is it possible to install a .zip via Ubuntu's recovery? I see only Ubuntu logo and it seems that nothing else happens.

  • @Mitu Could you please post a link to the files on XDA and then, if you succeed (which I whish you do), a tutorial on what needs to be done? Thank you!

  • OK, baseband changed. I've actually changed recovery to TWRP. Here is what I have done:

    1. Install TWRP - tutorial and download link here:
    2. Grab this: and flash via TWRP.

    In the sibling topics there are a few other baseband - I've tried the latest one.

    So far it seems much better, but I've just installed it, so I don't want to judge too quickly.

    For the next couple of days I'll test the battery life and the connection's reliability. If the issues are fixed indeed, I'll suggest changing in the bug tracker the baseband to the one I linked. If this succeeds or I find another baseband that will do well, would you, dear Devs, update it in future OTA-s or in 16.04 images for Pro5?

  • OK, I was entirely wrong. After some time I realized nothing got better at all.

    Even more, TWRP didn't even flash the zip.

  • I've investigated the topic more.

    The problem is as follows:

    1. The /system/vendor points to /android/system/vendor in recovery. However, the /android directory seems not to exist in when in recovery.
    2. It seems that /dev/block/loop0 should be mounted in /android/system. It also seems that it is not possible to mount this read-write. It seems like just it is not possible to swap only baseband in Ubuntu without modifying and reflashing the entire system image...

    Or I am wrong. I hope so. 😞

  • @mitu When I was playing with Flyme, I flashed different radio files with TWRP recovery and the result was visible in Settings/Baseband. The most stable was version Meizuchinaopen36 something like that. I think, but that was a while ago, the newest one might be better.
    Downloaded from here:link text

    I have no idea if that changes the baseband that Ubuntu Touch uses as this goes through Libhybris and system.img is created on first boot, if it chnges the files by flashing with TWRP on Ubuntu Touch I have not an idea.
    How to check in terminal what version we currently have installed???

  • @Stefano Yes, I guess with Flyme it is possible to flash it that way (never had Flyme and never tested though).

    I think baseband version can be checked by:


    My revision seems to be from 2015-10-02.

    In the RILs that can be downloaded from what you have linked there are more files - also a few .so files. I won't take the risk to flash it, as I expect that the libs will install, but the modem.bin will not.

  • @mitu I also tried with fastboot to flash modem.bin directly.

    What kind of issues you have with networking/data connection?

  • @Stefano Did it work to flash modem.bin with fastboot? What was the command you used? What does it say now when you check with /usr/share/ofono/scripts/list-modems | grep Revision?

  • @mihael at the moment on my Pro 5 there is Mz024 ( the end of modem name) which is rather old firmware (2.10.2015)
    I think it worked with Flyme when I flashed different modem.bin with: sudo fastboot flash modem modem.bin
    But can't remembrer the exact command

  • @stefano Ok, thank you, I thought now while having utouch you were able to flash the new modem.bin. I have the exact same old revision you have.

  • @Stefano, a lot:

    1. Frequent drops of carrier signal. On the remote areas I mostly have no connection at all, but even in the city centre network often drops entirely (no carrier at all, I can neither call nor use internet then)
    2. Frequent drops of data connection, while carrier signal retained. Network indicator shows different things - sometimes it notices that the data connection has droppedd and it shows no internet, but often it also shows an icon exactly as the connection was in place.
    3. I think (but I'm not sure if this is an issue or natural behavior) that phone slightly too often switches back and forth between 4G, H and 3G, sometimes going down to E. This can happen sometimes even outdoors in the center of on of the Poland's biggest cities, so I don't think it is related to poor signal quality and 4G network not being available there.
    4. Sometimes I expect stronger battery drains (for example 20% overnight, when the phone is idle), I think it also can be related.
    5. In general I turn on Wi-Fi only if I need it, as leaving Wi-Fi on may cause a random battery drain as well and make lose 40% in a few hours.
    6. I also think I sometimes expect a dead Wi-Fi connection - phone is connected, but internet does not work (and I am sure this is not my wi-fi network problem).
    7. Not to mention that sub-par call quality or killing calls from time to time due to the above.

  • @mitu I think this might be hardware related. What is on the back of phone? Is there TD-LTE or just LTE wording?
    I have the LTE version and it behaves mostly good, sometimes in areas with lower signal strength or rural areas or very overloaded places the signal jumps down to 3g/H rarely to E. While on 4 , then works like a charm.
    I had previously the TD-LTE version(Chinese) and the connection loosing was far more frequent and battery drain/overheating was significant. It also might be problematic frequency support.

    I don't know at the moment how to fix that, there might be broken antenna wire/connection, loose connection... cos it seems to be more than just software related. I tested my Pro 5 (LTE version) on Android(Flyme,RR) and the signal and data was reliable.
    On TD-LTE version( Chinese) was the problem present on every OS tried. Such are my experiences. I might try fix the antenna problem on my spare(broken) TD-LTE version, but I won't hold my breath. Sorry that I can't help with that.

  • I have the TD-LTE version and it works very well. But I keep it on 2G because 4G breaks the voice call. Data on 4G works very good though... I am very intersted in the new modem software in the hope that maybe 4G voice call in the city would work and thus I could keep it on 4G all the time.

  • I have the TD-LTE version, bought as Ubuntu Edition via then-called

    @Stefano, I'll keep my fingers crossed... if you need any logs, information or testing, please ask and I hope I will be able to help.

    EDIT: According to voice calls, they are OK in 4G for me... at least when there are no problems with the entire signal.

  • I have corresponded with Mitu about this issue on Telegram. I believe the issue is that recent versions of TWRP e.g. 3.0.2 are unable to flash new baseband firmware. This apprently isn't a problem confined to the Pro 5, but across many devices. It's a major, egregious regression and one which has hopefully been fixed by bleeding edge versions. The problem is, I think there are only two builds of TWRP for the MP5 and neither are the golden or bleeding edge. As I see it there are four possible fixes:

    1. Beg people on XDA to push for an appropriate build for the MP5
    2. Attempt to compile such a build for the phone (seems like a daunting task?)
    3. Find an alternative recovery method, a competitor to TWRP which allows this functionality
    4. Try multiboot and see if Android is any more capable for flashing baseband OR move to Android, upgrade baseband, move back to Ubuntu (I don't really want to try this option tbh because it's a pain reinstalling everything for Ubuntu)

    I will try these fixes when I have time. For now the only significant problem I have is not being able to use mobile data hotspot. If anyone comes up with an idea or tests these ones in the interim, I'm all ears.

  • @TartanSpartan - no, it's not the case. That was one of the hypotheses that I had, but the problem turned out to be different: the baseband is inside the LXC container, so it is in a different place than in am Android phone. Because of that you cannot flash the baseband using the method meant for Android phones.

    In fact you cannot just flash the baseband alone anyhow - you probably need to prepare the system image with the new baseband.

    What renders us unable to replace the baseband at all unless we want build something similar to what a custom ROM is for Android I think...

  • Could then the UPports team include it in an OTA and we get it when we update our devices?

Log in to reply