Help!, UB recovery, what opción select? Oneplus one

  • hello, I am trying to install UT on OnePlus One 64Gb, with the UBport.exe app from Win7, but I get to where the app in W7 indicates that it is waiting for the device to enter "recoverymode", at the same time the cell phone shows the UB Recovery screen, but I do not know which option to select so that the installation continues and finishes successfully.

    I clarify that I can navigate through the options of the UB recovery, also that I have selected "Reboot system", but the time passes and the installer does not finish and the phone does not pass the screen of the logo 1+, also that the app in W7 keeps showing that it is waiting for the cell phone to enter into recovery mode; so the cell phone is already indicating that it is in UB recovery; I appreciate your help.


  • @karlitozebc Sadly, I have the same problem on a OnePlusOne. With both Linux and Win 10, I can get to the reboot phase, but no further. I just get the opening:

    powered by Ubuntu
    supported by ubports

    I've tried over and over again, but I think my 'phone must be bricked. A shame because my Nexus 5 had been running for a couple of years on UB before dying.

  • @gregb49 Can you put the device into recovery and use android/Ubuntu recovery to clear cache factory reset. Then you can check that ADB is seeing your device correctly. If it is try again if not ADB needs sorting.

    Edit: Use the snap version of the installer if you can, you can see whats happening then in the terminal.

  • @Lakotaubp Thanks. I'll try that, if I can get passed the initial boot screen.

  • @gregb49 What linux OS are you using? Think booting to recovery is volume up and power held together but best check first.
    Edit: power and volume down together for recovery.

  • @Lakotaubp Thanks. i'm using elementary OS 0.4.1 Loki
    ADB is not seeing my device, unfortunately, whether I have it in fastboot mode or in its boot screen mode. I've tried different ports and usb leads to no avail. WIN 10 seems to see it though ??

  • @gregb49 OK boot to recovery and clear cache as mentioned above. If you want to use Windows and still have issues try 15 sec ADB from XDA developers it works well with Windows or try a live usb stick with Ubuntu on it with elementary. We have had a couple of issues with elementary recently.

  • @Lakotaubp I have the same problem with Debian 9 (4.19.97-v7l+) but I'll try your suggestion.

    Using power and volume down together for recovery, all I get is this screen, with which I seem to be able to do nothing.
    power and volume up together give me a screen that says "Fastboot Mode"

    oneplus1 recovery

  • @gregb49 Yes give that try. Normally fast boot installs the recovery and it sticks there. So good luck and let me know. One other thought yo don't have any power/battery issues. That can stop the device booting.

  • @Lakotaubp Thanks. Will do, but it will have to be tomorrow now. I'm not aware of any battery problems. Thanks for your help.

  • @Lakotaubp Now I do have a battery problem. I let it run down and now it wont charge, whatever charger I use. I think that that is the end of the road for my OPO - shame. However, that is typical for LiPo batteries. They should never be allowed to completely disharge, or so I understand.

  • @gregb49 I had same issue on one of mine. Battery replacements are cheap enough and easy to do. Give it a go. Mine is fine now.

Log in to reply