Python 3.5.4



  • I'm trying to install a package called home assistant in a libertine container.
    It fails to install because 3.5.4 is the minimum required python version.
    I'm at a loss on how to upgrade from the installed 3.5.2 version.
    I've attempted add-apt-repository ppa:deadsnakes/ppa but with no success

    Can anybody help pls



  • @Bry Libertine is still in it's infancy so expect bugs. If you are not a advanced user, I'd suggest that you stay away if you don't want headeaks. But if you want to play, go ahead.
    As well, please note that on UT you cannot install things like in Ubuntu desktop since the root file is read-only for your safety. You can change that ,of course, but you wanna do- it?



  • @Bry I don't know if you had a look before on this, if not, you might wanna: https://docs.ubports.com/en/latest/userguide/dailyuse/libertine.html



  • @Bry "Another challenge is that Ubuntu Touch system updates are released as OTA images. A consequence of this is that the root filesystem is read only. Libertine provides a container with a read-write filesystem to allow the installation of regular Linux desktop applications."



  • @C0n57an71n

    Thks for the info. I understand that ubport isn't really what I want .
    What I want is to recycle my old phones as simple server for home assistant. I use something called 'Termux' successfully but it sometimes disconnects to save power....
    So I thought I would look at ubport.

    Motto "If it ain't difficult, it ain't worth doing"

    But maybe this is too difficult. I'll look at the link you gave

    Thks again



  • @Bry Maybe UT is not ready for your project, but you'll find for sure other uses. My advice for you is stick with UT and make it as you want. If we all drop our dreams at the first bump in the road, we'll never achieve anything.



  • @Bry said in Python 3.5.4:

    I've attempted add-apt-repository ppa:deadsnakes/ppa but with no success

    What does no success mean exactly? The PPA has builds for xenial and armhf and arm64, but not for 3.5. You should be able to install 3.6 in a libertine container from there though (or 3.8 it looks like).



  • @dobey
    Sorry about the delay in replying

    After
    apt-get install software-properties-common
    apt-get update
    add-apt-repository ppa:deadsnakes/ppa
    apt-get update
    apt-get install python3.6
    seemed to finish ok ;
    but "python3 -V" still gave Python 3.5.2.

    Following your reply I looked further and realised that I needed to use the command "python3.6 -m venv homeassistant " to correctly (?) use python 3.6



  • Yes, installing a new version from the PPA doesn't replace the default python3. You need to use python3.6 directly to use that version.


Log in to reply