Sony Xperia X Performance F8131



  • Hi guys,

    I ordered an Xperia X Performance F8131 to install Ubuntu Touch.

    First I started the phone, set up the essentials and updated it to android 8. Flashboot activated with Imei etc., debug mode on and the ubuntu touch installer downloaded. The story started and ended with errors.
    E: couldn't load bitmap icon_error (error -7)

    I thought, ok there is something wrong and flashed android back and from the beginning but now I'm hanging and it doesn't go on.
    I am now hanging in Ubports Recovery.

    Can I still finish the installation properly? Maybe with Install ubuntu zip? However, he wants a file that I don't have. (recovery.zip)? Before I completely scrap the phone, I wanted to ask if someone can help me. What information can I provide and where can I get it so that you can help? I thought it would be a bit too easy for me.
    Thanks in advance.

    Greetings from Warburg / Germany
    Jakusimo



  • Wipe system data & cache partitions inside twrp.
    Reboot to bootloader and launch the installer.

    if you want to install it manually there is a thread in xda -> here.



  • @HMZ47 said in Sony Xperia X Performance F8131:

    twrp

    Thank you for your answer!
    i have completed the steps. I've done the same before. However, I had a different result. Twrp came right back and this time it was restarted twice. I am currently seeing the Sony start screen for 10 minutes.
    I'll wait a moment, but that's certainly not normal either. Funny, the "Successful screen in the tool" twice but the phone doesn't do it. I will wait a little longer and then initiate the restart.

    20min later:

    reboot
    Start logo
    Black screen
    (Red LED lights up briefly)
    dark
    Start logo
    (Purple led lights short)
    The start logo remains lit.



  • Tested several times, installing upgrade,
    reboot,
    black screen,
    reboot,
    sony logo
    nothing happens
    tomorrow I will try the "manual mode"

    Goodnight



  • @Jakusimo
    if your phone reboot to twrp i think you need to flash stock android image first (8.0) then enter the phone default recovery and make a factory image reset because of encryption.
    do not boot into system so you don't trigger encryption.
    then follow the install section in this post



  • @HMZ47 said in Sony Xperia X Performance F8131:

    Wipe system data & cache partitions inside twrp.
    Reboot to bootloader and launch the installer.

    For me it worked after I formated data inside TWRP and then did the wipes.
    Cheers, Christian


Log in to reply