Development testers for Anbox



  • I tried some things with the powerful adb command which gives wide control over the apps installed on the anbox image. There are some commands for example which control the permissions of an app. The command 'adb install -g apkfilename' grants the requested permissions of an app at installation. With adb pm grant package_name android.permission.WRITE_EXTERNAL_STORAGE or
    android.permission.READ_EXTERNAL_STORAGE it's possible to enhance permissions of an app. But for the latter the output of 'adb logcat' tells that that permissions weren't granted at runtime because they weren't granted at the installation time. Is it possible to set that permissions on installation time? The solution to uninstall it with 'adb shell pm' and reinstall the app with adb didn't help for that.
    I even tried to install the the apk file directly with the Android package installer without further success. The command for that was 'adb shell am -a android.intent.action.INSTALL_PACKAGE -d "file://path to apk file" -n com.android.packageinstaller/.PackageInstallerActivity'.
    One app worked after using LuckyPatcher on it.



  • Hi,
    Does anyone have any problems with Anbox on his BQ M10 HD ?
    https://forums.ubports.com/topic/2473/anbox-kernel-is-not-installed-bq-m10-hd

    I follow instructions (https://docs.ubports.com/en/latest/userguide/dailyuse/anbox.html#how-to-install) but when I'm launch "anbox-tool install", Terminal answer "Anbox kernel is not installed".



  • @pawlinski
    If you took the image from "http://cdimage.ubports.com/anbox-images/" maybe you've installed an OS update afterwards. In my experience this resets the former installed boot image, so it has to be reinstalled.



  • will the support for the nexus 4 come?



  • @baddea No idea why it will be
    Will it be by x11?



  • @ursfan with the commands anbox-Tool disable and anbox-tool enable afterwards the offline listed device normally gets active...



  • @ursfan After having added the file NotoColorEmoji.ttf to the image under /system/fonts and rebuild the android.img with mksquashfs it works...



  • any news on the native keyboard? @mariogrip
    or any workaround to get lag-free input from the android keyboard?
    (already tried disabling autocorrect, spellchecker, etc and other keyboard apps without success)



  • Hi @mariogrip I assume that the boot images for mako & UBPorts stable devices are not available because of the lack of power but can you point to resources for building a anbox boot image for mako and other devices not mentioned here for experimenting with it?



  • hi
    on my 1+1 can t install apk, emu in adb devices is listed but show up as "offline"
    also wwe wanted to check the status of ad in android developper options, but once i clic on it, app close (fc)
    hope it can help, if you have anything /logs you want me to share, let me know, here to help



  • @indiandraogn said in Development testers for Anbox:

    Hi @mariogrip I assume that the boot images for mako & UBPorts stable devices are not available because of the lack of power but can you point to resources for building a anbox boot image for mako and other devices not mentioned here for experimenting with it?

    Yeah. I would like that too. I would like to test Anbox on my Aquaris E4.5 (Krillin).



  • Coming from here: https://forums.ubports.com/topic/2876/anbox-development

    Do I have to build the Anbox boot image for myself?
    Do I need to modify the anbox-tool package?

    And in general: Are there any tips on getting started with Anobx development for UT?

    Thanks, Jan-Luca


  • Banned

    Ok been goofing with ubports for a few days again first installed with multirom a couple years ago but now that app seemingly fails to receive any updates doesnt give option to install anything I fear completely dead( correct me if you found a fix for this so I can go back to dualbooting with And9), hoping someone can catch me up on somethings.

    http://docs.ubports.com/en/latest/userguide/dailyuse/anbox.html Found these instructions which worked for me one oneplus one. Installed FDroid internet is working. Some apps dont like to open without clearing app cache but not bad. Tried to install play store/services using this tutorial, https://www.linuxuprising.com/2018/07/anbox-how-to-install-google-play-store.html cannot install the install.sh file due to snapd not starting being listed as unavailable but installed. A no snapd.socket cannot communicate with server error. Anyone manage to bypass this (possibly install this install.sh another way without snapd) or get snapd fully running? old version? found this for a different device https://www.youtube.com/watch?v=NHE5THEWq7c not sure if it is a 32/64 bit issue or if there is a way to install this old snapd version/ acceptable kernel.

    Any luck with play store with Micro g or the crackberry patch google apps route? Also anyone enable a backbutton/ navigation keys? I did the suggested fixes for apt-get running out of space but I keep running out again how can I make apt-get use my full 64 gb storage? mounted rw permenantly using
    $ adb shell
    $ sudo touch /userdata/.writable_image
    $ sudo reboot
    from here https://ubports.com/blog/ubports-blog-1/post/terminal-chapter-3-124 Can I symlink something possibly to get full space for apt-get(not just storage?) Hopefully this thread isn't dead thanks in advance for any help


  • Banned

    with multirom dualboot install I never had the space issue it must be something simple but I'm not pro linux level to figure it out



  • @errorcodevortex you cannot install snapd on Ubuntu Touch. It will not work. Please use the instructions for installing Anbox in this thread or in the documentation.



  • If you want to use apps from play store which don't require too much play services, you're probably better off just installing the microG packages, and Aurora Store.

    https://microg.org
    https://gitlab.com/AuroraOSS/AuroraStore


  • Banned

    @UniSuperBox I got anbox going good no problems. From what I gather it is flashing same kernel but simpler unified instructions? Just happened to runinto that tutorial first. This anbox is still based on android 7.1.1 right?. How did that guy get snapd running tho I wonder


  • Banned

    @dobey downloaded aurora and yalp store through frdroid, but have never had much success with microg in past have not done that yet but thats probably what I'll end up doing. I don't see any better method than that for full play store ability without fixing snapd unless I could figure out how to install/ run a install.sh without it, or pull off installing each non play-serviced modded apks separately through something like this https://forums.crackberry.com/blackberry-10-os-f269/cobalts-official-google-apps-landing-page-965257/ but I feel like its a stretch. Anyone try those yet?



  • @errorcodevortex said in Development testers for Anbox:

    How did that guy get snapd running tho I wonder

    It was an extremely experimental image from when Canonical still was developing Ubuntu Phones and Unity8, as the plan was to move the whole system to snaps. Had that happened, there would be no rootfs to resize. Your only option to get debs would have been to install the "classic" snap, and install things in the container it provides, much like how libertine works.


  • Banned

    On my oneplus one fresh install of anbox the webviewshell doesn't run but everything else does is connected to the internet with other apps. I was trying to add the key to add the gms repository to frdroid but I couldnt confirm it all the way without entering a browser on the android side. Workaround to this? Anyone find any browsers that work or a solution to this? And also has anyone managed to enable Magisk superuser yet? Is it possible to flash any zips through recovery I have not yet tried.


Log in to reply