Oneplus 3/3T

  • Hi everyone, I LOVE my UT phone, BIG thank you to everybody involved!! I'm not a pro....just self-taught hobbyist. Is there a way to enable USB audio and listen music from the USB (instead of the 3.5mm jack) through a DAC/Amp on OP 3T. Thanks in advance, cheers

  • sorry since i started using the phone as main phone
    i started to notice stuff
    like is the latest update made the phone feels slower, and the drop menu from above isn't it full screen any more ?

  • i'm thinking of reinstalling UT using the installer on the laptop to refresh everything is this a good idea or just waste of time

  • @pglushkov said in Oneplus 3/3T:

    @ziggutas said in Oneplus 3/3T:

    Trying the installer with Oneplus3T but it cannot get past the 'Sending...' screen so far. I've waited for 30 mins or so. That should be enough, no?

    The phone is showing Android Recovery screen with options: 'reboot system now', 'ubuntu actions, and 'android actions'. Screen is otherwise black (there was a flash of colour that looked as though it might have been the android robot lying down, but it was only there for a fraction of a second). Phone getting quite warm.

    Previous experiences suggest I should go and get a better cable!

    Hi all! Having same issue, stuck at this step. Device - OnePlus 3T, trying to install from Windows version of UBPorts installer. Any advice or instructions please? 🙂

    P.S. Also tried to 'reboot to recovery as PhoenixLandPirate suggested - did not help.

    You guys will not believe this but , I was struggling for a week with this problem and cable it is a big culprit here !
    It turns out USB (connection jack heads or A.K.A. boys ) have a color code too ! Where white is USB 1.0 , black is USB 2.0 and blue is USB 3.0 .
    I started with white and got errors same like you here and "connection to device is lost". Then I changed to my wife's cable it was black and I kept getting "lost connection to device" but manual flashing was with less errors . Then I decided to humor my self and tuck my daughters Huawei charging cable which was purple on connections so fastboot format:ext4 cahe & userdata start failing but Ubports installer just flyed with it with no problem ! So I got success !

  • @saran USB connection plugs from inside white is USB 1.0 , black is USB 2.0, blue is USB 3.0 .White and black did not worked for me . I succeeded with purple . It was educational and frustrating experience for all week , but rewarding in the end .

  • @Oneplus-3T Sorry my wifes cable was white on the chargers end and black on phones end so i guess it is still USB 1.0 and it is no good .

      Plus I booted to TWRP recovery and in wipe section choose advanced , picked everything except the bottom one and wiped , rebooted phone , went back again to TWRP recowery wipe section and swiped to format . Just this time advanced wiping and formatting returned no errors . And not like in previous attempts to wipe, everything could be ticked in advanced section and results returned with no red errors.

  • OnePlus3 only has USB2 though... so I doubt a usb3 cable will make a difference.
    But what about the usb fast charge cable (red) that came with your OnePlus3? That one should work fine, no?

  • I can't seem to get the installation to work. I was able to format /system, /data and /cache as ext4 with TWRP at one point, but now after using the UBports installer it just boots to a glowing circle and reboots.

    When I try to fastboot flash recovery twrp.img, touch input is no longer working in TWRP, so I can't do anything.

  • Ok, I got it to work. Apparently I just had to wait a long time on that Android-ish glowing circle screen and then it booted Ubuntu Touch.

    I was confused because the boot logo still showed "Powered by Android", whereas my old OnePlus One showed "Powered by UBports", so I assumed the installation failed.

    Is it normal for the boot screen to not show the UBports logo? And is there a way to get rid of the fastboot oem (un)lock "scary" warning?

  • @the7thstranger
    Is it normal for the boot screen to not show the UBports logo?
    --> yes
    And is there a way to get rid of the fastboot oem (un)lock "scary" warning?
    --> no, needs signed system (lineageos has signed system images).

    Logo: you have to flash it yourself. Take a look here. I used it on a op3t.
    You can flash the 'logo.bin' for your device from terminal (twrp) with a command like:

    dd if=logo.bin of=/dev/block/by-name/LOGO

    Be careful, check twice before you do it! You can brick your phone if something is wrong.

  • @gischpelino Thanks. Though that repository's README says it should be flashed with fastboot. Does it make a difference if I use dd instead of fastboot?

    Also, what do you mean with terminal (twrp)? Can I use a shell in Ubuntu Touch, or must I reboot to recovery and then use adb?

    There's no /dev/block/by-name/LOGO accessible from the OS, so I guess not.

  • I was eventually able to do it by booting to bootloader mode, running fastboot boot twrp.img, and running adb sideload from there.

    Then I downloaded the and ran adb sideload

    I was not able to run fastboot flash LOGO logo.bin, because I got the described FAILED (remote: Partition flashing is not allowed).

    Now I have a proper UBports logo. Great!

  • @the7thstranger inside twrp you can use the terminal and make it with dd. I told you to use dd because a flash logo using fastboot is not possible and I did not know, if there is a flashable zip available. Well done.

  • how to making system be rw?
    this guide need adb but adb doent work,anyother idea?

  • You can install ubuntu tweak tool ( from the open store, go to system and then chose rw, i think it should solve your problem

  • This post is deleted!

  • This post is deleted!

  • @ComLarsic said in Oneplus 3/3T:

    Hello, everyone. i am trying to install ubuntu touch on my device again using the ubports installer but i get this error:

    Error: systemimage: Error: Error: {"error":{"killed":false,"code":2,"signal":null,"cmd":"/tmp/.mount_ubporte14WRR/resources/app.asar.unpacked/platform-tools/linux/adb -P 5037 shell mount -a"},"stdout":"","stderr":"mount: mounting /dev/block/bootdevice/by-name/system on /system failed: Invalid argument\nmount: mounting /dev/block/bootdevice/by-name/userdata on /data failed: Invalid argument"}

    I am using the installer on manjaro 19.0
    is there any way to fix this?

    Hi @ComLarsic . Having the same issue. How did you format the system please? I've got fastboot running on my desktop, I guess I need to use that?

  • Did anyone has working hotspot connection? Hotspot is activating, but no internet connection, looks like problems with DNS etc.

  • @JimShady First flash TWRP from here using fastboot flash recovery twrp-3.4.0-0-oneplus3.img.

    Then run fastboot reboot recovery and format /system, /data and /cache as ext4 from TWRP. After that you can run the UBports installer again.

Log in to reply