Porting to Samsung Galaxy Note 4 SM-N910P

  • @doniks said in Porting to Samsung Galaxy Note 4 SM-N910P:

    again surrounded by QCOM_BSP

    @tigerpro are you still working on this port? I was reminded of this conversation by this: https://docs.ubports.com/en/latest/porting/installing-16-04.html#choose-a-rootfs there they are talking about CAF (Code Aurora Forum) in relation to this flag QCOM_BSP, maybe that CAF stuff is a lead for you?!

  • @doniks I actual put this on hold during the holidays, right now I'm trying to get a better emploent situation, but after that I'll start this project again. I never received an email saying I had a reply (weird but I'll check my settings on that) when I last tried to port Halium 7 I was trying to see if I could get the kernel output on the screen as logging it to a file didn't seem to be working properly with where it was hanging up. I haven't tried the ubports code in awhile, I will have to look into that link and see if there's any useful info in it. I also got one XDA user trying to help, I have to generate another log for him, and in return I'm trying to help him get a port for his devises working. I should have an update in a couple days with any luck.

  • So update time: (sorry for double posting)

    I had to start over due to a HDD crash, long story short I got Halium compiled again, since I managed to get it to compile, I figure might as well see if I can get it working before moving back to ubports 16 port, I installed Halium, go to boot it, and I seem to be having a boot failure with no telnet, the last_kmsg seems to indicate that Halium can't initialize /init, I'm wondering if my fixup_mountpoints script might be incorrect as I did "/dev/block/<partition>" instead of just the <partition>, as this time around when I followed the directions thats the output I got. I'll try switching the partition back to how I had it before, but I actually get the screen to blank itself now while trying to boot, something that did not happen prior to HDD crash. I am also helping a person create a Xiaomi land port of ubports, they have gotten quite far in their attempts so far. Has anyone successfully ported ubports 16 with their new porting guide?

  • @tigerpro I got Samsung S3 Neo to boot UT 16.04, yes. As a workaround you can also add your partition as /dev/block/mmcblk0pxx in the system image´s fstab file. instead of the mentioned userdata partition entry there.

  • @flohack thank you for the response, I will try adding that to my fstab, I'll report back any success or failure when I try it. One question that I have is, is this done in addition to the fstab work in the ubports guide or is this strictly Halium?

  • @tigerpro All porting efforts should be made with the Halium guide only now. Anything else you find might be outdated.

    See here: http://docs.halium.org/en/latest/porting/first-steps.html


  • @flohack is this guide up to date for ubports? It does mention Halium as well as state to get Halium to compile first


    Is the guide I'm referring to

  • @tigerpro

    That guide is correct.

    Source: I wrote it. 😛

  • @unisuperbox thank you for an updated guide, one question that I didn't see in the guide though, does Halium just have to compile, or does it have to boot as well?

  • @tigerpro the normal process is to get it running. However, keep in mind that porting is always a trial and error process. Nobody stops you from attempting UBports rootfs even though you might still have problems with halium rootfs. Equally well, nobody stops you from switching back and forth between the two

  • @doniks thank you doniks, I am currently trying to get it running, have an error with /init, haven't had a chance to try and fix it due to a recent family death, I'll keep ya posted

  • @tigerpro Sorry to hear. All the best!

  • @doniks thank you, I managed to get a test boot of my latest compile in, no change from the previous attempt, I think I have to modify my Mount points to get it working at this point. I'm going to redo that step and see if there's a change from this last attempt. I think if I can get a telnet or ssh interface I'm on the right track. I'm going to just mess with the data point for now to just speed up my attempts, once I get more successful results then I can apply it to the rest of the points.

  • @tigerpro solid plan! Yeah, telnet and ssh are important milestones and yes I think you need to do the fix mount points thing and yes I think the only partition you really need is the data partition.

    NB: the guys are working on an alternative to hybris-boot named halium-boot and somehow that will not need the fix mount points stuff, but I'm not sure how it works or whether it is fully fleshed out. I am personally holding off with trying halium-boot because it seems that there are just too many changes happening at once now and I want to wait until that stabilizes a bit.

  • @doniks oh, I did not know that, I will definitely have to keep an eye out for it. I agree waiting for the changes to be less sporadic is a good idea, otherwise you could end up compiling something that is outdated before you even finish compiling it, which gets annoying very quickly IMO. I'll let ya know how my next attempt goes, hopefully much better.

  • @tigerpro Are you in the Halium Telegram group yet?

  • @flohack I am not, I am however in the Halium IRC, although admittedly I have not looked at it in a few days

  • @tigerpro You definitely should, IRC is lacking screenshots and such features 😉 - The group is very busy sometimes, so I find it easier to follow also on Telegram. But it´s good you are connected already. This will be your main source for porting questions.

    I am working on S3 Neo port, so we can discuss common stuff like Heimdall and how to modify our install system to allow Samsung phones to be installed 😉


  • @flohack OK you can stop twisting my arm lol jk 😉 I signed up for telegram as well, I don't know of I'll be able to pay any more attention to it or not, but at least I'm now on it. I haven't had a chance to work on my data Mount point yet as I've been busy with family obligations, but I do intend to look at it in the coming days.

  • So an update, I compiled halium-boot, which successfully boots, loads Ubuntu gives me ssh, but the phone stays on the power on screen. I do have a few tips to try and fix it, but I am at least making progress, then I managed to break my ssh access so now I gotta fix that before I can move forward. The problem I get is that when I assign a IP on my developer machine, it gives me a "no route to host" error, and with lsusb it says google device for my phone I stead of Sony device, not sure its related but it is all I can find for clues to whether or not it will let me connect.

Log in to reply