Need help for porting to xiaomi 4 cancro



  • @doniks I said that if use multirom can mount ubuntu system files and create three runtime-related folders (including: android-data system-data user-data). Without multirom. Did not create those three folders. I do not know if I have not successfully mounted ubuntu system (system.img). When not multirom, can not boot to the boot animation. Nor is the bootloop. Temporarily I still can not get the log without multirom



  • @doniks I get dmesg without multirom,I got dmesg use this : https://github.com/ubports/ubports-boot
    https://github.com/kuailexs/porting-log/blob/master/dmesg-withoutmultirom
    Please help me to see



  • I see you have syspart on the kernel's cmdline, but not datapart (if that's still used in ubports-boot), if this is still used then that may be the reason why it's not creating your data directories. However system-data should be created by the rootfs (it contains overrides for certain items in directories on the system image like /etc/init/*.override, /var, etc.)

    MultiROM doesn't create these folders specifically, that's done by system-image-upgrader during installation of the Ubuntu Touch rootfs. So ensure that you have a valid Ubuntu Touch rootfs on your device, system.img should be in /data and I think ubuntu.img as well (not sure, I mainly use MultiROM with my Nexus 7). Other than that, It looks like your ramdisk is booting and running properly, at least to me. You may wish to remove the breakpoint from the kernel cmdline and get the last_kmsg from recovery instead to get a more full, detailed log including what happens after the ramdisk's execution (which isn't shown in your log as the ramdisk pauses it's init execution for the breakpoint).

    I would suggest letting the system sit for about 1 minute before rebooting over to recovery to do this, do note that to see the Ubuntu logs, you MUST start into recovery right after rebooting the system, it MUST NOT attempt to start anything but recovery or you'll find yourself with a different log file (for instance, the recovery image will rewrite the last_kmsg with it's own if it was the last thing to start up before a reboot). So if you can do an adb reboot recovery, or a reboot recovery from your ramdisk to boot into recovery, that will help a ton!

    To get the last_kmsg from recovery:

    • Ensure you boot straight into recovery after rebooting the system from it's boot animation.
    1. Once the device is in recovery and plugged into the machine, simply type adb pull /proc/last_kmsg.

    There you go. This should help since any of us attempting to assist can see the messages from past the ramdisk (your current log only shows the end of the ramdisk startup, but not Ubuntu's startup which is what we want.)

    Though those Kernel oops in the log (you can find these with the --- cut here --- style lines) could have something to do with things, but it looks like the only issues are with a crypto driver for the platform not being able to create a sysfs entry (not sure if qcrypto.0 is essential to your platform or not), though I don't have this device myself, so I can't give you an answer there.

    EDIT: I also noticed this interesting line in the logs, I'm not sure what it is though [system] Activated service 'com.canonical.SystemImage' failed: Launcher could not run (out of memory)

    This may be why your system isn't starting.



  • @Tonoxis
    No breakpoint, no way to get any log. Can not restart.black screen. More than five drive letters on the computer. Can only be forced to shut down. Can not get last_kmsg
    0_1512445460349_ff1b97df-2335-454e-98df-ce5294708b7b-图片.png



  • @doniks Good news. Now it can boot up. thank you for your help



  • @Tonoxis Good news. Now it can boot up. thank you for your help



  • 0_1512518646384_1ca35734-46a4-4576-98be-9c10014f69be-图片.png /media/feifei/linux/68606daaac13f3f4.jpg



  • Great news! What did you change to have it boot up (for future reference)? Was it the datapart kernel cmdline variable? As for the 5 volumes appearing in Nautilus, you may have entered QCOM_DL. If you're entering QCOM_DL while attempting to get into recovery, that means your recovery image is bad and needs re-flashed.



  • @Tonoxis The reason is that there is no 'ro.product.device=cancro' in build.prop, not loading 70-cancro.rules



  • @kuailexs Ah wonderful! Glad it was something minor instead of something huge!


  • Infrastructure

    @kuailexs Excellent Xie-Xie!

    Can you tell us what works:

    Boot - OK
    Bluetooth
    Camera
    Cellular Radio
    GPS
    Graphics
    Resume
    Rotation
    Sound
    Touch
    Wifi

    These are the main features we need to call it a good port. Good Luck!

    BR



  • @Flohack Most do not work

    Boot - OK
    Bluetooth
    Camera
    Cellular Radio
    GPS
    Graphics - OK
    Resume
    Rotation
    Sound - OK
    Touch - OK
    Wifi


  • Infrastructure

    Yeah this is expected but its a good progress already ;)

    BR Florian



  • @Flohack Please help me to see the log
    https://github.com/kuailexs/porting-log


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.