Ota-12 Teleports launcher bar Icon always Shows unread messages



  • yes it happens after the OTA-12 update.
    I did the following to fix it:

    • simple reboot
    • unpin / repin
    • unpin / reboot / repin
      but nothing works
      After rebooting all looks good, but if you start the App, the issue is there


  • Maybe an archived chat with unread messages?



  • If there are unread messages they are being reported by the underlying tdlib component which is a 3rd party library we directly use from upstream Telegram developers. TELEports just sums up what it gets from it, we cannot really do much about it. As @AppLee said it might be an archived chat that you cannot see on TELEports right now - did you compare with the desktop app, whats shown there?

    Another case is when you would leave a conversation (group, chat) with unread messages, they might get stuck there. Did you do this?

    I am using TELEports quite heavily but never ran into this issue. If you want to go the easier way, use the UT tweak tool and delete all app data, then re-register the device and see again if you hit those unreads.



  • The Desktop App shows none unread messages only the OPO, the issue occures directly after I did the OTA-12 update.
    re-register the device and using the UT Tweak Tool didn#t help
    maybe I've left a conversation or a group with unread messages, don't know 😃



  • Another data point: I see two (or more) unread on my M10, but none on N5 or desktop.

    @Flohack Any useful investigating I can do?



  • @alan_g we store unread message counters in a database in the teleports data directory: ~/.local/share/teleports.ubports/teleports.ubports/auxdb/auxdb.sqlite. Would be interesting to see if that really has that number in it, there is a column in the table chatlist_map called unread_messages. And also, if this column is set to 0 for all entries, if the problem comes back.

    BR



  • HI, I got it! 😃

    • Copied the auxdb.sqlite to my PC
    • Opened it with SqliteBrowser
    • and set 3 Values (with 5, 2 and 2 messages) in the unread_messages column to 0
    • copied the auxdb.sqlite back to my OPO
      and now it works!!
      thanx !!!!!


  • @Torkel67 that would tell me you are no longer member of these chats, can it be? Did you exit chats or conversations recently? I can see now we need to improve the handling in this case.



  • @Torkel67 Thank you it worked for me too (didn't left any chat recently).



  • @Flohack ervey Chat, Group or Channel I was in before manipulating the DB is still there, if you mean that!
    And of course I frequently add channels or groups to check out if they fit my needs and exit them if not, don't careing about unread messages in it.
    T



  • @Torkel67 said in Ota-12 Teleports launcher bar Icon always Shows unread messages:

    exit them if not, don't careing about unread messages in it

    That is probably the cause as @Flohack mentioned.
    Unread messages in left groups will stay this way with the current design if I understand correctly.
    Seems different though for @Capsia ...


Log in to reply